Bug 316149 - gwenview crash on start
Summary: gwenview crash on start
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 2.9.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-05 00:31 UTC by useful
Modified: 2013-03-05 11:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description useful 2013-03-05 00:31:24 UTC
Application: gwenview (2.9.4)
KDE Platform Version: 4.9.4
Qt Version: 4.8.3
Operating System: Linux 3.5.0-23-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:
started 'gwenview' from the command line (tmux session; zsh)

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f0de595b425 in __GI_raise (sig=<optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f0de595eb8b in __GI_abort () at abort.c:91
#8  0x00007f0de7cf84c2 in qt_message_output (msgType=<optimized out>, buf=0x11801c8 "gwenview(13116)/kdeui (kdelibs): Session bus not found \nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch) ") at global/qglobal.cpp:2290
#9  0x00007f0de729e316 in QDebug::~QDebug (this=0x7fffb84f74a0, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#10 0x00007f0de737aa67 in KApplicationPrivate::init (this=0x10c5270, GUIenabled=GUIenabled@entry=true) at ../../kdeui/kernel/kapplication.cpp:516
#11 0x00007f0de737ba38 in KApplication::KApplication (this=0x7fffb84f77d0, GUIenabled=true) at ../../kdeui/kernel/kapplication.cpp:352
#12 0x00000000004272ad in main (argc=1, argv=0x7fffb84f7938) at ../../app/main.cpp:132

Possible duplicates by query: bug 314342, bug 306037, bug 301897, bug 300838.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-03-05 11:28:27 UTC
You need a working session D-Bus to run KDE applications. If your session does not start it automatically, you have to start it manually. Please ask in a user support forum of your distribution, how to start the sesseion D-Bus.

*** This bug has been marked as a duplicate of bug 270442 ***