Bug 283935 - Akonadi Agent crashes few minutes after system start-up.
Summary: Akonadi Agent crashes few minutes after system start-up.
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdeui (show other bugs)
Version: 4.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-13 18:43 UTC by albert
Modified: 2011-10-14 01:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description albert 2011-10-13 18:43:19 UTC
Application: akonadi_nepomuk_calendar_feeder (4.7)
KDE Platform Version: 4.7.1 (4.7.1)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Few minutes after system start-up, Akonadi Agent crashes. Moreover the whole KDE
 session is teared down and a new one is started.

The crash can be reproduced every time.

-- Backtrace:
Application: Akonadi Agent (akonadi_nepomuk_calendar_feeder), signal: Aborted
[KCrash Handler]
#6  0x00007fa32249e3a5 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007fa3224a1b0b in __GI_abort () at abort.c:92
#8  0x00007fa32495643b in qt_message_output (msgType=<optimized out>, buf=0x1086f28 "akonadi_nepomuk_calendar_feeder(2119)/kdeui (kdelibs): Session bus not found \nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch) ") at global/qglobal.cpp:2315
#9  0x00007fa3257c728d in ~QDebug (this=0x7fff998f1e40, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#10 QDebug::~QDebug (this=0x7fff998f1e40, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qdebug.h:81
#11 0x00007fa3258b066b in KApplicationPrivate::init (this=0xfe34a0, GUIenabled=<optimized out>) at ../../kdeui/kernel/kapplication.cpp:516
#12 0x00007fa3258b16e8 in KApplication::KApplication (this=0x7fff998f1fe0, GUIenabled=true) at ../../kdeui/kernel/kapplication.cpp:352
#13 0x000000000040d833 in Akonadi::AgentBase::init<Akonadi::NepomukCalendarFeeder> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/agentbase.h:334
#14 0x00007fa32248930d in __libc_start_main (main=0x409440 <main(int, char**)>, argc=3, ubp_av=0x7fff998f20f8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff998f20e8) at libc-start.c:226
#15 0x0000000000409471 in _start ()

Possible duplicates by query: bug 264758, bug 255169, bug 253675, bug 253674, bug 237928.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-10-14 00:54:24 UTC
The crash is the result of this, not the cause:

Session
bus not found \nTo circumvent this problem try the following command (with
Linux and bash) \nexport $(dbus-launch) ")
Comment 2 Christoph Feck 2011-10-14 01:03:22 UTC

*** This bug has been marked as a duplicate of bug 270442 ***