Bug 364619 - kcm_grub2 editor stopped working in Fedora 24
Summary: kcm_grub2 editor stopped working in Fedora 24
Status: RESOLVED DUPLICATE of bug 270442
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_grub2 (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konstantinos Smanis
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-06-22 01:09 UTC by George Seaton
Modified: 2022-09-20 04:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description George Seaton 2016-06-22 01:09:10 UTC
Application: kcmshell4 (4.14.19)
KDE Platform Version: 4.14.20
Qt Version: 4.8.7
Operating System: Linux 4.5.7-300.fc24.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:
trying to start kcm_grub2  grub2 editor in Fedora 24

- Unusual behavior I noticed:
On initial startup utility window opens but is completely blank.
seems to be dbus errors

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Control Module (kcmshell4), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f95e5ae76f5 in raise () at /lib64/libc.so.6
#7  0x00007f95e5ae92fa in abort () at /lib64/libc.so.6
#8  0x00007f95e28c0d04 in _dbus_abort () at /lib64/libdbus-1.so.3
#9  0x00007f95e28b773c in  () at /lib64/libdbus-1.so.3
#10 0x00007f95e28a7c82 in dbus_message_new_method_call () at /lib64/libdbus-1.so.3
#11 0x00007f95e7df22c8 in QDBusMessagePrivate::toDBusMessage(QDBusMessage const&, QFlags<QDBusConnection::ConnectionCapability>, QDBusError*) () at /lib64/libQtDBus.so.4
#12 0x00007f95e7ded8ba in QDBusConnectionPrivate::sendWithReply(QDBusMessage const&, int, int) () at /lib64/libQtDBus.so.4
#13 0x00007f95e7defbd7 in QDBusConnectionPrivate::findMetaObject(QString const&, QString const&, QString const&, QDBusError&) () at /lib64/libQtDBus.so.4
#14 0x00007f95e7dfcc4b in QDBusInterfacePrivate::QDBusInterfacePrivate(QString const&, QString const&, QString const&, QDBusConnection const&) () at /lib64/libQtDBus.so.4
#15 0x00007f95e7dfcd95 in QDBusInterface::QDBusInterface(QString const&, QString const&, QString const&, QDBusConnection const&, QObject*) () at /lib64/libQtDBus.so.4
#16 0x00007f95e8eb7047 in KCMShell::isRunning() () at /lib64/libkdeinit4_kcmshell4.so
#17 0x00007f95e8eb890f in kdemain () at /lib64/libkdeinit4_kcmshell4.so
#18 0x00007f95e5ad3731 in __libc_start_main () at /lib64/libc.so.6
#19 0x000055e1fe6dc8e9 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2016-06-26 04:17:14 UTC
Please start it with "kdesu", not "su". The latter does not setup a DBus session.

*** This bug has been marked as a duplicate of bug 270442 ***