Bug 130630 - "ICQ server thinks the client you are using is too old"
Summary: "ICQ server thinks the client you are using is too old"
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal with 6 votes (vote)
Target Milestone: ---
Assignee: Roman Jarosz
URL:
Keywords:
: 130632 130636 130639 130641 130642 130645 130653 130655 130656 130659 130663 130669 130673 130685 130688 130703 130708 130715 130719 130757 131210 131599 131636 131700 131709 131713 131778 131813 131847 133109 133877 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-07-11 17:50 UTC by Revasser
Modified: 2006-09-20 04:15 UTC (History)
31 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New patch (581 bytes, patch)
2006-07-31 18:34 UTC, Roman Jarosz
Details
version info updater commit 568881 (26.54 KB, patch)
2006-08-02 20:12 UTC, Roman Jarosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Revasser 2006-07-11 17:50:11 UTC
Version:           0.12.0 (using KDE KDE 3.4.2)
Installed from:    SuSE RPMs
OS:                Linux

"The ICQ server thinks the client you are using is too old. Please report this as a bug at http://bugs.kde.org."

That's what it said so that's what I did.
Comment 1 Iuri Fiedoruk 2006-07-11 17:52:18 UTC
I just got it also.
I thinbk that AOL changed something on ICQ servers and is demanding a recent protocol implementation (v9 maybe?)
Comment 2 CaCO3 2006-07-11 18:00:08 UTC
I also have this message.
I installed V0.12 before some days and since then, i logged in many times until now, as this message cames up.
Comment 3 Michael 2006-07-11 18:04:56 UTC
SIM works just fine, but looking at the packet - I don't see it sending any version information, as kopete does
Comment 4 Andre Duffeck 2006-07-11 18:13:24 UTC
*** Bug 130632 has been marked as a duplicate of this bug. ***
Comment 5 Roman Jarosz 2006-07-11 18:38:02 UTC
SVN commit 560990 by rjarosz:

fix bug 130630 "ICQ server thinks the client you are using is too old"

BUG: 130630



 M  +2 -2      oscartypes.h  


--- branches/kopete/0.12/kopete/protocols/oscar/liboscar/oscartypes.h #560989:560990
@@ -237,9 +237,9 @@
 	const char ICQ_CLIENTSTRING[] 		= "ICQBasic";
 	const WORD ICQ_CLIENTID 		= 0x010A;
 	const WORD ICQ_MAJOR 			= 0x0014;
-	const WORD ICQ_MINOR 			= 0x0022;
+	const WORD ICQ_MINOR 			= 0x0034;
 	const WORD ICQ_POINT 			= 0x0000;
-	const WORD ICQ_BUILD 			= 0x0911;
+	const WORD ICQ_BUILD 			= 0x0A0F;
 	const char ICQ_OTHER[] 			= { 0x00, 0x00, 0x04, 0x3d };
 	const char ICQ_COUNTRY[] 		= "us";
 	const char ICQ_LANG[] 			= "en";
Comment 6 Andre Duffeck 2006-07-11 18:57:43 UTC
*** Bug 130636 has been marked as a duplicate of this bug. ***
Comment 7 Bram Schoenmakers 2006-07-11 19:03:34 UTC
Please backport to the 3.5 branch!
Comment 8 CaCO3 2006-07-11 19:07:59 UTC
How long will it go to compile it by myself?
I'm running make at my machine since 10 minutes without seeing an end.
(Thinkpad R40, i686 1.5GHz, 756MB RAM, KDE 3.5.3, Kernel 2.6.15)
Comment 9 Roman Jarosz 2006-07-11 19:15:52 UTC
George Ruinelli on amd 2000XP it takes half an hour.

Bram Schoenmakers will backport it if it doesn't work there because there is diffrent version. Need to compile and test it first
Comment 10 CaCO3 2006-07-11 19:28:51 UTC
Ok, thank you (for your quick answer and also for your quick bugfix!).

It now finished (needed only ca. 30minutes).
And icq works now again!

A debian-package could (in a few minutes) be downloaded from http://ruinelli.ch/archiv#Debian-Pakete
Comment 11 Revasser 2006-07-11 19:54:14 UTC
A quick edit and recompile and Kopete is logging onto ICQ once again.

Thanks for the quick fix!
Comment 12 Roman Jarosz 2006-07-11 20:01:03 UTC
SVN commit 561016 by rjarosz:

Backport fix for bug 130630 "ICQ server thinks the client you are using is too old"

CCBUG: 130630



 M  +6 -6      oscartypes.h  


--- branches/KDE/3.5/kdenetwork/kopete/protocols/oscar/liboscar/oscartypes.h #561015:561016
@@ -232,13 +232,13 @@
 
 	/* ICQ Version Characteristics */
 	const unsigned char ICQ_TCP_VERSION 	= 0x0008;
-	const char ICQ_CLIENTSTRING[] 		= "ICQ Inc. - Product of ICQ (TM).2003a.5.45.1.3777.85";
+	const char ICQ_CLIENTSTRING[] 		= "ICQBasic";
 	const WORD ICQ_CLIENTID 		= 0x010A;
-	const WORD ICQ_MAJOR 			= 0x0005;
-	const WORD ICQ_MINOR 			= 0x002D;
-	const WORD ICQ_POINT 			= 0x0001;
-	const WORD ICQ_BUILD 			= 0x0EC1;
-	const char ICQ_OTHER[] 			= { 0x00, 0x00, 0x00, 0x55 };
+	const WORD ICQ_MAJOR 			= 0x0014;
+	const WORD ICQ_MINOR 			= 0x0034;
+	const WORD ICQ_POINT 			= 0x0000;
+	const WORD ICQ_BUILD 			= 0x0A0F;
+	const char ICQ_OTHER[] 			= { 0x00, 0x00, 0x04, 0x3d };
 	const char ICQ_COUNTRY[] 		= "us";
 	const char ICQ_LANG[] 			= "en";
 
Comment 13 Roman Jarosz 2006-07-11 20:04:23 UTC
*** Bug 130639 has been marked as a duplicate of this bug. ***
Comment 14 Roman Jarosz 2006-07-11 20:43:13 UTC
*** Bug 130642 has been marked as a duplicate of this bug. ***
Comment 15 Roman Jarosz 2006-07-11 20:43:44 UTC
*** Bug 130641 has been marked as a duplicate of this bug. ***
Comment 16 Roman Jarosz 2006-07-11 21:00:00 UTC
*** Bug 130645 has been marked as a duplicate of this bug. ***
Comment 17 Stefan Borggraefe 2006-07-11 22:04:35 UTC
*** Bug 130653 has been marked as a duplicate of this bug. ***
Comment 18 Andre Duffeck 2006-07-11 22:31:14 UTC
*** Bug 130655 has been marked as a duplicate of this bug. ***
Comment 19 Det 2006-07-11 22:58:53 UTC
I'm very sorry but I cannot see here the resolution, how the problem is fixed? What's to do for me so that I can use kopete with ICQ again?
Comment 20 Conrad Hoffmann 2006-07-11 23:02:10 UTC
*** Bug 130656 has been marked as a duplicate of this bug. ***
Comment 21 Conrad Hoffmann 2006-07-11 23:07:02 UTC
*** Bug 130659 has been marked as a duplicate of this bug. ***
Comment 22 Roman Jarosz 2006-07-11 23:07:48 UTC
Det you need to compile it from SVN or wait for update from your distribution.

for compilation follow this:
svn co svn://anonsvn.kde.org/home/kde/branches/kopete/0.12
cd 0.12
make -f Makefile.cvs
./configure
cd kopete
make
su -c "make install"
Comment 23 Conrad Hoffmann 2006-07-11 23:09:49 UTC
*** Bug 130658 has been marked as a duplicate of this bug. ***
Comment 24 Conrad Hoffmann 2006-07-11 23:24:28 UTC
There seems to be a fixed .deb at http://bugs.kde.org/show_bug.cgi?id=130656#c4
Comment 25 Roman Jarosz 2006-07-11 23:25:21 UTC
Florian Schmid made a fixedversion for Debian. Also works with Dapper (checkinstall). 

http://ruinelli.ch/archiv#Debian-Pakete

A big thanks to him.

In gentoo fixed version is net-im/kopete-0.12.0-r2
Comment 26 Conrad Hoffmann 2006-07-12 00:03:01 UTC
*** Bug 130663 has been marked as a duplicate of this bug. ***
Comment 27 Det 2006-07-12 01:01:01 UTC
Many thanks to Roman. Now it's working fine again.
Comment 28 liam24 2006-07-12 03:23:31 UTC
I tried the svn with jingle enabled and it gave me errors.
Comment 29 Andre Duffeck 2006-07-12 08:40:31 UTC
*** Bug 130673 has been marked as a duplicate of this bug. ***
Comment 30 Andre Duffeck 2006-07-12 08:40:58 UTC
*** Bug 130669 has been marked as a duplicate of this bug. ***
Comment 31 Roman Jarosz 2006-07-12 09:08:21 UTC
liam24 you probably don't have some libraries, please look at http://wiki.kde.org/tiki-index.php?page=Kopete+Jabber+Jingle

If you still need help come to kopete irc channnel in the freenode IRC Network.
Comment 32 Jens Rutschmann 2006-07-12 10:57:50 UTC
Just some ideas:

Maybe the protocol version numbers should be specified in the configuration file rather than being hard coded in Kopete.
I mean, nowbody knows how often this will happen again. 

In a first version you could just read those settings from the config file and change them there. This would be a lot more quick and comfortable than compiling the whole program again and again.

Later  perhaps a mechanism could be implemented to get the latest version numbers from the Kopete homepage whenever the ICQ servers deny access again. Instead of the passive popup that is coming up currently, the user could be asked if he wants to update the version information with the data from the Kopete homepage.
Comment 33 Roman Jarosz 2006-07-12 11:07:24 UTC
*** Bug 130685 has been marked as a duplicate of this bug. ***
Comment 34 Olivier Goffart 2006-07-12 12:17:23 UTC
As workaround, if you don't want to upgrade, you can use Jabber transports (that have been improved in Kopete 0.12)
http://wiki.kde.org/tiki-index.php?page=Kopete+Jabber+Transport
Comment 35 Claude Herrmann 2006-07-12 12:20:28 UTC
I have a problem building from cvs.
My autoconf is version "autoconf (GNU Autoconf) 2.59" yet the "make -f Makefile.cvs" command tells me "*** AUTOCONF NOT FOUND!.
*** KDE requires autoconf 2.53 or newer"
Comment 36 Roman Jarosz 2006-07-12 12:23:31 UTC
Check if you have also automake
Comment 37 Roman Jarosz 2006-07-12 12:52:40 UTC
*** Bug 130688 has been marked as a duplicate of this bug. ***
Comment 38 liam24 2006-07-12 14:33:18 UTC
Roman, thanks for the reply. I have all the libraries listed on that site. here is the error I get when I do a Make

Collect2: ld returned 1 exit status
Error creating ./kopete/protocols/jabber/kopete_jabber.la. Exit status 1.
make: *** [all] Error 1
Comment 39 Roman Jarosz 2006-07-12 14:44:37 UTC
liam24, I never tried compiling kopete with jingle support.
Please ask in kopete channel on freenode.net.
Comment 40 baum-im-wald 2006-07-12 15:05:13 UTC
Found a fixed package for Kubuntu Dapper x86 here:

http://www.kde-apps.org/content/show.php?content=41143
Comment 41 Will Stephenson 2006-07-12 16:05:27 UTC
I've updated the suse packages in the build service: 
Repository URLs are:
http://repos.opensuse.org/KDE:/KDE3/
http://repos.opensuse.org/KDE:/Backports/

Masochists can navigate in there and install by hand.  I'll have a Yast Online update out in the next couple of days.
Comment 42 Roman Jarosz 2006-07-12 16:17:32 UTC
*** Bug 130703 has been marked as a duplicate of this bug. ***
Comment 43 Roman Jarosz 2006-07-12 17:51:33 UTC
*** Bug 130708 has been marked as a duplicate of this bug. ***
Comment 44 Michael 2006-07-12 18:54:16 UTC
Supporting Jens Rutschmann, I think it would be a great thing... especially for these oscar/msn/yahoo closed protocols
Comment 45 Mathias 2006-07-12 19:18:23 UTC
I have some missing libraries Jingle, XMMS... Any locations for a fixed SUSE RPM?
Comment 46 Stefan Borggraefe 2006-07-12 20:12:40 UTC
*** Bug 130715 has been marked as a duplicate of this bug. ***
Comment 47 Roman Jarosz 2006-07-12 20:33:14 UTC
*** Bug 130719 has been marked as a duplicate of this bug. ***
Comment 48 Roman Jarosz 2006-07-13 10:39:27 UTC
*** Bug 130757 has been marked as a duplicate of this bug. ***
Comment 49 Caligo Spiritus 2006-07-16 14:18:49 UTC
The deb of Mr. Runelli is working, but have a Huge problem - it's version in system appears 0.12.0-1 and in Debian Etch (for example) it must be 4:3.5.3-1
Comment 50 Bartosz Fabianowski 2006-07-22 17:04:53 UTC
*** Bug 131210 has been marked as a duplicate of this bug. ***
Comment 51 Ildar Nurislamov 2006-07-31 18:28:13 UTC
This bug is actual again :(
Comment 52 Roman Jarosz 2006-07-31 18:34:20 UTC
Created attachment 17185 [details]
New patch
Comment 53 Roman Jarosz 2006-07-31 18:42:32 UTC
SVN commit 568263 by rjarosz:

Fix for The ICQ server thinks your client is too old

CCBUG: 130630



 M  +1 -1      oscartypes.h  


--- branches/KDE/3.5/kdenetwork/kopete/protocols/oscar/liboscar/oscartypes.h #568262:568263
@@ -237,7 +237,7 @@
 	const WORD ICQ_MAJOR 			= 0x0014;
 	const WORD ICQ_MINOR 			= 0x0034;
 	const WORD ICQ_POINT 			= 0x0000;
-	const WORD ICQ_BUILD 			= 0x0A0F;
+	const WORD ICQ_BUILD 			= 0x0BB8;
 	const char ICQ_OTHER[] 			= { 0x00, 0x00, 0x04, 0x3d };
 	const char ICQ_COUNTRY[] 		= "us";
 	const char ICQ_LANG[] 			= "en";
Comment 54 Andreas Pietzowski 2006-07-31 18:50:00 UTC
This is now the second time that this message appears and I know that actually ICQ is the bad party which tries to fool 3rd party clients. But why can clients like Trillian and GAIM cope with these protocol changes without recompiling?

Would be interesting whats the difference with kopete. Thanks for information.

Have a nice day
Andreas
Comment 55 Alejandro Diaz Caro 2006-07-31 19:00:51 UTC
I don't understand, I didn't change anything and today my ICQ is working in the 0.12.0 version.
Comment 56 Alejandro Diaz Caro 2006-07-31 19:04:56 UTC
In addition, my KDE is the 3.5.3, maybe this is the key (some library?)
Comment 57 Andreas Kling 2006-07-31 19:09:17 UTC
*** Bug 131598 has been marked as a duplicate of this bug. ***
Comment 58 Andreas Kling 2006-07-31 19:09:22 UTC
*** Bug 131599 has been marked as a duplicate of this bug. ***
Comment 59 Mathias Homann 2006-07-31 20:32:09 UTC
i guess "other" clients increase their internal build number when they get booted with the "client too old" reason, then reconnect, repeat until !fail, then store the build number that worked in the ini file.
Comment 60 Andreas Pietzowski 2006-07-31 20:50:11 UTC
When it is really an only incrementing integer then you just postet the solution of our kopete-ICQ problem, right? Or does someone have connections to the GAIM developers or is someone involved in the programming of that client to find out their solution?

In my opinion a patch every one and then is not the solution. What do you think?
Comment 61 Mathias Homann 2006-07-31 22:16:15 UTC
re #60: gaim is open source, too.... someone with more understanding than me should just look at it.
licq also works with icq right now, with no errors... and my licq version is 6 weeks old.
Comment 62 Mathias Homann 2006-07-31 22:19:26 UTC
but i think the "centralized database of working client version numbers" is another good idea. just have it store FAILED versions as well, so that everyone who fails to connect reports it to the database as well; narrows down the hunt for working numbers, as well as shows mirabilis that they cant lock out other OSes.
Comment 63 Roman Jarosz 2006-07-31 22:23:10 UTC
Gaim use version of ICQ PRO, but when I was implementing buddy icons they didn't work when we identify Kopete as old pro client.

I'm working on fix that will allow change version without recompilation.
Comment 64 johnvand 2006-07-31 22:25:10 UTC
This is the error I got as well - seems like a lot of us have gotten this bug.  It might help to tell you that I just this minute received and installed a Kopete update, installed automatically.  Kopete worked fine before this.
Comment 65 Yuriy Apostol 2006-08-01 08:26:23 UTC
In message at 31 juli 2006 21:50 Andreas Pietzowski:
[bugs.kde.org quoted mail]

I do't know. I use now another distributive, kubuntu, and not have problem  
with kopete.
Comment 66 Andreas Kling 2006-08-01 09:42:54 UTC
*** Bug 131636 has been marked as a duplicate of this bug. ***
Comment 67 Edwin Boersma 2006-08-01 11:06:05 UTC
Request re-open. Message is back since 1st of August.
Comment 68 Cyrill Helg 2006-08-01 11:32:27 UTC
Yes I agree but not since the swiss national holiday, here it was already one day before. Please tell us how to fix as soon as possible :)
Comment 69 Roman Jarosz 2006-08-01 11:45:07 UTC
You have to recompile it with this http://bugs.kde.org/attachment.cgi?id=17185&action=view patch 
Comment 70 Ana 2006-08-01 12:46:04 UTC
I installed LICQ instead. 
After installing the packages from Mr. Ruinelli it still doesn't work. 
Also, Adept Package manager finds an update for Kopete, but still nothing happens. What to do??
Comment 71 Roman Jarosz 2006-08-01 13:21:06 UTC
Ana: the package from Mr Ruinelli is for old fix. The icq blocked older versions again 31.7.2006 so you have to recompile kopete with new patch.

I'm working on autoupdate stuff hopefully it will be ready today so than these problem will go away.
Comment 72 arne anka 2006-08-01 13:40:24 UTC
well, if simply changing a version-number inside kopete satisfies those guys at icq -- why not making this changeable from inside kopete or at least a config-file instead of patching and recompiling?
Comment 73 Florian Schmid 2006-08-01 13:49:30 UTC
I did a package for Ubuntu Dapper, maybe it works also with Debian.

Needs speex an KDE 3.5.3, cause of Jingle-Support.

http://www.floyd-online.com/Download/kopete_0.12.1.1-1_i386.deb
Comment 74 Roman Jarosz 2006-08-01 13:52:27 UTC
arne anka I'm working on that
Comment 75 arne anka 2006-08-01 14:38:25 UTC
made a debian/unstable package 3.5.4-1 with the patch mentioned in #69 (mostly for myself) and put it up to

http://www.ginguppin.de/kopete_3.5.4-1_i386.deb

hopefully you guys will not spoil my download-limit ;-)
Comment 76 arne anka 2006-08-01 14:40:26 UTC
ps: it's kopete 0.11.3 -- don't know why the debian-name does not reflect that
Comment 77 Sebastian Kosch 2006-08-01 16:36:15 UTC
Thanks a lot for the compiling, Florian. That saves me another half an hour!
I was just about to open another bug report when I saw this one. Isn't it incredible what can happen when somebody at ICQ Inc. changes a little version number in some server database? loool

Sebastian
Comment 78 Florian Schmid 2006-08-01 16:52:56 UTC
No problem. But i forgot a thing.
If you want to use Jabber with my package you need to have ortp 0.7.1 installed.

So I made a .deb with it. worked under Dapper.
http://www.floyd-online.com/Download/ortp_0.7.1-1_i386.deb 
Comment 79 Andreas Kling 2006-08-01 20:34:42 UTC
*** Bug 131680 has been marked as a duplicate of this bug. ***
Comment 80 Florian Schmid 2006-08-02 00:09:11 UTC
I messed up something with the versions in the package posted below. So Dapper wants to update the new, fixed Kopete. Uploaded a version with the correct Versionnumber, so that this problem should be solved.

http://www.floyd-online.com/Download/kopete_4:3.5.3-0ubuntu0.5-1_i386.deb

You also need this:
http://www.floyd-online.com/Download/ortp_0.7.1-1_i386.deb 
and speex installes (should be universal)
Hope it helps.
Comment 81 Christian Tessarek 2006-08-02 02:01:50 UTC
rather late, but at least now, there is an updated kdenetwork-rpm for Fedora5/i386 (with its source rpm along). it contains kopete-0.12.1-release with the patched oscartypes.h. you can simply use it with rpm -Uvh, replacing the original fedora package. i hope it helps :-)

http://crystal.cnetworks.ath.cx/linux/software/
Comment 82 Bartosz Fabianowski 2006-08-02 02:12:31 UTC
*** Bug 131700 has been marked as a duplicate of this bug. ***
Comment 83 Andreas Kling 2006-08-02 10:23:52 UTC
*** Bug 131709 has been marked as a duplicate of this bug. ***
Comment 84 Bartosz Fabianowski 2006-08-02 12:13:38 UTC
*** Bug 131713 has been marked as a duplicate of this bug. ***
Comment 85 Roman Jarosz 2006-08-02 16:09:09 UTC
SVN commit 568881 by rjarosz:

add version info updater
- version info for icq/aim is stored in kopeterc config
- kopete automatically downloads new version from kopete.kde.org if login fails with "client too old" :)

CCBUG: 130630
CCBUG: 131598



 M  +2 -1      Makefile.am  
 M  +1 -0      aim/aimaccount.cpp  
 M  +1 -0      icq/icqaccount.cpp  
 M  +11 -9     liboscar/aimlogintask.cpp  
 M  +11 -0     liboscar/client.cpp  
 M  +6 -0      liboscar/client.h  
 M  +5 -0      liboscar/connection.cpp  
 M  +1 -0      liboscar/connection.h  
 M  +14 -12    liboscar/icqlogintask.cpp  
 M  +13 -18    liboscar/oscartypes.h  
 M  +31 -3     oscaraccount.cpp  
 M  +2 -0      oscaraccount.h  
 A             oscarversionupdater.cpp   [License: GPL (v2+)]
 A             oscarversionupdater.h   [License: GPL (v2+)]
Comment 86 Mathias Homann 2006-08-02 19:59:58 UTC
can someone wrap up svn commit 568881 into a .diff file?
Comment 87 Roman Jarosz 2006-08-02 20:12:49 UTC
Created attachment 17205 [details]
version info updater commit 568881

Kopete 0.12.2 will be released soon so if you want to do packages than maybe
wait till it's released.
Comment 88 Ben Aceler 2006-08-03 08:17:06 UTC
Just an idea.
Kopete can download new identification string directly from kopete.kde.org.
For example: when "Your client is too old" error will occur, kopete doqwnloads a file from kopete.kde.org/icqrc or something similar, and try to connect again.
Comment 89 Roman Jarosz 2006-08-03 11:40:47 UTC
Ben, the idea is already implemented :) commit 568881
Comment 90 Andreas Kling 2006-08-03 15:01:43 UTC
*** Bug 131778 has been marked as a duplicate of this bug. ***
Comment 91 Dominik Karall 2006-08-03 17:52:05 UTC
But can anybody tell me why gaim doesn't need such a thing and works withouth problems? I don't know, but are there big differences between the implementation in gaim and kopete? Because IMHO such problems mostly occure with kopete.
Comment 92 Roman Jarosz 2006-08-03 17:56:04 UTC
Dominik, Gaim uses icq2003b identification
Comment 93 Dominik Karall 2006-08-03 18:04:13 UTC
Hm..is that bad? I think if it works more reliable, it would be the better choice. Or am I wrong?
Comment 94 Roman Jarosz 2006-08-03 18:08:35 UTC
When I was implementing buddy icons for ICQ it didn't work till I used icq5 identification. Anyway with commit 568881 this problems should go away.
Comment 95 Andreas Kling 2006-08-03 23:45:44 UTC
*** Bug 131813 has been marked as a duplicate of this bug. ***
Comment 96 Olivier Goffart 2006-08-04 10:33:58 UTC
*** Bug 131847 has been marked as a duplicate of this bug. ***
Comment 97 Roman Jarosz 2006-08-29 15:46:07 UTC
*** Bug 133109 has been marked as a duplicate of this bug. ***
Comment 98 Stefan Borggraefe 2006-09-11 20:59:40 UTC
*** Bug 133877 has been marked as a duplicate of this bug. ***