Bug 130708 - Kopete fails connecting to ICQ: Version too old
Summary: Kopete fails connecting to ICQ: Version too old
Status: RESOLVED DUPLICATE of bug 130630
Alias: None
Product: kopete
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-12 17:49 UTC by Robert Lindner
Modified: 2006-07-12 17:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Lindner 2006-07-12 17:49:05 UTC
Version:           0.12.0 (using KDE 3.4.0 Level "b" , SUSE 9.3)
Compiler:          gcc version 3.3.5 20050117 (prerelease) (SUSE Linux)
OS:                Linux (x86_64) release 2.6.11.4-20a-default

When trying to connect to Kopete since today, I receive the message "Der ICQ Server ist der Meinung, Sie verwenden einen zu alten Client. Diesen Bug bitte melden..." 
(The icq server thinks you're using a too old client...)

Here's the console's output:

 ICQAccount::connectWithPassword(const QString&)] Logging in as 1*********
kopete (oscar - raw protocol): [KNetworkConnector::KNetworkConnector(QObject*, const char*)] New KNetwork connector.
kopete (oscar - raw protocol): [KNetworkByteStream::KNetworkByteStream(QObject*, const char*)] Instantiating new KNetwork byte stream.
kopete (oscar - raw protocol): [void KNetworkConnector::setOptHostPort(const QString&, short unsigned int)] Manually specifying host login.oscar.aol.com and port 5190
kopete (oscar - raw protocol): [void Client::setStatus(unsigned int, const QString&)] Setting status message to
kopete (oscar - raw protocol): [virtual void KNetworkConnector::done()]
kopete (oscar - raw protocol): [virtual void KNetworkConnector::connectToServer(const QString&)] Initiating connection to login.oscar.aol.com
kopete (oscar - raw protocol): [bool KNetworkByteStream::connect(QString, QString)] Connecting to login.oscar.aol.com, service 5190
kopete (oscar - raw protocol): [void KNetworkConnector::slotConnected()] We are connected.
kopete (oscar - raw protocol): [void CoreProtocol::addIncomingData(const QByteArray&)] Received 10 bytes.
kopete (oscar - raw protocol): [virtual Transfer* FlapProtocol::parse(const QByteArray&, uint&)] channel: \x01 sequence: 50705 length: 4
kopete (oscar - raw protocol): [virtual bool StageOneLoginTask::take(Transfer*)] Starting ICQ login
kopete (oscar - raw protocol): [QString IcqLoginTask::encodePassword(const QString&)] Called.
kopete (oscar - raw protocol): [virtual void IcqLoginTask::onGo()] Sending ICQ channel 0x01 login packet
kopete (oscar - raw protocol): [void CoreProtocol::addIncomingData(const QByteArray&)] Received 377 bytes.
kopete (oscar - raw protocol): [virtual Transfer* FlapProtocol::parse(const QByteArray&, uint&)] channel: \x04 sequence: 50706 length: 371
kopete (oscar - raw protocol): [virtual bool CloseConnectionTask::take(Transfer*)] RECV (DISCONNECT)
kopete (oscar - raw protocol): [virtual bool CloseConnectionTask::take(Transfer*)] found TLV(1) [UIN], uin=135679183
kopete (oscar - raw protocol): [virtual bool CloseConnectionTask::take(Transfer*)] found TLV(8) [ERROR] error= 28
kopete (oscar): [void OscarAccount::slotTaskError(const Oscar::SNAC&, int, bool)] error recieived from task
kopete (oscar): [void OscarAccount::slotTaskError(const Oscar::SNAC&, int, bool)] service: 0 subtype: 0 code: 28
kopete (oscar): [void OscarAccount::logOff(Kopete::Account::DisconnectReason)] accountId='1********'
kopete (oscar - raw protocol): [void ConnectionHandler::clear()] Clearing all connections
kopete: [void KopeteWindow::slotAccountStatusIconChanged(Kopete::Contact*)] [variant:  toString=]
kopete: [void KopeteWindow::slotAccountStatusIconChanged(Kopete::Contact*)] [variant:  toString=]
kopete: [void KopeteWindow::slotAccountStatusIconChanged(Kopete::Contact*)] [variant:  toString=]
kopete (oscar/icq): [virtual void ICQAccount::disconnected(Kopete::Account::DisconnectReason)] Attempting to set status offline
kopete: [void KopeteWindow::slotAccountStatusIconChanged(Kopete::Contact*)] [variant:  toString=]
kopete (oscar - raw protocol): [void KNetworkByteStream::slotConnectionClosed()] Socket has been closed.
kopete (oscar - raw protocol): ..by ourselves!
kopete (oscar - raw protocol): socket error is Kein Fehler feststellbar
kopete (oscar - raw protocol): [virtual void KNetworkConnector::done()]
kopete (oscar - raw protocol): [virtual void KNetworkConnector::done()]
Comment 1 Roman Jarosz 2006-07-12 17:51:31 UTC
Fixed in SVN see bug 130630.

*** This bug has been marked as a duplicate of 130630 ***