Bug 131598 - cant connect to icq
Summary: cant connect to icq
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Applications
Component: ICQ and AIM Plugins (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 131605 131607 131612 131618 131622 131623 131624 131626 131633 131639 131644 131647 131651 131655 131760 131765 131945 132128 132417 132797 138408 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-07-31 18:12 UTC by Rouven Hornung
Modified: 2006-12-06 10:54 UTC (History)
19 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rouven Hornung 2006-07-31 18:12:18 UTC
Version:           0.12.1 (using KDE KDE 3.5.3)
Installed from:    SuSE RPMs
OS:                Linux

When I try to connect to icq,I get a message that the server means my client-version is too old and I shall report it to http://bugs.kde.org . I have version 0.12.1 and a few days ago it worked perfectly and I didn`t change preferences.
Comment 1 Andreas Kling 2006-07-31 19:09:16 UTC

*** This bug has been marked as a duplicate of 130630 ***
Comment 2 Andre Duffeck 2006-07-31 19:15:56 UTC
The protocol has changed again. It's not a duplicate.
Comment 3 Andre Duffeck 2006-07-31 19:23:27 UTC
oh, and kedge has fixed it in r568243.
Comment 4 Andre Duffeck 2006-07-31 20:15:05 UTC
*** Bug 131605 has been marked as a duplicate of this bug. ***
Comment 5 Andre Duffeck 2006-07-31 20:31:26 UTC
*** Bug 131607 has been marked as a duplicate of this bug. ***
Comment 6 Alexandre Oliveira 2006-07-31 23:23:31 UTC
*** Bug 131612 has been marked as a duplicate of this bug. ***
Comment 7 Alexandre Oliveira 2006-07-31 23:30:42 UTC
*** Bug 131618 has been marked as a duplicate of this bug. ***
Comment 8 Jan Ritzerfeld 2006-08-01 00:46:38 UTC
*** Bug 131622 has been marked as a duplicate of this bug. ***
Comment 9 Jan Ritzerfeld 2006-08-01 00:46:58 UTC
*** Bug 131623 has been marked as a duplicate of this bug. ***
Comment 10 Jan Ritzerfeld 2006-08-01 01:10:32 UTC
*** Bug 131624 has been marked as a duplicate of this bug. ***
Comment 11 Alexandre Oliveira 2006-08-01 07:30:22 UTC
*** Bug 131626 has been marked as a duplicate of this bug. ***
Comment 12 Alexandre Oliveira 2006-08-01 07:30:25 UTC
*** Bug 131633 has been marked as a duplicate of this bug. ***
Comment 13 Jan Ritzerfeld 2006-08-01 10:42:41 UTC
*** Bug 131639 has been marked as a duplicate of this bug. ***
Comment 14 Stefan Borggraefe 2006-08-01 11:16:50 UTC
*** Bug 131644 has been marked as a duplicate of this bug. ***
Comment 15 Jan Ritzerfeld 2006-08-01 12:28:10 UTC
*** Bug 131647 has been marked as a duplicate of this bug. ***
Comment 16 Bartosz Fabianowski 2006-08-01 12:53:16 UTC
*** Bug 131651 has been marked as a duplicate of this bug. ***
Comment 17 Bartosz Fabianowski 2006-08-01 12:55:06 UTC
*** Bug 131626 has been marked as a duplicate of this bug. ***
Comment 18 Roman K. 2006-08-01 12:56:15 UTC
Where can I find a solution of this problem?
Comment 19 Igor 2006-08-01 13:21:45 UTC
Solution (found at http://www.kde-forum.org/artikel/15097/Kopete-ICQ-protocol-changed-again-solved.html), they report that afrer re-compilation Kopete works... Let us check, too...

Index: kopete/protocols/oscar/liboscar/oscartypes.h
===================================================================
--- kopete/protocols/oscar/liboscar/oscartypes.h	(revision 568242)
+++ kopete/protocols/oscar/liboscar/oscartypes.h	(working copy)
@@ -239,7 +239,7 @@
 	const WORD ICQ_MAJOR 			= 0x0014;
 	const WORD ICQ_MINOR 			= 0x0034;
 	const WORD ICQ_POINT 			= 0x0000;
-	const WORD ICQ_BUILD 			= 0x0A0F;
+	const WORD ICQ_BUILD 			= 0x0BB8;
 	const char ICQ_OTHER[] 			= { 0x00, 0x00, 0x04, 0x3d };
 	const char ICQ_COUNTRY[] 		= "us";
 	const char ICQ_LANG[] 			= "en";
Comment 20 Igor 2006-08-01 13:29:13 UTC
Pardon, original patch is here:
http://bugs.kde.org/attachment.cgi?id=17185&action=view
Comment 21 Stefan Borggraefe 2006-08-01 15:16:22 UTC
*** Bug 131655 has been marked as a duplicate of this bug. ***
Comment 22 Mathias Panzenböck 2006-08-01 19:37:48 UTC
It would be nice if one could edit thouse protocol version numbers as some kind of advanced settings. Maybe without a UI, only in the kopeterc, but not compiled into the source.
Comment 23 Bartosz Fabianowski 2006-08-01 23:53:57 UTC
You never know what Mirabilis/AOL come up with next. They are playing with us (and Trillian, Miranda, etc.), changing little things that the official client doesn't mind but that trip up others. Next time, it may not be a protocol version number but the order of SNACs or something else.
Comment 24 Igor 2006-08-02 13:30:55 UTC
Kopete really works after new compilation with patched oscartypes.h file; till the next trick from ICQ server protocol. Alas, "make" process takes too much time...
Comment 25 Roman Jarosz 2006-08-02 16:09:04 UTC
SVN commit 568881 by rjarosz:

add version info updater
- version info for icq/aim is stored in kopeterc config
- kopete automatically downloads new version from kopete.kde.org if login fails with "client too old" :)

CCBUG: 130630
CCBUG: 131598



 M  +2 -1      Makefile.am  
 M  +1 -0      aim/aimaccount.cpp  
 M  +1 -0      icq/icqaccount.cpp  
 M  +11 -9     liboscar/aimlogintask.cpp  
 M  +11 -0     liboscar/client.cpp  
 M  +6 -0      liboscar/client.h  
 M  +5 -0      liboscar/connection.cpp  
 M  +1 -0      liboscar/connection.h  
 M  +14 -12    liboscar/icqlogintask.cpp  
 M  +13 -18    liboscar/oscartypes.h  
 M  +31 -3     oscaraccount.cpp  
 M  +2 -0      oscaraccount.h  
 A             oscarversionupdater.cpp   [License: GPL (v2+)]
 A             oscarversionupdater.h   [License: GPL (v2+)]
Comment 26 Andre Duffeck 2006-08-03 09:15:37 UTC
*** Bug 131760 has been marked as a duplicate of this bug. ***
Comment 27 Roman Jarosz 2006-08-03 13:24:26 UTC
*** Bug 131765 has been marked as a duplicate of this bug. ***
Comment 28 Roman Jarosz 2006-08-06 11:30:38 UTC
*** Bug 131945 has been marked as a duplicate of this bug. ***
Comment 29 Olivier Goffart 2006-08-09 12:19:07 UTC
*** Bug 132128 has been marked as a duplicate of this bug. ***
Comment 30 Bartosz Fabianowski 2006-08-14 23:50:52 UTC
*** Bug 132417 has been marked as a duplicate of this bug. ***
Comment 31 Philip Rodrigues 2006-08-23 19:19:34 UTC
*** Bug 132797 has been marked as a duplicate of this bug. ***
Comment 32 Roman Jarosz 2006-12-06 10:54:21 UTC
*** Bug 138408 has been marked as a duplicate of this bug. ***