Bug 130658 - cannot connect to accounts
Summary: cannot connect to accounts
Status: RESOLVED WORKSFORME
Alias: None
Product: kopete
Classification: Applications
Component: ICQ and AIM Plugins (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-11 23:03 UTC by nardew
Modified: 2006-07-30 14:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nardew 2006-07-11 23:03:49 UTC
Version:           0.12.0 (using KDE KDE 3.5.2)
Installed from:    Gentoo Packages
Compiler:          3.4.6 
OS:                Linux

During using of Kopete I have problems with connecting into accounts. Sometimes it connects me without any problems but often it cannot connect me for half an hour, sometimes even more. Then when I try another OS(Windows), ICQ runs OK and I have no problems, so I guess the problems aren't on my side. Tonight I couldn't coonect for a few hours and after permanent attempts to log-in, Kopete returned me this message: The ICQ server thinks the client you are using is too old. Please report this as a bug at bugs.kde.org. That was the first time I've received such message. Maybe it was due to too many attempts to connect to the server, who knows... I've got no firewall and as I said, when I try another OS, everythings runs OK. Thank you
Comment 1 Conrad Hoffmann 2006-07-11 23:09:47 UTC
the "client is too old" stuff is fixed in svn.
If you have any other unrelated, reproducable login problems, please open a seperate bug report

*** This bug has been marked as a duplicate of 130630 ***
Comment 2 nardew 2006-07-12 09:45:30 UTC
i don't know why I should open a new report, because this report isn't primarily about that "old client", but it's about unability to connect to the accounts and even subject says about it. and that message I received yesterday is only the consequence of the first problem... btw, i've just try to connect to icq account and that message disappeared, but still i cannot connect.
Comment 3 Roman Jarosz 2006-07-12 09:54:13 UTC
Can you provide console log ?

run it from console

kopete --nofork 1>&2 2>kopete.log

now you will have file kopete.log in current directory, please post this file.
If you don't want to post it here mail it to me.
Also see bug 129366.

Thanks
Comment 4 nardew 2006-07-12 10:10:44 UTC
after a few automatic relogins the log file contains this:

QDateTime::fromString: Parameter out of range
QDateTime::fromString: Parameter out of range
kopete (oscar/icq): WARNING: [ICQ::Presence ICQ::OnlineStatusManager::presenceOf(uint)] No presence exists for internal status 99! Returning Offline
Comment 5 Roman Jarosz 2006-07-12 10:15:39 UTC
You don't have debug output. Can you compile kopete with debug enabled?

./configure --enable-debug

Comment 6 nardew 2006-07-30 14:34:19 UTC
ok, the problem with unability to connect to the icq accounts was due to wrong settings of DNS server of my ISP and since having set up my own named daemon everything runs ok...

thnx