Bug 113329 - KMail crash on startup
Summary: KMail crash on startup
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash with 76 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 113444 115508 115887 116734 116815 117159 117337 117844 118014 118161 118468 118603 118865 118954 119913 120725 122564 122588 122982 126022 130574 132638 132796 133172 138369 148874 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-09-26 01:07 UTC by Josh Berry
Modified: 2008-05-16 10:44 UTC (History)
27 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
The kcrash file from debuger (4.73 KB, text/plain)
2008-05-16 10:43 UTC, Erwin Mueller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Josh Berry 2005-09-26 01:07:34 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc 3.4 
OS:                Linux

Sometimes when I start KMail, it crashes after displaying the password dialog for my first IMAP account, but before displaying the dialog for my second IMAP.  (It usually displays both at the same time.)

This has been occurring sporadically for the past week or so in KDE 3.5 SVN.

Here's the backtrace:

Using host libthread_db library "/lib/libthread_db.so.1".
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1251199312 (LWP 7929)]
[KCrash handler]
#4  0xb7ce4e4b in KMFolder::noContent (this=0x11)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/kmfolder.cpp:280
#5  0xb7d80e4d in KMAcctImap::processNewMail (this=0x83b5a30, 
    interactive=true)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/kmacctimap.cpp:315
#6  0xb7d21c14 in KMail::AccountManager::processNextCheck (this=0x83a4bc8, 
    _newMail=232)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/accountmanager.cpp:196
#7  0xb7d21d82 in KMail::AccountManager::singleCheckMail (this=0x83a4bc8, 
    account=0x83b5a30, interactive=true)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/accountmanager.cpp:125
#8  0xb7d21f22 in KMail::AccountManager::checkMail (this=0x83a4bc8, 
    _interactive=true)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/accountmanager.cpp:312
#9  0xb7e51f87 in KMMainWidget::slotCheckMail (this=0x8455588)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/kmmainwidget.cpp:793
#10 0xb7e66779 in KMMainWidget::qt_invoke (this=0x8455588, _id=49, 
    _o=0xbf8dd1f0) at kmmainwidget.moc:467
#11 0xb73006f6 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#12 0xb7640256 in QSignal::signal () from /usr/qt/3/lib/libqt-mt.so.3
#13 0xb731a075 in QSignal::activate () from /usr/qt/3/lib/libqt-mt.so.3
#14 0xb73216a7 in QSingleShotTimer::event () from /usr/qt/3/lib/libqt-mt.so.3
#15 0xb729e8de in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#16 0xb729ea6d in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#17 0xb789f98c in KApplication::notify (this=0xbf8ded60, receiver=0x84c70f8, 
    event=0xbf8dd6c0)
    at /net/seme/srv/alnath/kde/KDE/kdelibs/kdecore/kapplication.cpp:550
#18 0xb7292550 in QEventLoop::activateTimers ()
   from /usr/qt/3/lib/libqt-mt.so.3
#19 0xb724b346 in QEventLoop::processEvents ()
   from /usr/qt/3/lib/libqt-mt.so.3
#20 0xb72b4851 in QEventLoop::enterLoop () from /usr/qt/3/lib/libqt-mt.so.3
#21 0xb729db69 in QApplication::enter_loop () from /usr/qt/3/lib/libqt-mt.so.3
#22 0xb7488c9f in QDialog::exec () from /usr/qt/3/lib/libqt-mt.so.3
#23 0xb6187a3c in KIO::PasswordDialog::getNameAndPassword (user=@0xbf8ddae0, 
    pass=@0x11, keep=0xbf8dda0f, prompt=@0xbf8dda70, readOnly=false, 
    caption=@0xb776df40, comment=@0xbf8dda50, label=@0x11)
    at /net/seme/srv/alnath/kde/KDE/kdelibs/kio/kio/passdlg.cpp:353
#24 0xb7d75a15 in KMail::ImapAccountBase::makeConnection (this=0x83b5a30)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/imapaccountbase.cpp:285
#25 0xb7d7db79 in KMAcctImap::makeConnection (this=0x11)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/kmacctimap.cpp:547
#26 0xb7d9b0de in KMFolderImap::listDirectory (this=0x83a7690)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/kmfolderimap.cpp:705
#27 0xb7c8b98e in KMFolderTree::slotFolderExpanded (this=0x84b0508, 
    item=0xb7fb6128)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/kmfoldertree.cpp:1449
#28 0xb7c9262f in KMFolderTree::qt_invoke (this=0x84b0508, _id=139134216, 
    _o=0xbf8ddca0) at kmfoldertree.moc:479
#29 0xb73006f6 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#30 0xb7652801 in QListView::expanded () from /usr/qt/3/lib/libqt-mt.so.3
#31 0xb73e42ed in QListViewItem::setOpen () from /usr/qt/3/lib/libqt-mt.so.3
#32 0xb7c8f658 in KMFolderTree::addDirectory (this=0x84b0508, fdir=0x8372d6c, 
    parent=0x0)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/kmfoldertree.cpp:695
#33 0xb7c8fb55 in KMFolderTree::reload (this=0x84b0508, openFolders=false)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/kmfoldertree.cpp:535
#34 0xb7e62d92 in KMMainWidget::readConfig (this=0x8455588)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/kmmainwidget.cpp:401
#35 0xb7e63a22 in KMMainWidget (this=0x8455588, parent=0x11, 
    name=0x11 <Address 0x11 out of bounds>, aGUIClient=0x11, 
    actionCollection=0x8456de8, config=0x11)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/kmmainwidget.cpp:172
#36 0xb7c30cea in KMMainWin (this=0x8456598)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/kmmainwin.cpp:42
#37 0xb7dc2f89 in KMKernel::openReader (this=0xbf8dec80, onlyCheck=false)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/kmkernel.cpp:349
#38 0xb7dc30ac in KMKernel::action (this=0xbf8dec80, mailto=false, 
    check=false, to=@0x11, cc=@0x11, bcc=@0x11, subj=@0x11, body=@0x11, 
    messageFile=@0x11, attachURLs=@0x11)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/kmkernel.cpp:1798
#39 0xb7dc918b in KMKernel::handleCommandLine (this=0xbf8dec80, 
    noArgsOpensReader=true)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/kmkernel.cpp:302
#40 0x0804a53a in KMailApplication::newInstance (this=0xbf8ded60)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/main.cpp:62
#41 0xb794d713 in KUniqueApplication::processDelayed (this=0xbf8ded60)
    at /net/seme/srv/alnath/kde/KDE/kdelibs/kdecore/kuniqueapplication.cpp:444
#42 0xb794d8d5 in KUniqueApplication::qt_invoke (this=0xbf8ded60, _id=18, 
    _o=0x11) at kuniqueapplication.moc:86
#43 0xb73006f6 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#44 0xb7640256 in QSignal::signal () from /usr/qt/3/lib/libqt-mt.so.3
#45 0xb731a075 in QSignal::activate () from /usr/qt/3/lib/libqt-mt.so.3
#46 0xb73216a7 in QSingleShotTimer::event () from /usr/qt/3/lib/libqt-mt.so.3
#47 0xb729e8de in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#48 0xb729ea6d in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#49 0xb789f98c in KApplication::notify (this=0xbf8ded60, receiver=0x83728b8, 
    event=0xbf8dea10)
    at /net/seme/srv/alnath/kde/KDE/kdelibs/kdecore/kapplication.cpp:550
#50 0xb7292550 in QEventLoop::activateTimers ()
   from /usr/qt/3/lib/libqt-mt.so.3
#51 0xb724b346 in QEventLoop::processEvents ()
   from /usr/qt/3/lib/libqt-mt.so.3
#52 0xb72b4851 in QEventLoop::enterLoop () from /usr/qt/3/lib/libqt-mt.so.3
#53 0xb72b47aa in QEventLoop::exec () from /usr/qt/3/lib/libqt-mt.so.3
#54 0xb729db43 in QApplication::exec () from /usr/qt/3/lib/libqt-mt.so.3
#55 0x0804a6c2 in main (argc=17, argv=0x11)
    at /net/seme/srv/alnath/kde/KDE/kdepim/kmail/main.cpp:110
Comment 1 Thiago Macieira 2005-09-28 04:55:52 UTC
*** Bug 113444 has been marked as a duplicate of this bug. ***
Comment 2 Mathieu Jobin 2005-10-01 19:00:25 UTC
I got this too....


kmail: KMFolderImap::processNewMail - waiting for connection: Kate
kmail: KMFolderImap::processNewMail - waiting for connection: Programming Notes
kmail: KMFolderImap::processNewMail - imapPath of Sent is empty!
kmail: slotListNamespaces - waiting for connection

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 11483)]
0xb7c6afd8 in QGuardedPtr<KMFolder>::operator KMFolder*() const () from /usr/kde/3.5/lib/libkmailprivate.so
(gdb) bt
#0  0xb7c6afd8 in QGuardedPtr<KMFolder>::operator KMFolder*() const () from /usr/kde/3.5/lib/libkmailprivate.so
#1  0xb7f8f83c in ?? () from /usr/kde/3.5/lib/libkmailprivate.so
#2  0x21eb4ab2 in ?? ()
#3  0xb7f8f83c in ?? () from /usr/kde/3.5/lib/libkmailprivate.so
#4  0xb7d75087 in KMAcctImap::processNewMail(bool) () from /usr/kde/3.5/lib/libkmailprivate.so
#5  0x00000001 in ?? ()
#6  0x0804ac50 in kdbgstream::operator<<(kdbgstream& (*)(kdbgstream&)) ()
#7  0xbffd27e0 in ?? ()
#8  0xb5fcb354 in QString::deref() () from /usr/qt/3/lib/libqt-mt.so.3
Previous frame inner to this frame (corrupt stack?)
(gdb)                                                

Comment 3 Josh Berry 2005-10-24 07:23:58 UTC
Ping?  This bug is still here...
Comment 4 Andreas Roth 2005-11-01 14:22:32 UTC
In Beta2 3.4.92 the bug is present. It only happens, when no new mails are inbox. On my machine i can't start kontact or kmail unless there are unread mails in my inbox. I configured kmail with 5 imap accounts.
Comment 5 Tommi Tervo 2005-11-02 15:49:49 UTC
*** Bug 115508 has been marked as a duplicate of this bug. ***
Comment 6 Tommi Tervo 2005-11-21 14:41:49 UTC
*** Bug 116815 has been marked as a duplicate of this bug. ***
Comment 7 Tommi Tervo 2005-11-28 15:50:09 UTC
*** Bug 117159 has been marked as a duplicate of this bug. ***
Comment 8 Tommi Tervo 2005-11-30 11:20:50 UTC
*** Bug 117337 has been marked as a duplicate of this bug. ***
Comment 9 Spencer Shimko 2005-12-05 15:28:53 UTC
I have what appears to be the same problem but I also have to remove the stale kmail/lock before it will successfully start.  It starts fine when closed down properly, but after abnormal closure (crash etc.) I must have new mail and no lock file. 
Comment 10 Thiago Macieira 2005-12-19 00:07:32 UTC
*** Bug 118603 has been marked as a duplicate of this bug. ***
Comment 11 Tom Chance 2005-12-19 12:27:11 UTC
Can you clarify your steps to solve the problem? I've deleted all the kmail files in /tmp, deleted the file ~/.kde/share/apps/kmail/lock and sent myself some new mail that arrives in my inbox. When I start KMail it still crashes! It'd be handy to know a way of resolving this so I can continue using it...
Comment 12 Thiago Macieira 2005-12-22 19:37:31 UTC
*** Bug 118865 has been marked as a duplicate of this bug. ***
Comment 13 Thiago Macieira 2005-12-22 19:39:29 UTC
*** Bug 116734 has been marked as a duplicate of this bug. ***
Comment 14 Thiago Macieira 2005-12-22 19:40:15 UTC
*** Bug 118468 has been marked as a duplicate of this bug. ***
Comment 15 Thiago Macieira 2005-12-24 13:55:04 UTC
*** Bug 118954 has been marked as a duplicate of this bug. ***
Comment 16 Thiago Macieira 2005-12-24 13:55:57 UTC
*** Bug 118014 has been marked as a duplicate of this bug. ***
Comment 17 Imre Péntek 2005-12-24 14:02:09 UTC
*** This bug has been confirmed by popular vote. ***
Comment 18 Juha Tuomala 2005-12-24 14:32:57 UTC
How about changing the bug version to 3.5? It's out now and people using the latest stable relase are reporting duplicates as they don't see this during the report process when other bugs releated bugs are listed.
Comment 19 Jens 2006-01-04 10:34:52 UTC
Hello, I'm having this bug too and it only appeared after updating from 3.4.2 to 3.5.0. Is it possbile that SuSE's 3.4 RPMs have a "private" fix for this bug? Maybe somebody from SuSE can comment?

Thanks!
Comment 20 Jens 2006-01-04 14:11:19 UTC
Update: After deleting .kde/share/apps/kmail (which seems to contain an IMAP cache, although I never used IMAP cached accounts) KMail started up OK. My accounts were all still there, only the icons and folder settings were gone. Plus I had to resubscribe to all IMAP folders, and KMail asked me for each account if I want to "enable subscriptions".

Anotther thing: KMail 1.9 seems to ignore the IMAP folder prefix setting which I had defined before (and which is still set in the account setting). Courier IMAP (which I use) uses "INBOX." as a prefix and before, the "Inbox" was shown as a normal folder. Now, INBOX ("Posteingang") is shown as a parent folder and all IMAP folders are subfolders of this one, regardless of what I specify in the account settings.

Maybe this is related to this bug.
Comment 21 Sylvain Garneau 2006-01-05 02:07:05 UTC
Samething here. After upgrading to kde 3.5, kmail crashes, 2-3 seconds after I start it.
Comment 22 Carsten Burghardt 2006-01-05 11:47:05 UTC
> Update: After deleting .kde/share/apps/kmail (which seems to contain an
> IMAP cache, although I never used IMAP cached accounts) KMail started up
> OK.


Of course, this contains the headers.

> My accounts were all still there, only the icons and folder settings
> were gone. Plus I had to resubscribe to all IMAP folders, and KMail asked
> me for each account if I want to "enable subscriptions".


The settings are obviously lost.

> Anotther thing: KMail 1.9 seems to ignore the IMAP folder prefix setting
> which I had defined before (and which is still set in the account
> setting). Courier IMAP (which I use) uses "INBOX." as a prefix and before,
> the "Inbox" was shown as a normal folder. Now, INBOX ("Posteingang") is
> shown as a parent folder and all IMAP folders are subfolders of this one,
> regardless of what I specify in the account settings.


This is ok, KMail now uses the namespace and the hack to display the
folders on the same level has been removed. There is already a wish to
change it but this won't change for 3.5
Comment 23 Jens 2006-01-05 11:59:21 UTC
So what data in apps/kmail exactly caused the crash? I still have the folder, I can probably narrow it down given a starting point.
Comment 24 Thiago Macieira 2006-01-12 03:49:59 UTC
*** Bug 119913 has been marked as a duplicate of this bug. ***
Comment 25 Marcus D. Hanwell 2006-01-13 03:20:28 UTC
This bug looks very similar to the bug 115020 which I have already added comments to. I find that after improper shutdown kmail crashes until I remove .kde/share/apps/kmail/imap/*, I don't need to delete the . files but I guess kmail finds some files missing and rebuilds the index? This seems to happen quite frequently and I would love to see this bug squashed.

I have 3 IMAP accounts set up (using BincIMAP on a remote server) with some pretty large folders in there too. I think they may spark the crash, but I am not sure.
Comment 26 John Myers 2006-01-13 03:30:08 UTC
large folders may be a commonality here. My lkml folder has 55771 messages, and my gentoo-user folder has 16871. And it does seem to have the most problems with the large folders.
Comment 27 Marcus D. Hanwell 2006-01-13 03:38:15 UTC
That could be the case for causing the crashes. At work I use the same version of kmail but don't have the 3rd account set up which is the one with all the big folders. It hasn't crashed once yet. I can trigger the crash on start up bug by killing it off though, and then need to delete the files I mentioned to get back in.
Comment 28 John Myers 2006-01-13 03:48:43 UTC
I should also mention that once triggered, the crashes on startup usually go away if I send myself some mail (with the 'mail' command or something) so that I have new mail that KMail hasn't seen, and then open another client on the inbox. Somehow, this results in the imap cache being cleared, and KMail is able to start up again, though I have to re-sort several folders (especially the large ones)
Comment 29 Juha Tuomala 2006-01-13 06:56:47 UTC
Most of my crashes stopped when I disabled automated mail checks for my two account. I guess there might be some bug when there are concurrent events like manual UI activity and timer starts the mail check and that causes kmail to crash.

It still crashes quite frequently, but now I'm able to handle my mail. I also had to edit kmailrc manually before  those startup crashes stopped. Running kmail from shell and looking what it is doing when the crash happens helps a lot.
Comment 30 Patrick Audley 2006-01-15 03:15:27 UTC
I see this crash occasionally and have verified that it's only with automatic checks on.  I have 100+ folders with between 3000-5000 messages so it's possible that it's size related.  On an odd note, I get it at work where all my accounts are IMAP and at home where I have a mix of DIMAP/IMAP (same four accounts as work though).   Since it always seems to corrupt either the kmailrc or the indices some sort of bad interaction in mail checking makes sense.
Comment 31 Marcus D. Hanwell 2006-01-15 03:40:05 UTC
I can confirm earlier observations too, I do not need to remove any files if there is a new email waiting for me. It has encouraged me to fix bugs to get bug mail so I can get back into my mailbox :)
Comment 32 Marcus D. Hanwell 2006-01-24 11:52:23 UTC
Doing some further testing, and it seems that sometimes I do need to remove some of the files in .kde/share/apps/kmail/imap to invalidate the cache. I have also tested kmail as included with KDE 3.5.1 and the same issues are present (I am a packager for KDE on Gentoo), that is with everything upgraded to KDE 3.5.1 too (one compiled with GCC 3.4.4, other with GCC 4.0.2, both amd64). This has got to be one of the worst bugs I have seen in kmail - if there is anything I can do to help diagnose it then please let me know.
Comment 33 Thomas Beinicke 2006-01-24 14:14:34 UTC
I have been experiencing it for a long time as well.
Sometimes it doesn't occur for days but it keeps returning.
The crash is also on a "per folder basis" since I experience quite often that it crashes and then I restart it just to let it crash again until the crash has worked it's way through all folders. After that I can start it properly again but all my settings for the specific folders are gone. For example to sort per date and also marked as to-do.
Comment 34 Tommi Tervo 2006-01-27 09:36:32 UTC
*** Bug 117844 has been marked as a duplicate of this bug. ***
Comment 35 Juha Tuomala 2006-01-29 11:52:09 UTC
I feel that most of my crashes are somehow related to bug 110862. 

I do filtering (move messages to mailing list folders) for my inbox and sometimes some list fails and all its messages are left into folder. If I select one of those messages and press ctrl-j to apply all filters, kmail typically crashes. It also crashes during the filtering.

If then go and see the filter, it has lost its target folder. Insde the kmailrc, the folder in question has lost (a least) its ImapPath= setting. 

Fixing that and manually subscribing the folder with kmail brings it visible again and the filter is also fixed automatically.

Would it be possible that there is something what corrupts the kmailrc at runtime and causes all these crashes? Of course it should not crash even with rotten config file.
Comment 36 Marcus D. Hanwell 2006-01-29 14:27:24 UTC
In my case I know it is not due to filtering - I do not use any kmail filters. They are IMAP folders filtered server side using procmail. Invalidating the cache by deleting a few of the files in imap/ causes kmail to rebuild its cache and I can start kmail again, although the folder settings are unfortunately lost.
Comment 37 Tommi Tervo 2006-02-24 11:31:31 UTC
*** Bug 122588 has been marked as a duplicate of this bug. ***
Comment 38 Tommi Tervo 2006-02-24 11:57:30 UTC
*** Bug 122564 has been marked as a duplicate of this bug. ***
Comment 39 ratko 2006-02-27 14:13:40 UTC
Hi all.

My kmail also crashes on startup. I leave it running during day and when i come back home kde is crashed. After trying to run it again it crashes right after UI ha been rendered. After about 10 crashes, it starts, but has to download all headers again.

System is:
debian sid, kde 3.5.1, kmail 1.9.1, kontact 1.2.

Here is my backtrace.
Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1241433280 (LWP 5128)]
[New Thread -1281524816 (LWP 5132)]
[New Thread -1273136208 (LWP 5131)]
[New Thread -1264747600 (LWP 5130)]
[New Thread -1256358992 (LWP 5129)]
[KCrash handler]
#5  0xb55c495c in KMFolder::noContent (this=0x68)
    at /tmp/buildd/kdepim-3.5.1/build-tree/kdepim-3.5.1/kmail/kmfolder.cpp:288
#6  0xb565cf04 in KMAcctImap::processNewMail (this=0x859b270, interactive=true)
    at /tmp/buildd/kdepim-3.5.1/build-tree/kdepim-3.5.1/kmail/kmacctimap.cpp:316
#7  0xb55fac2f in KMail::AccountManager::processNextCheck (this=0x859ae18, 
    _newMail=false)
    at /tmp/buildd/kdepim-3.5.1/build-tree/kdepim-3.5.1/kmail/accountmanager.cpp:196
#8  0xb55fae0e in KMail::AccountManager::singleCheckMail (this=0x859ae18, 
    account=0x859b270, interactive=true)
    at /tmp/buildd/kdepim-3.5.1/build-tree/kdepim-3.5.1/kmail/accountmanager.cpp:125
#9  0xb55fafbf in KMail::AccountManager::checkMail (this=0x859ae18, 
    _interactive=true)
    at /tmp/buildd/kdepim-3.5.1/build-tree/kdepim-3.5.1/kmail/accountmanager.cpp:312
#10 0xb571d907 in KMMainWidget::slotCheckMail (this=0x864b248)
    at /tmp/buildd/kdepim-3.5.1/build-tree/kdepim-3.5.1/kmail/kmmainwidget.cpp:793
#11 0xb5733d41 in KMMainWidget::qt_invoke (this=0x864b248, _id=49, 
    _o=0xbffff3b8) at kmmainwidget.moc:467
#12 0xb70aab57 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#13 0xb743b055 in QSignal::signal () from /usr/lib/libqt-mt.so.3
#14 0xb70c8a40 in QSignal::activate () from /usr/lib/libqt-mt.so.3
#15 0xb70d0354 in QSingleShotTimer::event () from /usr/lib/libqt-mt.so.3
#16 0xb7040698 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#17 0xb70408b6 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#18 0xb7746d4e in KApplication::notify () from /usr/lib/libkdecore.so.4
#19 0xb6fd05e5 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#20 0xb703198c in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#21 0xb6fe435c in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#22 0xb7058da2 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#23 0xb7058ccb in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#24 0xb703f225 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#25 0x0805ae7b in main (argc=104, argv=0x68) at main.cpp:177
#26 0xb780bed0 in __libc_start_main () from /lib/tls/libc.so.6
#27 0x08058561 in _start () at ../sysdeps/i386/elf/start.S:119

i apologize if this is a debian thing...
Comment 40 monstermunch 2006-02-27 17:18:51 UTC
I can confirm that this bug still exists on Suse 10 with KDE 3.5.1. It's a very annoying bug and it happens to me probably 10/20% of the time I start KMail (KMail displays for about half a second and crashes). If I quickly click on a folder, this stops it from crashing for some reason. Now I start Kmail and constantly click on the desktop where the folders are going to appear to get Kmail to start. Is there a temporary fix to this because it makes Kmail a pain to use and I really like it? :-(
Comment 41 monstermunch 2006-02-27 17:19:02 UTC
I can confirm that this bug still exists on Suse 10 with KDE 3.5.1. It's a very annoying bug and it happens to me probably 10/20% of the time I start KMail (KMail displays for about half a second and crashes). If I quickly click on a folder, this stops it from crashing for some reason. Now I start Kmail and constantly click on the desktop where the folders are going to appear to get Kmail to start. Is there a temporary fix to this because it makes Kmail a pain to use and I really like it? :-(
Comment 42 Timo Weingärtner 2006-04-16 21:54:40 UTC
The procedure described in #40 (and #41) works for me too. KMail 4:3.5.2-1 on Debian testing/unstable.
Comment 43 Tommi Tervo 2006-04-21 21:03:48 UTC
*** Bug 126022 has been marked as a duplicate of this bug. ***
Comment 44 Imre Péntek 2006-07-13 08:30:30 UTC
Still present in kmail 1.9.3
Comment 45 Andreas Kling 2006-07-31 23:23:10 UTC
*** Bug 118161 has been marked as a duplicate of this bug. ***
Comment 46 Andreas Kling 2006-07-31 23:24:10 UTC
*** Bug 117935 has been marked as a duplicate of this bug. ***
Comment 47 Andreas Kling 2006-07-31 23:24:20 UTC
*** Bug 122982 has been marked as a duplicate of this bug. ***
Comment 48 Andreas Kling 2006-07-31 23:24:43 UTC
*** Bug 130246 has been marked as a duplicate of this bug. ***
Comment 49 Andreas Kling 2006-07-31 23:24:58 UTC
*** Bug 130574 has been marked as a duplicate of this bug. ***
Comment 50 Andreas Kling 2006-07-31 23:29:23 UTC
*** Bug 115887 has been marked as a duplicate of this bug. ***
Comment 51 Tommi Tervo 2006-08-07 08:57:20 UTC
*** Bug 131957 has been marked as a duplicate of this bug. ***
Comment 52 Andreas Kling 2006-08-20 09:47:10 UTC
*** Bug 132638 has been marked as a duplicate of this bug. ***
Comment 53 Andreas Kling 2006-08-20 09:47:31 UTC
*** Bug 132669 has been marked as a duplicate of this bug. ***
Comment 54 Ralph Moenchmeyer 2006-08-20 22:04:58 UTC
 I have Suse 9.3 and Suse 10.1 with KDE 3.5.4 and Kmail (Kontact version 1.2.3). On the server side there is an OX 5 instalation on a SLES 9 with cyrus imap. There are relatively many and large folders on the imap server. Kmail is setup for a TLS connection (which is recognized when testing the server). I use a disconnected imap (cachedimap) setup within Kmail. A check for new mails is performed every five minutes.   
 
Both installations lead to periodic crashes of Kmail during the opening of folders on the server and the synchronization. I could not recognize any specific pattern that lead to the bug, with one exception: 

The bug never occurs when I deactivate the TLS connection and use just an unencrypted connection to the cyrus server. Maybe, that helps to analyze the bug better.  

The error occurs both with SuSE 9.3 and SuSE 10.1. It did also occur with KDE 3.4. 
Comment 55 Nathaniel Taylor 2006-08-21 00:12:53 UTC
Interesting:  I too have two installations (detailed somewhere earlier) and had initially suspected as significant the difference that one used an NFS homedir and the other didn't, until someone else reported the same problem with a local homedir.
Now I see that the case without crashes is the one on the same network as the mailserver, using no encryption, while the bad installation is the remote one using ssl.  I shall try connecting by an ssh tunnel and see if that helps.  Perhaps others with this crash problem would try without kmail's ssl or tls to help root out the problem -- it's a very time-wasting problem for me, and very annoying.
Comment 56 Sebastian Reitenbach 2006-08-21 16:47:25 UTC
my kmail is connected to a cyrus imapd via SSL too.
Comment 57 John Myers 2006-08-21 17:17:58 UTC
This problem suddenly stopped for me around 3.5.3, IIRC. (but I don't think it was the KDE upgrade that fixed it, sorry) I connect to a Dovecot IMAP server with TLS.

Oooh, my certificate on the server has expired sometime relatively recently (like within the past several months) though. I wonder if that may have something to do with it not having the problem...
Comment 58 Tommi Tervo 2006-08-22 15:45:38 UTC
*** Bug 132796 has been marked as a duplicate of this bug. ***
Comment 59 Tommi Tervo 2006-08-23 14:37:11 UTC
*** Bug 120725 has been marked as a duplicate of this bug. ***
Comment 60 Ralph Moenchmeyer 2006-08-25 09:43:26 UTC
Looking at my own comment 54 and comments 55, 56, 57 it seems to me that ssl/tls encryption is one of the causes for the bug. 

As I learned from a different bug with Thunderbird it may also be important to look at the processor architecture - I have a dual core Athlon X2 4800+ on the machine on which kmail runs. But this only for completeness. I do not know whether that plays any role. What happens if the basic kmail process runs on one core and the encryption/deciphering process in parallel on the other core - could some mismatch then lead to the error? Or can that be excluded?  
Comment 61 Imre Péntek 2006-08-25 11:59:48 UTC
As I also use ssl/tls, this possibility cannot be excluded. But I have only one processor:
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 4
model name      : Mobile AMD Athlon(tm) 64 Processor 3000+
stepping        : 10
cpu MHz         : 800.000
cache size      : 1024 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext lm 3dnowext 3dnow up ts fid vid ttp
bogomips        : 1605.62

And this crash occured.
Comment 62 Julian Mehnle 2006-08-25 12:28:26 UTC
I, too, experience the problem from time to time.  I am using KMail 1.9.1 on KDE 3.5.3.  I use several connected IMAP accounts as well as a single disconnected IMAP account.  In some of my mail folders I do have large amounts of messages (5,000 ~ 20,000).  I do NOT use mail filters.  This is my CPU:

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 7
model name      : Pentium III (Katmai)
stepping        : 3
cpu MHz         : 601.453
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse
bogomips        : 1204.40
Comment 63 Carsten Burghardt 2006-08-29 13:02:47 UTC
*** Bug 133172 has been marked as a duplicate of this bug. ***
Comment 64 Elan Ruusamäe 2006-08-29 19:16:40 UTC
my setup is 1 disconnected imap, 1 online imap, but i don't think the disconnected imap has role here as my default startup folder was online imap. changing the folder to open at startup "resolved" the crash. the online imap is over ssl.

it is odd that this bug has so many duplicates and reports but no actual words from developers who actually are willing to fix anything ;(

here's top from my kcrashdialog. note i avoided the crash by changing default startup folder. but if i "enter" the broke imap account the backtrace is:

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[KCrash handler]
#6  0xb7294735 in QMap<KPIM::ProgressItem*, bool>::detach (this=0x887aa88)
    at /usr/include/qt/qmap.h:739
#7  0xb7294137 in QMap<KPIM::ProgressItem*, bool>::remove (this=0x887aa88, 
    k=@0xbfa63eb4) at /usr/include/qt/qmap.h:831
#8  0xb7291e21 in KPIM::ProgressItem::removeChild (this=0x887aa48, 
    kiddo=0x866dce8) at progressmanager.cpp:74
#9  0xb7291d9d in KPIM::ProgressItem::setComplete (this=0x866dce8)
    at progressmanager.cpp:60
#10 0xb7cd8393 in KMail::ImapAccountBase::removeJob (this=0x83274f0, 
    it=@0xbfa63f40) at imapaccountbase.cpp:1174
#11 0xb7c267d6 in KMail::ListJob::slotListResult (this=0x8686328, 
    job=0x86825b0) at listjob.cpp:183
#12 0xb7c27093 in KMail::ListJob::qt_invoke (this=0x8686328, _id=2, 
    _o=0xbfa64010) at listjob.moc:128

i'd be happy to provide more information to get this ProgressItem related bug resolved finally (i've kept the corrupted imap account for this purpose).
Comment 65 Tommi Tervo 2007-02-03 16:59:34 UTC
*** Bug 138369 has been marked as a duplicate of this bug. ***
Comment 66 Ralph Moenchmeyer 2007-02-11 18:13:30 UTC
Just an additional remark to my contributions from last year. I meanwhile run Opensuse 10.2 and KDE 3.5.6 on my old machine with the AMD Dual Core processor. 
I use kmail with a cachedimap and a connection to a cyrus imap server. From my bad experiences last year I first tried with TLS deactivated (see my previous comments).  
I some days ago tried to switch on TLS again. I did not get any error up to now. I checked again with the old SuSE 10.1 installation with KDE 3.5.4 -> There I sooner or later still get the kmail crash after some time.
So it seems to me that some things have changed since KE 3.5.5 or 3.5.6. 
Comment 67 Stephan Kulow 2007-03-20 09:40:04 UTC
you lost your bad luck - that's about everything that has changed ;(
Comment 68 Will Stephenson 2007-03-20 19:47:09 UTC
SVN commit 644705 by wstephens:

Don't continue checking mail in the other folders when a local folder was removed, it causes a crash on startup.

There is still a bug that local folders are removed erroneously because their ImapPath somehow become empty, but at least they can be recovered with Refresh Folder List now.
CCBUG:113329


 M  +3 -1      kmacctimap.cpp  


--- branches/work/kmail_debug_imap/kmacctimap.cpp #644704:644705
@@ -342,7 +342,7 @@
         else {
           connect(imapFolder, SIGNAL(numUnreadMsgsChanged(KMFolder*)),
               this, SLOT(postProcessNewMail(KMFolder*)));
-          bool ok = imapFolder->processNewMail(interactive);
+          bool ok = imapFolder->processNewMail(interactive); // this removes the local kmfolderimap if its imapPath is somehow empty, and removing it calls createFolderList, invalidating mMailCheckFolders, and causing a crash
           if (!ok)
           {
             // there was an error so cancel
@@ -352,6 +352,8 @@
               mMailCheckProgressItem->incCompletedItems();
               mMailCheckProgressItem->updateProgress();
             }
+            // since the list of folders might have been updated at this point, mMailCheckFolders may be invalid, so break
+            break;
           }
         }
       }
Comment 69 Stephan Kulow 2007-03-21 08:08:17 UTC
SVN commit 644877 by coolo:

Don't continue checking mail in the other folders when a local folder
was removed, it causes a crash on startup.

There is still a bug that local folders are removed erroneously because
their ImapPath somehow become empty, but at least they can be recovered
with Refresh Folder List now.

And as the crash is gone, I consider the bug fixed 
BUG:113329


 M  +3 -1      kmacctimap.cpp  


--- branches/KDE/3.5/kdepim/kmail/kmacctimap.cpp #644876:644877
@@ -342,7 +342,7 @@
         else {
           connect(imapFolder, SIGNAL(numUnreadMsgsChanged(KMFolder*)),
               this, SLOT(postProcessNewMail(KMFolder*)));
-          bool ok = imapFolder->processNewMail(interactive);
+          bool ok = imapFolder->processNewMail(interactive); // this removes the local kmfolderimap if its imapPath is somehow empty, and removing it calls createFolderList, invalidating mMailCheckFolders, and causing a crash
           if (!ok)
           {
             // there was an error so cancel
@@ -352,6 +352,8 @@
               mMailCheckProgressItem->incCompletedItems();
               mMailCheckProgressItem->updateProgress();
             }
+            // since the list of folders might have been updated at this point, mMailCheckFolders may be invalid, so break
+            break;
           }
         }
       }
Comment 70 Thomas McGuire 2007-08-16 18:19:50 UTC
*** Bug 148874 has been marked as a duplicate of this bug. ***
Comment 71 Erwin Mueller 2008-05-16 10:43:20 UTC
Created attachment 24788 [details]
The kcrash file from debuger
Comment 72 Erwin Mueller 2008-05-16 10:44:16 UTC
I think I have the same bug with 1.9.9. I have one IMAP account and one SMTP account. Sometimes KMail crashes on startup, sometimes it's fine.

Have added the kcrash file.