Bug 118161 - crash with imap account after upgrade from 3.4.3 to 3.5.0
Summary: crash with imap account after upgrade from 3.4.3 to 3.5.0
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 1.2
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-12 06:46 UTC by Jean-Damien Durand
Modified: 2006-07-31 23:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Damien Durand 2005-12-12 06:46:36 UTC
Version:           1.2 (using KDE KDE 3.5.0)
Installed from:    Unlisted Binary Package
OS:                Linux

Using an 3.4.3's ~/.kde/share/apps/kmail/imap directory, kontact crashed after upgrading to KDE 3.5.0.
- I observed that a nested imap directory was absent from the listing of directories before it crashed.
- Seems it crashed when checking for new mail
- I was not able to reproduce it on another 3.4.3 box that I also upgraded to 3.5.0
- The workaround was to delete ~/.kde/share/apps/kmail/imap; then no more crash.

I have two backtraces, looking identical and leaving to KMFolder::noContent () from /usr/lib/libkmailprivate.so.

Full backtrace is:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1241913664 (LWP 5868)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#3  0xb5583a6c in KMFolder::noContent () from /usr/lib/libkmailprivate.so
#4  0xb5615479 in KMAcctImap::processNewMail ()
   from /usr/lib/libkmailprivate.so
#5  0xb55b756e in KMail::AccountManager::processNextCheck ()
   from /usr/lib/libkmailprivate.so
#6  0xb55b772b in KMail::AccountManager::singleCheckMail ()
   from /usr/lib/libkmailprivate.so
#7  0xb554389c in KMAccount::mailCheck () from /usr/lib/libkmailprivate.so
#8  0xb5543a5f in KMAccount::qt_invoke () from /usr/lib/libkmailprivate.so
#9  0xb56025c4 in KMail::NetworkAccount::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#10 0xb560e50c in KMail::ImapAccountBase::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#11 0xb56166cc in KMAcctImap::qt_invoke () from /usr/lib/libkmailprivate.so
#12 0xb6fe6b57 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#13 0xb6fe763b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#14 0xb7378d55 in QTimer::timeout () from /usr/lib/libqt-mt.so.3
#15 0xb700c0b4 in QTimer::event () from /usr/lib/libqt-mt.so.3
#16 0xb6f7c698 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#17 0xb6f7c8b6 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#18 0xb7676abc in KApplication::notify () from /usr/lib/libkdecore.so.4
#19 0xb6f0c5e5 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#20 0xb6f6d98c in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#21 0xb6f2035c in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#22 0xb6f94da2 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#23 0xb6f94ccb in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#24 0xb6f7b225 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#25 0x0805aa5d in ?? ()
#26 0xbf803050 in ?? ()
#27 0x00000001 in ?? ()
#28 0x00000001 in ?? ()
#29 0x00000000 in ?? ()
Comment 1 Andreas Kling 2006-07-31 23:23:07 UTC

*** This bug has been marked as a duplicate of 113329 ***