Bug 117159 - Kontact crashes at startup
Summary: Kontact crashes at startup
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-27 20:57 UTC by Frederik Himpe
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frederik Himpe 2005-11-27 20:57:05 UTC
Version:            (using KDE KDE 3.5.0)
Installed from:    Mandriva RPMs
Compiler:          gcc 4.0.2 
OS:                Linux

I was using KDE 3.5rc1 with Kontact open, when suddenly a message appeared that my battery had only 5 minutes to go. KDE logged me out automatically (I think here we have a first bug, because I can loose any unsaved work by this action!). I put in the AC adapter, and logged in in kde. Since then, kontact crashes immediately at startup, with this backtrace:

Using host libthread_db library "/lib/tls/libthread_db.so.1".
`shared object read from target memory' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1244014912 (LWP 22842)]
[New Thread -1259996240 (LWP 22845)]
[KCrash handler]
#4  QGuardedPtr<KMFolder>::operator KMFolder* (this=0x72747067)
    at /usr/lib/qt3/include/qguardedptr.h:117
#5  0xb55e65c4 in KMAcctImap::processNewMail (this=0x8482a28, 
    interactive=true) at kmacctimap.cpp:315
#6  0xb5569ba3 in KMail::AccountManager::processNextCheck (this=0x84eba20, 
    _newMail=false) at accountmanager.cpp:196
#7  0xb5569e2f in KMail::AccountManager::singleCheckMail (this=0x84eba20, 
    account=0x8482a28, interactive=true) at accountmanager.cpp:125
#8  0xb556a196 in KMail::AccountManager::checkMail (this=0x84eba20, 
    _interactive=true) at accountmanager.cpp:312
#9  0xb561686e in KMMainWidget::slotCheckMail (this=0x850c828)
    at kmmainwidget.cpp:793
#10 0xb5672a0c in KMMainWidget::qt_invoke (this=0x850c828, _id=50, 
    _o=0xbf9becc4) at kmmainwidget.moc:467
#11 0xb6aef009 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0xb6e8d1cb in QSignal::signal () from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0xb6b0fca7 in QSignal::activate () from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0xb6b192a4 in QSingleShotTimer::event ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0xb6a81ec0 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0xb6a828cf in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0xb724a71e in KApplication::notify () from /usr/lib/libkdecore.so.4
#18 0xb6a753d9 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0xb6a24bf2 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0xb6a9be43 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0xb6a9bd24 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0xb6a8171c in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0x08061a23 in main (argc=1920233575, argv=0x72747067) at main.cpp:177
Comment 1 Tommi Tervo 2005-11-28 15:50:08 UTC

*** This bug has been marked as a duplicate of 113329 ***