Bug 122564 - Crash in KMFolder::noContent when using IMAP
Summary: Crash in KMFolder::noContent when using IMAP
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-23 16:19 UTC by Ken Bloom
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Bloom 2006-02-23 16:19:44 UTC
Version:            (using KDE KDE 3.5.1)
Installed from:    Debian testing/unstable Packages
Compiler:          g++ (GCC) 4.0.3 20060212 (prerelease) (Debian 4.0.2-9) 
OS:                Linux

Kmail crashes under many circumstances, all in KMFolder::noContent, when using IMAP.

 * Clicking the check mail button using normal (non-TLS) IMAP.
 * Switching from non-TLS to TLS IMAP

I'll let the backtrace speak for itself.

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1248659776 (LWP 7370)]
[New Thread -1278067792 (LWP 7395)]
[New Thread -1269675088 (LWP 7394)]
[New Thread -1261282384 (LWP 7393)]
[New Thread -1252889680 (LWP 7392)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb7ce8959 in KMFolder::noContent () from /usr/lib/libkmailprivate.so
#7  0xb7d80f04 in KMAcctImap::processNewMail ()
   from /usr/lib/libkmailprivate.so
#8  0xb7d1ec2f in KMail::AccountManager::processNextCheck ()
   from /usr/lib/libkmailprivate.so
#9  0xb7d1ee0e in KMail::AccountManager::singleCheckMail ()
   from /usr/lib/libkmailprivate.so
#10 0xb7ca6466 in KMAccount::mailCheck () from /usr/lib/libkmailprivate.so
#11 0xb7ca6645 in KMAccount::qt_invoke () from /usr/lib/libkmailprivate.so
#12 0xb7d6da6b in KMail::NetworkAccount::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#13 0xb7d79d93 in KMail::ImapAccountBase::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#14 0xb7d821e3 in KMAcctImap::qt_invoke () from /usr/lib/libkmailprivate.so
#15 0xb7135b57 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#16 0xb713663b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#17 0xb74c7d55 in QTimer::timeout () from /usr/lib/libqt-mt.so.3
#18 0xb715b0b4 in QTimer::event () from /usr/lib/libqt-mt.so.3
#19 0xb70cb698 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#20 0xb70cb8b6 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#21 0xb77d1d4e in KApplication::notify () from /usr/lib/libkdecore.so.4
#22 0xb705b5e5 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#23 0xb70bc98c in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#24 0xb706f35c in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#25 0xb70e3da2 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#26 0xb70ca255 in QApplication::enter_loop () from /usr/lib/libqt-mt.so.3
#27 0xb72eacf6 in QDialog::exec () from /usr/lib/libqt-mt.so.3
#28 0xb7c5fe6b in AccountsPageReceivingTab::slotModifySelectedAccount ()
   from /usr/lib/libkmailprivate.so
#29 0xb7c7544a in AccountsPageReceivingTab::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#30 0xb7135b57 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#31 0xb713663b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#32 0xb74ce04e in QButton::clicked () from /usr/lib/libqt-mt.so.3
#33 0xb71d36b7 in QButton::mouseReleaseEvent () from /usr/lib/libqt-mt.so.3
#34 0xb7170ec6 in QWidget::event () from /usr/lib/libqt-mt.so.3
#35 0xb70cb698 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#36 0xb70cbc6b in QApplication::notify () from /usr/lib/libqt-mt.so.3
#37 0xb77d1d4e in KApplication::notify () from /usr/lib/libkdecore.so.4
#38 0xb705b653 in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#39 0xb7056ae4 in QETWidget::translateMouseEvent () from /usr/lib/libqt-mt.so.3
#40 0xb7054dbe in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#41 0xb706e8c0 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#42 0xb70e3da2 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#43 0xb70e3ccb in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#44 0xb70ca225 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#45 0x0804a098 in ?? ()
#46 0xbf8e9ab8 in ?? ()
#47 0xbf8e9ca4 in ?? ()
#48 0x00000000 in ?? ()
Comment 1 Tommi Tervo 2006-02-24 11:57:28 UTC

*** This bug has been marked as a duplicate of 113329 ***