Bug 132796 - kmail crashed startup in slotFolderExpanded
Summary: kmail crashed startup in slotFolderExpanded
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.4
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-22 12:20 UTC by Frederic Heem
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Heem 2006-08-22 12:20:01 UTC
Version:           1.9.4 (using KDE KDE 3.5.4)
Installed from:    Fedora RPMs

After updating kmail from fc3 to fc5, kmail crashes on startup.
Removing kmailrc avoids the crash to happen again.
The bug has already been found on the debian mailing list:
http://lists.debian.org/debian-qt-kde/2006/07/msg00199.html

[KCrash handler]
#6  0x00532218 in KMFolderTree::slotFolderExpanded ()
   from /usr/lib/libkmailprivate.so
#7  0x00538c3a in KMFolderTree::qt_invoke () from /usr/lib/libkmailprivate.so
#8  0x011c41aa in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#9  0x015634c1 in QListView::expanded ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#10 0x012c03a5 in QListViewItem::setOpen ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#11 0x00537447 in KMFolderTree::addDirectory ()
   from /usr/lib/libkmailprivate.so
#12 0x00539703 in KMFolderTree::reload () from /usr/lib/libkmailprivate.so
#13 0x006f3b42 in KMMainWidget::readConfig () from /usr/lib/libkmailprivate.so
#14 0x006f4594 in KMMainWidget::KMMainWidget ()
   from /usr/lib/libkmailprivate.so
#15 0x004ddca4 in KMMainWin::KMMainWin () from /usr/lib/libkmailprivate.so
#16 0x0065cdab in KMKernel::mainWin () from /usr/lib/libkmailprivate.so
#17 0x00614d84 in KMail::ImapAccountBase::makeConnection ()
   from /usr/lib/libkmailprivate.so
#18 0x006162ef in KMail::ImapAccountBase::readConfig ()
   from /usr/lib/libkmailprivate.so
#19 0x0061c634 in KMAcctImap::readConfig () from /usr/lib/libkmailprivate.so
#20 0x005bc7ee in KMail::AccountManager::readConfig ()
   from /usr/lib/libkmailprivate.so
#21 0x00665be0 in KMKernel::init () from /usr/lib/libkmailprivate.so
#22 0x0804a0a1 in ?? ()
#23 0x0015e724 in __libc_start_main () from /lib/libc.so.6
#24 0x08049e71 in ?? ()
Comment 1 Tommi Tervo 2006-08-22 15:45:36 UTC

*** This bug has been marked as a duplicate of 113329 ***