Bug 122588 - Crash when Checking for new IMAP E-Mails and the INBOX is empty
Summary: Crash when Checking for new IMAP E-Mails and the INBOX is empty
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-23 20:27 UTC by Eric Sorensen
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Sorensen 2006-02-23 20:27:21 UTC
Version:            (using KDE KDE 3.5.1)
Installed from:    SuSE RPMs
OS:                Linux

When in the I check for new Mails by clicking on the appropriate Menu-Icon. Kmail crashes after a second or two.  Changing from one folder to the Inbox again.

After trying to reproduce this bug using all the different possible functions in KMail, it crashed another couple of times and now seems to have found its feet again.  Maybe the backtrace is helpfull.  It hat 1920 lines so I shortend it a bit...

PS. KMail ist TOP !!


(no debugging symbols found)
Using host libthread_db library "/lib64/tls/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 46912607639360 (LWP 9713)]
[New Thread 1082145120 (LWP 9900)]
[Thread debugging using libthread_db enabled]
[New Thread 46912607639360 (LWP 9713)]
[New Thread 1082145120 (LWP 9900)]
[Thread debugging using libthread_db enabled]
[New Thread 46912607639360 (LWP 9713)]
[New Thread 1082145120 (LWP 9900)]
[New Thread 1080043872 (LWP 9899)]
[New Thread 1077942624 (LWP 9898)]
[New Thread 1075841376 (LWP 9897)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#5  0x00002aaaaaded284 in KMFolder::noContent ()
   from /opt/kde3/lib64/libkmailprivate.so
#6  0x00002aaaaaf6b504 in KMAcctImap::processNewMail ()
   from /opt/kde3/lib64/libkmailprivate.so
#7  0x00002aaaaaef27fc in KMail::AccountManager::processNextCheck ()
   from /opt/kde3/lib64/libkmailprivate.so
#8  0x00002aaaaaef2d4a in KMail::AccountManager::singleCheckMail ()
   from /opt/kde3/lib64/libkmailprivate.so
#9  0x00002aaaaaef32a7 in KMail::AccountManager::checkMail ()
   from /opt/kde3/lib64/libkmailprivate.so
#10 0x00002aaaab0509ba in KMMainWidget::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#11 0x00002aaaabad1b38 in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#12 0x00002aaaabad1f5d in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#13 0x00002aaaae4ddbe1 in KAction::qt_invoke ()
   from /opt/kde3/lib64/libkdeui.so.4
#14 0x00002aaaae4ddcd9 in KActionMenu::qt_invoke ()
   from /opt/kde3/lib64/libkdeui.so.4
#15 0x00002aaaabad1a96 in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#16 0x00002aaaabad1f5d in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#17 0x00002aaaae4cb1a4 in KToolBarButton::mouseReleaseEvent ()
   from /opt/kde3/lib64/libkdeui.so.4
#18 0x00002aaaabb053b7 in QWidget::event ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#19 0x00002aaaae51b4b6 in KToolBarButton::event ()
   from /opt/kde3/lib64/libkdeui.so.4
#20 0x00002aaaaba7b643 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#21 0x00002aaaaba7c2b4 in QApplication::notify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#22 0x00002aaaab45fb5e in KApplication::notify ()
   from /opt/kde3/lib64/libkdecore.so.4
#23 0x00002aaaaba212dc in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#24 0x00002aaaaba20188 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#25 0x00002aaaaba321b7 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#26 0x00002aaaaba90283 in QEventLoop::enterLoop ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#27 0x00002aaaaba90182 in QEventLoop::exec ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#28 0x000000000040298d in ?? ()
#29 0x00002aaaac2d15aa in __libc_start_main () from /lib64/tls/libc.so.6
#30 0x000000000040271a in ?? ()
#31 0x00007fffffd344f8 in ?? ()
#32 0x00002aaaaabc19c0 in rtld_errno () from /lib64/ld-linux-x86-64.so.2
#33 0x0000000000000007 in ?? ()
#34 0x00007fffffd35f4a in ?? ()
Comment 1 Tommi Tervo 2006-02-24 11:31:27 UTC

*** This bug has been marked as a duplicate of 113329 ***