Bug 117844 - crash after some time and at startup imap ssl + plain
Summary: crash after some time and at startup imap ssl + plain
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-07 10:10 UTC by p
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description p 2005-12-07 10:10:56 UTC
Version:            (using KDE KDE 3.5.0)
Installed from:    SuSE RPMs
OS:                Linux

I connect to a Dovecot IMAP server, over ssl + plain. (same problem with ssl + text and tls + text)
Kmail often crashes at startup, probably after I had problems like the one below. Deleting the imap folder under .kde/share/apps/kmail/ solves the problem, but it keeps coming back.

After a while connections take a long time and suddenly either the mail isn't visible anymore at all, sometimes I get headers only, sometimes message list disappears. Shortly after the problem occurs Kmail crashes.
After a crash it either keeps crashing when I start it up again or I see the message list but no message. Doubleclicking a message gives me only the header.

How can I try to reproduce the error or get more information about what's gone wrong?

thx,
p
Comment 1 p 2005-12-08 14:20:44 UTC
I have the impression problems start when I send an email, at least this time it is certainly the case. When I click the arrow in the status bar to see more detailed information about traffic to and from the imap server I see that Kmail is hanging at retrieving the messages from the sent mail folder, at about 18% for what that's worth.

Some time later I get:
The connection to the server xxx.xxxxxxxx@example.com was unexpectedly closed or timed out. It will be re-established automatically if possible.

After that I can click any of the folders on the left, none give me any information, although I can tell by the detailed status popping up and down that the client is still connecting to the folders I select.
Comment 2 Ingo Klöcker 2006-01-26 23:47:08 UTC
Some more information the reporter gave me:
Problems started when I installed kde 3.5, back in november. I have been 
installing all subsequent updates from the suse kde updates server 
hoping that the problem would go away.
[...]
I also attached a crash backtrace, maybe it rings a bell for you or one 
of the developers.

If all this isn't the way things should go I can understand, but can you 
point me in the right direction?
I don't know how to get more detailed information since the problems 
leading up to that crash are very erratic, but I really desperately 
would like to get this out of the way.

Removing the .lock file and imap directory resolve the error temporarily 
but depending on the sun, moon and other heavenly bodies it sooner or 
later crashes again.

The backtrace:
#4  0x4272b919 in KMFolder::noContent () from /opt/kde3/lib/libkmailprivate.so
#5  0x42901f74 in KMAcctImap::processNewMail ()
   from /opt/kde3/lib/libkmailprivate.so
#6  0x42866da4 in KMail::AccountManager::processNextCheck ()
   from /opt/kde3/lib/libkmailprivate.so
#7  0x4286738e in KMail::AccountManager::singleCheckMail ()
   from /opt/kde3/lib/libkmailprivate.so
#8  0x4286795f in KMail::AccountManager::checkMail ()
   from /opt/kde3/lib/libkmailprivate.so
#9  0x429d58f7 in KMMainWidget::slotCheckMail ()
   from /opt/kde3/lib/libkmailprivate.so
#10 0x429e7201 in KMMainWidget::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#11 0x410dfa49 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0x414215d2 in QSignal::signal () from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0x410fc66b in QSignal::activate () from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0x41103fc3 in QSingleShotTimer::event ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0x4107fd41 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0x410806b9 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x40d8614e in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#18 0x41074ab8 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0x4102df4f in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0x41096c53 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0x41096b36 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0x4107f68f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0x0805aefb in ?? ()
#24 0xbfaeb1d0 in ?? ()
#25 0x00000001 in ?? ()
#26 0x00000001 in ?? ()
#27 0x00000000 in ?? ()
#28 0x00000000 in ?? ()
#29 0x00000001 in ?? ()
#30 0x08068540 in typeinfo name for QPtrList<KParts::Part> ()
#31 0x00000000 in ?? ()
#32 0x08067b04 in typeinfo name for QPtrList<KParts::Part> ()
#33 0x08067af0 in typeinfo name for QPtrList<KParts::Part> ()
#34 0x00000021 in ?? ()
#35 0x417508b0 in main_arena () from /lib/tls/libc.so.6
#36 0x00000004 in ?? ()
#37 0x00000020 in ?? ()
#38 0x41698241 in _int_malloc () from /lib/tls/libc.so.6
#39 0x41648ea0 in __libc_start_main () from /lib/tls/libc.so.6
#40 0x080585c1 in ?? ()
Comment 3 Tommi Tervo 2006-01-27 09:36:30 UTC

*** This bug has been marked as a duplicate of 113329 ***