Bug 118603 - Kmail crashes on startup
Summary: Kmail crashes on startup
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-18 23:24 UTC by Tom Chance
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
The backtrace (6.50 KB, text/plain)
2005-12-18 23:25 UTC, Tom Chance
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Chance 2005-12-18 23:24:15 UTC
Version:            (using KDE KDE 3.5.0)
Installed from:    Ubuntu Packages

KMail has started to crash on startup. It gets so far as the UI appearing, the folder list and message lists are populated and the systray icons appears, then very quickly it just crashes.

My laptop ran out of battery power (me cleverly leaving it unplugged), so the system didn't shut down properly. That might have contributed to it - nothing else changed before it started crashing.
Comment 1 Tom Chance 2005-12-18 23:25:02 UTC
Created attachment 13978 [details]
The backtrace

Here's a backtrace. I've got the latest kubuntu packages installed, so no
proper debugging I'm afraid.
Comment 2 Thiago Macieira 2005-12-19 00:05:25 UTC
Pasting the backtrace.

no debugging symbols found)
[KCrash handler]
#4  0xb7d07dfc in KMFolder::noContent () from /usr/lib/libkmailprivate.so
#5  0xb7d99ad9 in KMAcctImap::processNewMail ()
   from /usr/lib/libkmailprivate.so
#6  0xb7d3ba3e in KMail::AccountManager::processNextCheck ()
   from /usr/lib/libkmailprivate.so
#7  0xb7d3bbfb in KMail::AccountManager::singleCheckMail ()
   from /usr/lib/libkmailprivate.so
#8  0xb7d3bdc7 in KMail::AccountManager::checkMail ()
   from /usr/lib/libkmailprivate.so
#9  0xb7e537a6 in KMMainWidget::slotCheckMail ()
   from /usr/lib/libkmailprivate.so
#10 0xb7e68ea8 in KMMainWidget::qt_invoke () from /usr/lib/libkmailprivate.so
#11 0xb7404929 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#12 0xb7763e92 in QSignal::signal () from /usr/lib/libqt-mt.so.3
#13 0xb7422344 in QSignal::activate () from /usr/lib/libqt-mt.so.3
#14 0xb7429e88 in QSingleShotTimer::event () from /usr/lib/libqt-mt.so.3
#15 0xb739bf80 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#16 0xb739c172 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#17 0xb7059c3c in KApplication::notify () from /usr/lib/libkdecore.so.4
#18 0xb732cdb7 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#19 0xb738d99b in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#20 0xb7340a84 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#21 0xb73b3cfb in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#22 0xb73b3c1e in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#23 0xb739ac13 in QApplication::exec () from /usr/lib/libqt-mt.so.3
Comment 3 Thiago Macieira 2005-12-19 00:07:30 UTC
Several backtraces match.

*** This bug has been marked as a duplicate of 113329 ***

*** This bug has been marked as a duplicate of 113329 ***