Bug 118954 - Crash at start and mail check
Summary: Crash at start and mail check
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-24 13:10 UTC by Juha Tuomala
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juha Tuomala 2005-12-24 13:10:49 UTC
Version:            (using KDE KDE 3.5.0)
Installed from:    Fedora RPMs

I updated to 3.5 and started Kmail first time. It asks IMAP (2x) passwords,
one I skip with Esc/Cancel as the server is down and then it tries to start up
and check mails from those accounts. It crashes immediatly and every time.


(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208588608 (LWP 2491)]
[New Thread -1243948112 (LWP 2495)]
[New Thread -1233458256 (LWP 2494)]
[New Thread -1222968400 (LWP 2493)]
[New Thread -1212478544 (LWP 2492)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#4  0x005a0a2f in KMFolder::noContent () from /usr/lib/libkmailprivate.so
#5  0x00642980 in KMAcctImap::processNewMail ()
   from /usr/lib/libkmailprivate.so
#6  0x005dccdc in KMail::AccountManager::processNextCheck ()
   from /usr/lib/libkmailprivate.so
#7  0x005dd022 in KMail::AccountManager::singleCheckMail ()
   from /usr/lib/libkmailprivate.so
#8  0x005dd49e in KMail::AccountManager::checkMail ()
   from /usr/lib/libkmailprivate.so
#9  0x00718e08 in KMMainWidget::slotCheckMail ()
   from /usr/lib/libkmailprivate.so
#10 0x0072f78b in KMMainWidget::qt_invoke () from /usr/lib/libkmailprivate.so
#11 0x07820eb4 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#12 0x07b992e6 in QSignal::signal () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#13 0x0783e693 in QSignal::activate () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#14 0x07846f75 in QSingleShotTimer::event ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#15 0x077bc0dd in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#16 0x077bca5c in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#17 0x02100841 in KApplication::notify () from /usr/lib/libkdecore.so.4
#18 0x077b0972 in QEventLoop::activateTimers ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#19 0x0776635a in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#20 0x077d4812 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x077d4736 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x077bbaa9 in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#23 0x0804a69d in ?? ()
#24 0x025e6d5f in __libc_start_main () from /lib/libc.so.6
#25 0x0804a371 in ?? ()
Comment 1 Juha Tuomala 2005-12-24 13:18:02 UTC
Here is the stdout from the same:

% kmail
kmail: KMKernel::KMKernel
kmail: No Qt-native utf-7 codec found; registering QUtf7Codec from libkdenetwork
kmail: [void KMKernel::init()] foldersPath (from config): '/home/tuomala/Mail'
kmail: instantating KPIM::IdentityManager
kmail: Identity::readConfig(): UOID = 359431453 for identity named "XX"
kmail: Identity::readConfig(): UOID = 2001315680 for identity named "XXX"
kmail: pPopFilter set
kmail: namespaces fetched
kmail: slotSaveNamespaces xxx.fi
kmail: migratePrefix - no migration needed
kmail: capabilities:(imap4rev1,sort,thread=references,multiappend,unselect,literal+,idle,children,listext,list-subscribed,namespace,auth=plain)
kmail: namespaces fetched
kmail: slotSaveNamespaces YY
kmail: migratePrefix - replaced empty with Mail
kmail: capabilities:(imap4rev1,idle,namespace,mailbox-referrals,scan,sort,thread=references,thread=orderedsubject,multiappend,login-referrals,auth=plain,auth=login)
WeaverThreadLogger: thread (ID: 1) suspended.
WeaverThreadLogger: thread (ID: 2) suspended.
WeaverThreadLogger: thread (ID: 3) suspended.
WeaverThreadLogger: thread (ID: 4) suspended.
kmail: KMailApplication::newInstance()
kmail: KMKernel::openReader called
kmail: slotListNamespaces
% kmail: processNextCheck, remaining 1
kmail: for host 212.16.xxx.xxx current connections=0 and limit is 0
kmail: connection limit reached: false
kmail: processing next mail check for xxx.fi
kmail: check mail started - connections for host 212.16.xxx.xxx now is 1
kmail: processNextCheck, remaining 1
kmail: for host 212.16.xx.xx current connections=0 and limit is 0
kmail: connection limit reached: false
kmail: processing next mail check for XX
kmail: check mail started - connections for host 212.16.xx.xx now is 1
kmail: KMFolderImap::processNewMail - imapPath of 01-forget is empty!
*** KMail got signal 11 (Crashing)
KCrash: Application 'kmail' crashing...


It also mentions something, that it has detected my folder prefixes and
changed something, I should check my account iformation. It happens 
every time so apparently it fails to do the modification. 
Comment 2 Thiago Macieira 2005-12-24 13:55:02 UTC

*** This bug has been marked as a duplicate of 113329 ***