Bug 120725 - Random crashes in Kontact, hard to relaunch afterwards (backtrace included)
Summary: Random crashes in Kontact, hard to relaunch afterwards (backtrace included)
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Thibaut Cousin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-24 20:57 UTC by Thibaut Cousin
Modified: 2006-08-23 14:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
backtrace of kontact crash (6.65 KB, application/octet-stream)
2006-05-24 12:58 UTC, hubert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thibaut Cousin 2006-01-24 20:57:13 UTC
Version:           inconnu (using KDE 3.5.0 Level "a" , SUSE 10.0 UNSUPPORTED)
Compiler:          Target: x86_64-suse-linux
OS:                Linux (x86_64) release 2.6.13-15.7-default

I'm experiencing regular Kontact crashes, several times a day. I haven't been able to pinpoint the cause, so the best I can do is describe it and provide a backtrace.

- I use mostly KMail and Akregator. Both are in systray all the time.
- No third-party plugin or app, no strange application in memory, no other application problem.
- KMail : mostly used to access an IMAP mailbox (on a Cyrus server) and a POP3 mailbox. No SSL or TLS. No disconnected IMAP (I'm always online).
- Akregator : access about twenty feeds, the biggest being Freshmeat, one needing access to KWallet for a password.
- The crash is completely random. It can happen even when I'm not using Kontact, when it's minimized. I can never reproduce it, but it happens very often : in the middle of typing an email, when switching module, when displaying the source of a message...

Once Kontact has crashed, I have to try to restart it several times before it works: I launch it again, it crashes and leaves some kio_imap4 and kio_pop3 processes behind. So I kill those proceses ans start again. Usually, after 2-5 tries, Kontact starts again normally.

The bug appeared with KDE 3.5.0. As far as I can remember, it didn't happen with KDE 3.4.3.

Since the backtrace is very long, I put it in a text file which you can download here:

http://www.thibaut-cousin.net/vrac/stack_kontact_crash.txt

I hope it will be useful. Don't hesitate to ask me for more details. If recompiling Kontact to get more info is needed, I can also do that.

Thanks for your attention!
Comment 1 Thibaut Cousin 2006-05-24 10:12:03 UTC
I think I have narrowed down the problem. Akregator seems to be the cause. After a hard crash of my computer, Kontact would refuse to start again (crash at launch). I found that KMail could start standalone, but not Akregator. When I removed the ~/.kde/share/apps/akregator folder, Kontact would start again normally and never crash again.

But when I started to use Akregator again, starting from a new clean configuration, Kontact started to crash again at random, every once in a while.

Perhaps the crash is caused by an RSS feed that Akregator doesn't like. But as I have many RSS feeds, it will take time to find which one is the problem.

In any case, Akregator shouldn't react to a bad RSS feed by crashing, obviously... and taking the whole Kontact with it.
Comment 2 Thibaut Cousin 2006-05-24 10:17:44 UTC
I forgot to mention that since comment #1, I upgraded to OpenSUSE 10.1 and KDE 3.5.2. Even starting everything from a clean configuration (I didn't reuse my old .kde folder), the problem was still there.
Comment 3 hubert 2006-05-24 12:58:32 UTC
Created attachment 16254 [details]
backtrace of kontact crash
Comment 4 Tommi Tervo 2006-08-23 14:37:09 UTC

*** This bug has been marked as a duplicate of 113329 ***