Bug 110862 - KMail Crashes because of invalid ImapPath in rc file
Summary: KMail Crashes because of invalid ImapPath in rc file
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash with 42 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 109682 117659 128463 130995 131667 156843 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-08-16 03:35 UTC by Josh Berry
Modified: 2012-08-19 11:01 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josh Berry 2005-08-16 03:35:54 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc 3.3.x 
OS:                Linux

[I originally reported this issue to kde-devel@ with the subject "KMail/Kontact crash on startup".]

KMail crashes on startup if any IMAP folder has an ImapPath of "" in the kmailrc file.

When KMail undergoes some random, unrelated crash (it doesn't matter what), it leaves its kmailrc in an odd state -- some of the ImapPath values for my IMAP folders are empty.  Then, when I restart KMail after the crash, it sees some apparently-invalid IMAP folders in its configuration and tries to remove them (KMFolderMgr::remove()).

For some reason I haven't been able to figure out, this removal attempt causes KMail to crash with the backtrace below.

I can fix the crash and get KMail to start by manually editing the kmailrc file and resetting the ImapPaths back to what they're supposed to be.  (Who knows how they got cleared in the first place...)

-----
Using host libthread_db library "/lib/libthread_db.so.1".
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread -1243158864 (LWP 12550)]
[KCrash handler]
#4  0xb6dbe125 in QString::QString () from /usr/qt/3/lib/libqt-mt.so.3
#5  0xb76836d0 in KIO::Slave::slaveProtocol (this=0x0) at slave.h:117
#6  0xb768029e in KIO::Scheduler::_assignJobToSlave (this=0x85bf358, 
    slave=0x0, job=0x86c78d8)
    at /srv/home/condor/Code/kde/KDE/kdelibs/kio/kio/scheduler.cpp:798
#7  0xb559f7b7 in KIO::Scheduler::assignJobToSlave (slave=0xbf941d90, 
    job=0xbf941d90) at scheduler.h:216
#8  0xb567aea6 in KMFolderImap::remove (this=0x85e41c8)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/kmfolderimap.cpp:218
#9  0xb55c9431 in KMFolder::remove (this=0x38)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/kmfolder.cpp:498
#10 0xb56116f3 in KMFolderMgr::removeFolder (this=0x38, aFolder=0x85e0450)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/kmfoldermgr.cpp:339
#11 0xb5612ad8 in KMFolderMgr::remove (this=0x8590c68, aFolder=0x85e0450)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/kmfoldermgr.cpp:332
#12 0xb5612b65 in KMFolderMgr::remove (this=0x8590c68, aFolder=0x85c1e18)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/kmfoldermgr.cpp:328
#13 0xb56777f9 in KMFolderImap::processNewMail (this=0x85c2308)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/kmfolderimap.cpp:1960
#14 0xb56641df in KMAcctImap::processNewMail (this=0x85beeb0, 
    interactive=true)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/kmacctimap.cpp:340
#15 0xb56058e8 in KMail::AccountManager::processNextCheck (this=0x85aec98, 
    _newMail=104)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/accountmanager.cpp:196
#16 0xb5605a56 in KMail::AccountManager::singleCheckMail (this=0x85aec98, 
    account=0x85beeb0, interactive=true)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/accountmanager.cpp:125
#17 0xb5605bf6 in KMail::AccountManager::checkMail (this=0x85aec98, 
    _interactive=true)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/accountmanager.cpp:312
#18 0xb57347b5 in KMMainWidget::slotCheckMail (this=0x861cfd8)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/kmmainwidget.cpp:793
#19 0xb5748dd0 in KMMainWidget::qt_invoke (this=0x861cfd8, _id=49, 
    _o=0xbf9425a0) at kmmainwidget.moc:465
#20 0xb6aea6f6 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#21 0xb6e2a256 in QSignal::signal () from /usr/qt/3/lib/libqt-mt.so.3
#22 0xb6b04075 in QSignal::activate () from /usr/qt/3/lib/libqt-mt.so.3
#23 0xb6b0b6a7 in QSingleShotTimer::event () from /usr/qt/3/lib/libqt-mt.so.3
#24 0xb6a888de in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#25 0xb6a88a6d in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#26 0xb708987c in KApplication::notify (this=0xbf944350, receiver=0x86abf00, 
    event=0xbf942a70)
    at /srv/home/condor/Code/kde/KDE/kdelibs/kdecore/kapplication.cpp:550
#27 0xb6a7c550 in QEventLoop::activateTimers ()
   from /usr/qt/3/lib/libqt-mt.so.3
#28 0xb6a35346 in QEventLoop::processEvents ()
   from /usr/qt/3/lib/libqt-mt.so.3
#29 0xb6a9e851 in QEventLoop::enterLoop () from /usr/qt/3/lib/libqt-mt.so.3
#30 0xb6a87b69 in QApplication::enter_loop () from /usr/qt/3/lib/libqt-mt.so.3
#31 0xb6c72c9f in QDialog::exec () from /usr/qt/3/lib/libqt-mt.so.3
#32 0xb76c9c64 in KIO::PasswordDialog::getNameAndPassword (user=@0xbf942e90, 
    pass=@0x38, keep=0xbf942dbf, prompt=@0xbf942e20, readOnly=false, 
    caption=@0x806f330, comment=@0xbf942e00, label=@0x38)
    at /srv/home/condor/Code/kde/KDE/kdelibs/kio/kio/passdlg.cpp:353
#33 0xb56591ad in KMail::ImapAccountBase::makeConnection (this=0x85beeb0)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/imapaccountbase.cpp:285
#34 0xb5660e0d in KMAcctImap::makeConnection (this=0x38)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/kmacctimap.cpp:544
#35 0xb567e432 in KMFolderImap::listDirectory (this=0x8591ea0)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/kmfolderimap.cpp:703
#36 0xb556f556 in KMFolderTree::slotFolderExpanded (this=0x8682250, 
    item=0xb58978a8)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/kmfoldertree.cpp:1452
#37 0xb5576249 in KMFolderTree::qt_invoke (this=0x8682250, _id=141042256, 
    _o=0xbf943050) at kmfoldertree.moc:479
#38 0xb6aea6f6 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#39 0xb6e3c801 in QListView::expanded () from /usr/qt/3/lib/libqt-mt.so.3
#40 0xb6bce2ed in QListViewItem::setOpen () from /usr/qt/3/lib/libqt-mt.so.3
#41 0xb5573220 in KMFolderTree::addDirectory (this=0x8682250, fdir=0x8590c94, 
    parent=0x0)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/kmfoldertree.cpp:695
#42 0xb557371d in KMFolderTree::reload (this=0x8682250, openFolders=false)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/kmfoldertree.cpp:535
#43 0xb57453fe in KMMainWidget::readConfig (this=0x861cfd8)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/kmmainwidget.cpp:401
#44 0xb574608e in KMMainWidget (this=0x861cfd8, parent=0x38, 
    name=0x38 <Address 0x38 out of bounds>, aGUIClient=0x38, 
    actionCollection=0x84d4818, config=0x38)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/kmmainwidget.cpp:172
#45 0xb58b34cf in KMailPart (this=0x8439458, parentWidget=0x807cb20, 
    widgetName=0x38 <Address 0x38 out of bounds>, parent=0x38, 
    name=0x38 <Address 0x38 out of bounds>)
    at /srv/home/condor/Code/kde/KDE/kdepim/kmail/kmail_part.cpp:121
#46 0xb58b49f2 in KDEPrivate::ConcreteFactory<KMailPart, QObject>::create (
    parentWidget=0x38, widgetName=0x38 <Address 0x38 out of bounds>, 
    parent=0x38, name=0x38 <Address 0x38 out of bounds>, args=@0x38)
    at kgenericfactory.tcc:146
#47 0xb58b4a78 in KDEPrivate::ConcreteFactory<KMailPart, QObject>::create (
    parentWidget=0x38, widgetName=0x38 <Address 0x38 out of bounds>, 
    parent=0x38, name=0x38 <Address 0x38 out of bounds>, 
    className=0xbf943640 "H\203C\b\214\206��5+\005\b(7\224�\220H��", 
    args=@0x38) at kgenericfactory.tcc:132
#48 0xb58b4ac8 in KParts::GenericFactory<KMailPart>::createPartObject (
    this=0x84386c0, parentWidget=0x38, 
    widgetName=0x38 <Address 0x38 out of bounds>, parent=0x38, 
    name=0x38 <Address 0x38 out of bounds>, 
    className=0xb79409ce "KParts::ReadOnlyPart", args=@0x38)
    at genericfactory.h:110
#49 0xb79390d3 in KParts::Factory::createPart (this=0x84386c0, 
    parentWidget=0x38, widgetName=0x38 <Address 0x38 out of bounds>, 
    parent=0x38, name=0x38 <Address 0x38 out of bounds>, 
    classname=0x38 <Address 0x38 out of bounds>, args=@0x38)
    at /srv/home/condor/Code/kde/KDE/kdelibs/kparts/factory.cpp:44
#50 0xb7da8a4f in createPartInstanceFromFactory<KParts::ReadOnlyPart> (
    factory=0x84386c0, parentWidget=0x807cb20, 
    widgetName=0x38 <Address 0x38 out of bounds>, parent=0x38, 
    name=0x38 <Address 0x38 out of bounds>, args=@0xbf941d90)
    at componentfactory.h:105
#51 0xb7da8b33 in createPartInstanceFromLibrary<KParts::ReadOnlyPart> (
    libraryName=0x84390c8 "(; ��� �", parentWidget=0x807cb20, 
    widgetName=0x38 <Address 0x38 out of bounds>, parent=0x38, 
    name=0x38 <Address 0x38 out of bounds>, args=@0x38, error=0xbf94360c)
    at componentfactory.h:190
#52 0xb7da9398 in Kontact::Core::createPart (this=0x807cb20, 
    libname=0x8300588 "libkmailpart")
    at /srv/home/condor/Code/kde/KDE/kdepim/kontact/interfaces/core.cpp:69
#53 0xb7dab3cb in Kontact::Plugin::loadPart (this=0x8349f88)
    at /srv/home/condor/Code/kde/KDE/kdepim/kontact/interfaces/plugin.cpp:122
#54 0xb5b162ec in KMailPlugin::createPart (this=0x8349f88)
    at
/srv/home/condor/Code/kde/KDE/kdepim/kontact/plugins/kmail/kmail_plugin.cpp:149
#55 0xb7dab524 in Kontact::Plugin::part (this=0x8349f88)
    at /srv/home/condor/Code/kde/KDE/kdepim/kontact/interfaces/plugin.cpp:144
#56 0x08061bbe in Kontact::MainWindow::selectPlugin (this=0x807cb20, 
    plugin=0x8349f88)
    at /srv/home/condor/Code/kde/KDE/kdepim/kontact/src/mainwindow.cpp:536
#57 0x0805f741 in Kontact::MainWindow::loadSettings (this=0x807cb20)
    at /srv/home/condor/Code/kde/KDE/kdepim/kontact/src/mainwindow.cpp:636
#58 0x08060d09 in Kontact::MainWindow::initObject (this=0x807cb20)
    at /srv/home/condor/Code/kde/KDE/kdepim/kontact/src/mainwindow.cpp:160
#59 0x080619c4 in MainWindow (this=0x807cb20)
    at /srv/home/condor/Code/kde/KDE/kdepim/kontact/src/mainwindow.cpp:107
#60 0x0805c01d in KontactApp::newInstance (this=0xbf944350)
    at /srv/home/condor/Code/kde/KDE/kdepim/kontact/src/main.cpp:124
#61 0xb713763b in KUniqueApplication::processDelayed (this=0xbf944350)
    at /srv/home/condor/Code/kde/KDE/kdelibs/kdecore/kuniqueapplication.cpp:444
#62 0xb71377fd in KUniqueApplication::qt_invoke (this=0xbf944350, _id=18, 
    _o=0x38) at kuniqueapplication.moc:86
#63 0xb6aea6f6 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#64 0xb6e2a256 in QSignal::signal () from /usr/qt/3/lib/libqt-mt.so.3
#65 0xb6b04075 in QSignal::activate () from /usr/qt/3/lib/libqt-mt.so.3
#66 0xb6b0b6a7 in QSingleShotTimer::event () from /usr/qt/3/lib/libqt-mt.so.3
#67 0xb6a888de in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#68 0xb6a88a6d in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#69 0xb708987c in KApplication::notify (this=0xbf944350, receiver=0x82a8ca0, 
    event=0xbf9440d0)
    at /srv/home/condor/Code/kde/KDE/kdelibs/kdecore/kapplication.cpp:550
#70 0xb6a7c550 in QEventLoop::activateTimers ()
   from /usr/qt/3/lib/libqt-mt.so.3
#71 0xb6a35346 in QEventLoop::processEvents ()
   from /usr/qt/3/lib/libqt-mt.so.3
#72 0xb6a9e851 in QEventLoop::enterLoop () from /usr/qt/3/lib/libqt-mt.so.3
#73 0xb6a9e7aa in QEventLoop::exec () from /usr/qt/3/lib/libqt-mt.so.3
#74 0xb6a87b43 in QApplication::exec () from /usr/qt/3/lib/libqt-mt.so.3
#75 0x0805c6e3 in main (argc=56, argv=0x38)
    at /srv/home/condor/Code/kde/KDE/kdepim/kontact/src/main.cpp:177
-----
Comment 1 Josh Berry 2005-08-18 03:33:08 UTC
Also, this ImapPath clobbering only seems to happen with folders that have been opened in KMail at some point during the session.
Comment 2 Tommi Tervo 2005-12-05 09:55:31 UTC
*** Bug 117659 has been marked as a duplicate of this bug. ***
Comment 3 Tommi Tervo 2005-12-05 09:55:52 UTC
*** Bug 109682 has been marked as a duplicate of this bug. ***
Comment 4 Ayran 2006-03-29 21:38:45 UTC
I have this bug too. After each crash of kmail I have to edit kmailrc to be able to start up kmail again.
This is on an AMD64 with Fedora Rawhide packages and I have observed this bug since at least KDE 3.5.0, maybe even earlier.
Comment 5 Stefan Borggraefe 2006-07-17 23:41:37 UTC
*** Bug 130995 has been marked as a duplicate of this bug. ***
Comment 6 Tommi Tervo 2006-08-19 13:50:11 UTC
*** Bug 128463 has been marked as a duplicate of this bug. ***
Comment 7 Tommi Tervo 2006-08-19 13:50:50 UTC
*** Bug 131667 has been marked as a duplicate of this bug. ***
Comment 8 John Baldwin 2006-08-22 20:28:16 UTC
I see this often with KMail 1.9.1 (KDE 3.5.2) on FreeBSD 6.1 and 7-current.  Even when I fixup the IMAPPath in kmailrc to stop the crash, it still sometimes tosses the state for some of the folders that had a cleared IMAPPath meaning they lose their custom default sender and have to re-download all the headers from IMAP the next time I select the folder, etc.
Comment 9 Michael Seiwert 2006-11-01 08:27:03 UTC
Does the crash still occur with a recent version of kmail (1.9.5) KDE 3.5.5?

I remember there were some work on fixing the issue of crashing kmail with empty imap path in kmailrc some time ago.
Comment 10 Rogier 2006-11-04 00:23:46 UTC
Hi Michael,

I just verified using kmail 1.9.5:
$ kmail --version
Qt: 3.3.7
KDE: 3.5.5
KMail: 1.9.5

It still crashes.
Attached are the output (stdout/stderr) and backtrace (with kdepim debug 
symbols installed).

Regards,

Rogier.


Michael Seiwert wrote:
[bugs.kde.org quoted mail]

kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806b6b8 ): KAccel object already contains an action name "move_message_to_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806b6b8 ): KAccel object already contains an action name "copy_message_to_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806b6b8 ): KAccel object already contains an action name "jump_to_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806b6b8 ): KAccel object already contains an action name "remove_duplicate_messages"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806b6b8 ): KAccel object already contains an action name "cancel"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806b6b8 ): KAccel object already contains an action name "inc_current_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806b6b8 ): KAccel object already contains an action name "dec_current_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806b6b8 ): KAccel object already contains an action name "select_current_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806b6b8 ): KAccel object already contains an action name "inc_current_message"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806b6b8 ): KAccel object already contains an action name "dec_current_message"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806b6b8 ): KAccel object already contains an action name "select_current_message"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806b6b8 ): KAccel object already contains an action name "delete"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806b6b8 ): KAccel object already contains an action name "edit"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x806b6b8 ): KAccel object already contains an action name "display_message"
ERROR: Communication problem with kmail, it probably crashed.

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1249450304 (LWP 7685)]
[KCrash handler]
#6  KMFolderTree::slotFolderExpanded (this=0x82c3c08, item=0x82ffeb8)
    at /tmp/buildd/kdepim-3.5.5/build-tree/kdepim-3.5.5/kmail/kmfoldertree.cpp:1439
#7  0xb7e1233b in KMFolderTree::qt_invoke (this=0x82c3c08, _id=125, 
    _o=0xbfe36f48) at ./kmfoldertree.moc:479
#8  0xb708dcb3 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#9  0xb742dc78 in QListView::expanded () from /usr/lib/libqt-mt.so.3
#10 0xb7194dd5 in QListViewItem::setOpen () from /usr/lib/libqt-mt.so.3
#11 0xb7dbecc8 in KMFolderTree::addDirectory (this=0x82c3c08, fdir=0x81ecf84, 
    parent=0x0)
    at /tmp/buildd/kdepim-3.5.5/build-tree/kdepim-3.5.5/kmail/kmfoldertree.cpp:695
#12 0xb7dbefa3 in KMFolderTree::reload (this=0x82c3c08, openFolders=false)
    at /tmp/buildd/kdepim-3.5.5/build-tree/kdepim-3.5.5/kmail/kmfoldertree.cpp:535
#13 0xb7de17ba in KMMainWidget::readConfig (this=0x827f4b0)
    at /tmp/buildd/kdepim-3.5.5/build-tree/kdepim-3.5.5/kmail/kmmainwidget.cpp:404
#14 0xb7de21fa in KMMainWidget (this=0x827f4b0, parent=0x8282718, 
    name=0xb7e8aef6 "KMMainWidget", aGUIClient=0x82827dc, 
    actionCollection=0x827a950, config=0x80853f0)
    at /tmp/buildd/kdepim-3.5.5/build-tree/kdepim-3.5.5/kmail/kmmainwidget.cpp:172
#15 0xb7de2659 in KMMainWin (this=0x8282718)
    at /tmp/buildd/kdepim-3.5.5/build-tree/kdepim-3.5.5/kmail/kmmainwin.cpp:42
#16 0xb7de2999 in KMKernel::mainWin (this=0xbfe378b4)
    at /tmp/buildd/kdepim-3.5.5/build-tree/kdepim-3.5.5/kmail/kmkernel.cpp:2045
#17 0xb7de5236 in KMail::ImapAccountBase::makeConnection (this=0x827c210)
    at /tmp/buildd/kdepim-3.5.5/build-tree/kdepim-3.5.5/kmail/imapaccountbase.cpp:280
#18 0xb7dfab7f in KMail::ImapAccountBase::readConfig (this=0x827c210, 
    config=@0x80853f0)
    at /tmp/buildd/kdepim-3.5.5/build-tree/kdepim-3.5.5/kmail/imapaccountbase.cpp:214
#19 0xb7dfafc4 in KMAcctImap::readConfig (this=0x827c210, config=@0x80853f0)
    at /tmp/buildd/kdepim-3.5.5/build-tree/kdepim-3.5.5/kmail/kmacctimap.cpp:528
#20 0xb7dbd66c in KMail::AccountManager::readConfig (this=0x8267008)
    at /tmp/buildd/kdepim-3.5.5/build-tree/kdepim-3.5.5/kmail/accountmanager.cpp:105
#21 0xb7e12e4d in KMKernel::init (this=0xbfe378b4)
    at /tmp/buildd/kdepim-3.5.5/build-tree/kdepim-3.5.5/kmail/kmkernel.cpp:1416
#22 0x0804a02a in main (argc=)
    at /tmp/buildd/kdepim-3.5.5/build-tree/kdepim-3.5.5/kmail/main.cpp:96
#23 0xb77e4ea8 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#24 0x08049e11 in _start () at ../sysdeps/i386/elf/start.S:119
Comment 11 Sune Vuorela 2006-12-14 10:34:04 UTC
*** This bug has been confirmed by popular vote. ***
Comment 12 Josh Berry 2007-04-24 23:59:41 UTC
I can't reproduce this anymore... is it still an open issue?

I'm using KMail from KDE 3.5.6 compiled from the Gentoo -r2 ebuild.  (The -r2 ebuild includes fixes for the following bugs: #66740, #71549, #79685, #96498, #102001, #113329, #113580, #113885, #115713, #117785, #117935, #118060, #121863, #126715, #132487, #137302, #138514, #140195 and #140660.)

In particular, I'm wondering if the fix for #113329 fixed this as well.
Comment 13 John Baldwin 2007-04-25 00:08:26 UTC
I just got this crash yesterday on KMail 1.9.6 (from KDE 3.5.6) built from FreeBSD ports.  This kmail dosen't seem to "lose" the ImapPath like the older version did though.  In fact, I've only seen the crash once (yesterday) and it happened when I added a new folder on the IMAP server and kmail later crashed for some other reason.  It then crashed on startup and when I examined the kmailrc file, the ImapPath for the new folder was empty.  Previously when the kmailrc file would be broken, ImapPath for several existing folders would be broken, so it definitely seems to be improved, and my crash yesterday might be due to a remaining edge case with creating new folders?
Comment 14 Josh Berry 2007-12-02 09:35:46 UTC
Is this still a problem in KDE 3.5.8?  I haven't encountered it personally in a very long while.  If it's been fixed, I'd like to close the bug.
Comment 15 Thomas McGuire 2008-02-05 15:48:19 UTC
*** Bug 156843 has been marked as a duplicate of this bug. ***
Comment 16 Rogier 2008-02-09 21:14:26 UTC
<div id="_htmlarea_default_style_" style="font:10pt arial,helvetica,sans-serif">I just installed kmail 4:3.5.8-1 (debian testing). It still crashes at startup. <br>After removing all sections of the type [Folder-.&lt;something&gt;]  from kmailrc<br>(most of them containing an ImapPath), kmail does not SEGV at startup.<br><br>Regards,<br><br>Rogier.<br><br>On 2 Dec 2007 08:35:48 -0000<br> Josh Berry <des@condordes.net> wrote:<br>&gt; ------- You are receiving this mail because: -------<br>&gt; You are on the CC list for the bug, or are watching <br>&gt;someone who is.<br>&gt;         <br>&gt; http://bugs.kde.org/show_bug.cgi?id=110862         <br>&gt; <br>&gt; <br>&gt; <br>&gt; <br>&gt; ------- Additional Comments From des condordes net <br>&gt; 2007-12-02 09:35 -------<br>&gt; Is this still a problem in KDE 3.5.8?  I haven't <br>&gt;encountered it personally in a very long while.  If it's <br>&gt;been fixed, I'd like to close the
bug.<br><br></des@condordes.net></div>
Comment 17 Rogier 2008-02-09 21:20:58 UTC
My apologies for the HTML (Comment #16).

Kmail 3.5.8 (4:3.5.8-1 from Debian testing) still crashes.

Rogier.
Comment 18 gkarungo 2008-02-11 08:33:00 UTC
Hi,

This is way too technical for me.

If i delete kmail and reinstall it, will the problem go away?

Best wishes
Greg

On 9 Feb 2008 20:20:59 -0000, R. J. G. <rjg@tele2.nl> wrote:
[bugs.kde.org quoted mail]



Hi,<br><br>This is way too technical for me.<br><br>If i delete kmail and reinstall it, will the problem go away?<br><br>Best wishes<br>Greg<br><br><div><span class="gmail_quote">On 9 Feb 2008 20:20:59 -0000, <b class="gmail_sendername">R. J. G.</b> &lt;<a href="mailto:rjg@tele2.nl">rjg@tele2.nl</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
------- You are receiving this mail because: -------<br>You are on the CC list for the bug, or are watching someone who is.<br><br><a href="http://bugs.kde.org/show_bug.cgi?id=110862">http://bugs.kde.org/show_bug.cgi?id=110862</a><br>
<br><br><br><br>------- Additional Comments From rjg tele2 nl&nbsp;&nbsp;2008-02-09 21:20 -------<br>My apologies for the HTML (Comment #16).<br><br>Kmail 3.5.8 (4:3.5.8-1 from Debian testing) still crashes.<br><br>Rogier.<br></blockquote>
</div><br><br clear="all"><br>-- <br>Greg Karungo<br>Advocate<br><br>Mobile: 254-733-735423<br><a href="http://gregkarungo.blogspot.com">http://gregkarungo.blogspot.com</a>
Comment 19 Myriam Schweingruber 2012-08-19 11:01:56 UTC
Thank you for your report. Kmail1 is currently unmaintained and the code has changed sufficiently in Kmail2 so the backtraces are not really useful anymore. Should you experience the same crash in Kmail 4.8.5 or later, please open a new report for Kmail2. Thank you for your understanding