Bug 138369 - kmail crashes right after loading
Summary: kmail crashes right after loading
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.1
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-05 00:23 UTC by Kai Blin
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
valgrind trace (27.55 KB, text/plain)
2006-12-05 00:30 UTC, Kai Blin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Blin 2006-12-05 00:23:31 UTC
Version:           1.9.1 (using KDE KDE 3.5.1)
Installed from:    SuSE RPMs
Compiler:          gcc (GCC) 4.1.0 (SUSE Linux) 
OS:                Linux

When loading Kmail, it crashes right after starting, leaving the following backtrace:

System configuration startup check disabled.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1240078672 (LWP 2027)]
[New Thread -1279362144 (LWP 2031)]
[New Thread -1270969440 (LWP 2030)]
[New Thread -1262576736 (LWP 2029)]
[New Thread -1254184032 (LWP 2028)]
[KCrash handler]
#6  0xb55fd8cc in KMFolder::noContent (this=0x8514310)
    at ./kmail/kmfolder.cpp:288
#7  0xb5888ea7 in KMAcctImap::processNewMail (this=0x854c300, interactive=true)
    at ./kmail/kmacctimap.cpp:316
#8  0xb572048d in KMail::AccountManager::processNextCheck (this=0x8589200, 
    _newMail=false) at ./kmail/accountmanager.cpp:225
#9  0xb5720850 in KMail::AccountManager::singleCheckMail (this=0x8589200, 
    account=0x854c300, interactive=true) at ./kmail/accountmanager.cpp:126
#10 0xb5720e25 in KMail::AccountManager::checkMail (this=0x8589200, 
    _interactive=true) at ./kmail/accountmanager.cpp:341
#11 0xb587be86 in KMMainWidget::slotCheckMail (this=0x85b3240)
    at ./kmail/kmmainwidget.cpp:793
#12 0xb58c4a31 in KMMainWidget::qt_invoke (this=0x85b3240, _id=50, 
    _o=0xbf929124) at ./kmail/kmmainwidget.moc:467
#13 0xb6d39e9d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0xb707139e in QSignal::signal () from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0xb6d55f77 in QSignal::activate () from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0xb6d5d333 in QSingleShotTimer::event ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0xb6cdaf37 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0xb6cdbd01 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0xb73848e3 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#20 0xb6cd00c5 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0xb6c8a710 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0xb6cf1d68 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0xb6cf1bfe in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0xb6cdaaef in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0x0805ae52 in main (argc=) at ./kontact/src/main.cpp:177
#26 0xb68dc87c in __libc_start_main () from /lib/libc.so.6
#27 0x08058591 in _start ()

I'll try to get a valgrind log to you soon.
Comment 1 Kai Blin 2006-12-05 00:30:53 UTC
Created attachment 18789 [details]
valgrind trace

valgrind trace of running kmail until the crash happens.
Comment 2 Kai Blin 2006-12-05 00:44:58 UTC
I've deleted the new mails in one of my imap accounts and it now seems to work again.
Comment 3 Tommi Tervo 2007-02-03 16:59:32 UTC

*** This bug has been marked as a duplicate of 113329 ***