Bug 122982 - kmail crashes when checking for new mail after initial check at atartup
Summary: kmail crashes when checking for new mail after initial check at atartup
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.1
Platform: FreeBSD Ports FreeBSD
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-02 18:27 UTC by Megan Carney
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Megan Carney 2006-03-02 18:27:37 UTC
Version:           1.9.1 (using KDE KDE 3.5.0)
Installed from:    FreeBSD Ports
OS:                FreeBSD

Kmail checks for new mail fine when first starting up.

When checking for new mail again it crashes.

Crash handler reports the following backtrace:
[Switching to LWP 100116]
0x2a74cd9b in pthread_testcancel () from /usr/lib/libpthread.so.1
#0  0x2a74cd9b in pthread_testcancel () from /usr/lib/libpthread.so.1
#1  0x2a744e0c in pthread_mutexattr_init () from /usr/lib/libpthread.so.1
#2  0x2a7491f4 in pthread_setconcurrency () from /usr/lib/libpthread.so.1
#3  0x2a73f346 in _nanosleep () from /usr/lib/libpthread.so.1
#4  0x2a798e4f in sleep () from /lib/libc.so.5
#5  0x2a73473f in sleep () from /usr/lib/libpthread.so.1
#6  0x29b9bb83 in KCrash::startDrKonqi () from /usr/local/lib/libkdecore.so.6
#7  0x29b9b912 in KCrash::defaultCrashHandler ()
   from /usr/local/lib/libkdecore.so.6
#8  0x2a73b926 in sigaction () from /usr/lib/libpthread.so.1
#9  0x2a73b758 in sigaction () from /usr/lib/libpthread.so.1
#10 0x2a73c417 in sigaction () from /usr/lib/libpthread.so.1
#11 0x2a745360 in pthread_mutexattr_init () from /usr/lib/libpthread.so.1
#12 0x2a745207 in pthread_mutexattr_init () from /usr/lib/libpthread.so.1
#13 0x2a803d03 in _ctx_start () from /lib/libc.so.5
#14 0x00000000 in ?? ()
#15 0xbfbfdb80 in ?? ()
#16 0xbfbfd8c0 in ?? ()
#17 0x00000000 in ?? ()
#18 0x2a745190 in pthread_mutexattr_init () from /usr/lib/libpthread.so.1
#19 0x283b099b in KMAcctImap::processNewMail ()
   from /usr/local/lib/libkmailprivate.so
#20 0x283485d6 in KMail::AccountManager::processNextCheck ()
   from /usr/local/lib/libkmailprivate.so
#21 0x28347f48 in KMail::AccountManager::singleCheckMail ()
   from /usr/local/lib/libkmailprivate.so
#22 0x28348f84 in KMail::AccountManager::checkMail ()
   from /usr/local/lib/libkmailprivate.so
#23 0x28485e66 in KMMainWidget::slotCheckMail ()
   from /usr/local/lib/libkmailprivate.so
#24 0x28480e7f in KMMainWidget::qt_invoke ()
   from /usr/local/lib/libkmailprivate.so
#25 0x2a023569 in QObject::activate_signal ()
   from /usr/X11R6/lib/libqt-mt.so.3
#26 0x2a023474 in QObject::activate_signal ()
   from /usr/X11R6/lib/libqt-mt.so.3
#27 0x2981f059 in KAction::activated () from /usr/local/lib/libkdeui.so.6
#28 0x2981e728 in KAction::slotActivated () from /usr/local/lib/libkdeui.so.6
#29 0x2981f346 in KAction::qt_invoke () from /usr/local/lib/libkdeui.so.6
#30 0x2983847b in KActionMenu::qt_invoke () from /usr/local/lib/libkdeui.so.6
#31 0x2a023616 in QObject::activate_signal ()
   from /usr/X11R6/lib/libqt-mt.so.3
#32 0x2a023474 in QObject::activate_signal ()
   from /usr/X11R6/lib/libqt-mt.so.3
#33 0x2a395f1c in QButton::clicked () from /usr/X11R6/lib/libqt-mt.so.3
#34 0x2a0bc452 in QButton::mouseReleaseEvent ()
   from /usr/X11R6/lib/libqt-mt.so.3
#35 0x298e6aec in KToolBarButton::mouseReleaseEvent ()
   from /usr/local/lib/libkdeui.so.6
#36 0x2a05e9ac in QWidget::event () from /usr/X11R6/lib/libqt-mt.so.3
#37 0x298e7b23 in KToolBarButton::event () from /usr/local/lib/libkdeui.so.6
#38 0x29fbd5cb in QApplication::internalNotify ()
   from /usr/X11R6/lib/libqt-mt.so.3
#39 0x29fbcc6c in QApplication::notify () from /usr/X11R6/lib/libqt-mt.so.3
#40 0x29af53e9 in KApplication::notify () from /usr/local/lib/libkdecore.so.6
#41 0x29f4b0e0 in QETWidget::translateMouseEvent ()
   from /usr/X11R6/lib/libqt-mt.so.3
#42 0x29f48b64 in QApplication::x11ProcessEvent ()
   from /usr/X11R6/lib/libqt-mt.so.3
#43 0x29f61ebc in QEventLoop::processEvents ()
   from /usr/X11R6/lib/libqt-mt.so.3
#44 0x29fd1640 in QEventLoop::enterLoop () from /usr/X11R6/lib/libqt-mt.so.3
#45 0x29fd1586 in QEventLoop::exec () from /usr/X11R6/lib/libqt-mt.so.3
#46 0x29fbd75f in QApplication::exec () from /usr/X11R6/lib/libqt-mt.so.3
#47 0x0804a686 in main ()
Comment 1 Megan Carney 2006-03-02 20:28:29 UTC
Using the F5 key or going in to check new mail through the 'Folder' menu doesn't cause a crash.  Appears to happen only when you use the 'Check Mail In' icon.
Comment 2 Andreas Kling 2006-07-31 23:24:17 UTC

*** This bug has been marked as a duplicate of 113329 ***