Bug 116815 - kmail crashes when a new message arrives in imap inbox and kmail window is closed at the same time
Summary: kmail crashes when a new message arrives in imap inbox and kmail window is cl...
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.8.92
Platform: OpenSUSE NetBSD
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-21 14:35 UTC by Sebastian Reitenbach
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Reitenbach 2005-11-21 14:35:33 UTC
Version:           1.8.92 (using KDE KDE 3.4.92)
Installed from:    SuSE RPMs
OS:                NetBSD

a new mail arrived at the imap inbox where kmail is connected to. At the same time the kmail window was closed, and kmail crashed.

This is the backtrace:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 1113473120 (LWP 19426)]
[KCrash handler]
#7  0x4019ba39 in KMFolder::noContent () from /opt/kde3/lib/libkmailprivate.so
#8  0x4033883d in KMAcctImap::processNewMail ()
   from /opt/kde3/lib/libkmailprivate.so
#9  0x402d6713 in KMail::AccountManager::processNextCheck ()
   from /opt/kde3/lib/libkmailprivate.so
#10 0x402d684e in KMail::AccountManager::singleCheckMail ()
   from /opt/kde3/lib/libkmailprivate.so
#11 0x402d6e92 in KMail::AccountManager::checkMail ()
   from /opt/kde3/lib/libkmailprivate.so
#12 0x4042ab8d in KMMainWidget::slotCheckMail ()
   from /opt/kde3/lib/libkmailprivate.so
#13 0x404885dc in KMMainWidget::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#14 0x40a6c98e in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0x40a6d136 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0x41eb7199 in KAction::activated () from /opt/kde3/lib/libkdeui.so.4
#17 0x41fd0eca in KAction::slotActivated () from /opt/kde3/lib/libkdeui.so.4
#18 0x41fd06a7 in KAction::qt_invoke () from /opt/kde3/lib/libkdeui.so.4
#19 0x41fd09cb in KActionMenu::qt_invoke () from /opt/kde3/lib/libkdeui.so.4
#20 0x40a6c8da in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0x40a6d136 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0x40dc7c2c in QButton::clicked () from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0x40b05ca4 in QButton::mouseReleaseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0x41f3c7f9 in KToolBarButton::mouseReleaseEvent ()
   from /opt/kde3/lib/libkdeui.so.4
#25 0x40aa2e05 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0x41f3d9ec in KToolBarButton::event () from /opt/kde3/lib/libkdeui.so.4
#27 0x40a09c4f in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0x40a0bff6 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0x4071adc1 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#30 0x409a6fbe in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0x409a5e76 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0x409b6a58 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0x40a21be1 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0x40a21a26 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0x40a0b6df in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0x0804a696 in ?? ()
#37 0xbfffded0 in ?? ()
#38 0xbfffdde0 in ?? ()
#39 0x00000000 in ?? ()
#40 0x00000000 in ?? ()
#41 0x40814ee4 in ?? () from /usr/lib/qt3/lib/libqt-mt.so.3
#42 0x400367e8 in ?? ()
#43 0x0000003f in ?? ()
#44 0x425d46d8 in ?? ()
#45 0x40edffd0 in vtable for QGArray () from /usr/lib/qt3/lib/libqt-mt.so.3
#46 0x081af690 in ?? ()
#47 0x0aada85f in ?? ()
#48 0x4100ea31 in _int_malloc () from /lib/tls/libc.so.6
#49 0x40fc0e80 in __libc_start_main () from /lib/tls/libc.so.6
#50 0x0804a401 in ?? ()
Comment 1 Tommi Tervo 2005-11-21 14:41:48 UTC

*** This bug has been marked as a duplicate of 113329 ***