Bug 130246 - kontact crash on imap update
Summary: kontact crash on imap update
Status: RESOLVED DUPLICATE of bug 117935
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-04 12:39 UTC by Sebastian Reitenbach
Modified: 2006-09-06 10:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Reitenbach 2006-07-04 12:39:25 UTC
Version:           1.9.3 (using KDE KDE 3.5.3)
Installed from:    SuSE RPMs
OS:                Linux

I just had Kontact running, and it crashed. The crash is, at least I think because of automatic mail checking the configured imap account. The first backtrace is from a cached imap, the second is the connection to the same imap server, but without a cached connection.

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 1106136832 (LWP 8923)]
[New Thread 1127513008 (LWP 8930)]
[Thread debugging using libthread_db enabled]
[New Thread 1106136832 (LWP 8923)]
[New Thread 1127513008 (LWP 8930)]
[Thread debugging using libthread_db enabled]
[New Thread 1106136832 (LWP 8923)]
[New Thread 1127513008 (LWP 8930)]
[New Thread 1125411760 (LWP 8929)]
[New Thread 1123310512 (LWP 8928)]
[New Thread 1121209264 (LWP 8927)]
[KCrash handler]
#9  0x4281e3df in KMAcctCachedImap::processNewMail (this=0x88877c0, 
    folder=0x0, recurse=true) at qvaluelist.h:233
#10 0x4281e54b in KMAcctCachedImap::processNewMail (this=0x88877c0)
    at /usr/src/packages/BUILD/kdepim-3.5.3/kmail/kmacctcachedimap.cpp:215
#11 0x427b2453 in KMail::AccountManager::processNextCheck (this=0x843abc8, 
    _newMail=false)
    at /usr/src/packages/BUILD/kdepim-3.5.3/kmail/accountmanager.cpp:225
#12 0x427b258e in KMail::AccountManager::singleCheckMail (this=0x843abc8, 
    account=0x88877c0)
    at /usr/src/packages/BUILD/kdepim-3.5.3/kmail/accountmanager.cpp:126
#13 0x4272cd5e in KMAccount::mailCheck (this=0x88877c0) at kmkernel.h:223
#14 0x4272f07f in KMAccount::qt_invoke (this=0x88877c0, _id=2, _o=0xbfffe750)
    at kmaccount.moc:237
#15 0x42805a5b in KMail::NetworkAccount::qt_invoke (this=0x0, _id=0, _o=0x0)
    at networkaccount.moc:77
#16 0x42811165 in KMail::ImapAccountBase::qt_invoke (this=0x88877c0, _id=2, 
    _o=0xbfffe750) at imapaccountbase.moc:296
#17 0x4281dda1 in KMAcctCachedImap::qt_invoke (this=0x88877c0, _id=2, 
    _o=0xbfffe750) at kmacctcachedimap.moc:97
#18 0x4112421e in QObject::activate_signal (this=0x86b6a90, clist=0x8875088, 
    o=0xbfffe750) at qconnection.h:56
#19 0x411249c6 in QObject::activate_signal (this=0x86b6a90, signal=2)
    at qobject.cpp:2325
#20 0x41478179 in QTimer::timeout (this=0x0) at qmetaobject.h:261
#21 0x4114941f in QTimer::event (this=0x86b6a90, e=0xbfffeae0)
    at qtimer.cpp:219
#22 0x410c0c2f in QApplication::internalNotify (this=0x0, receiver=0x86b6a90, 
    e=0xbfffeae0) at qevent.h:144
#23 0x410c2813 in QApplication::notify (this=0xbfffed40, receiver=0x86b6a90, 
    e=0xbfffeae0) at qapplication.cpp:2524
#24 0x40dd4ef1 in KApplication::notify (this=0xbfffed40, receiver=0x86b6a90, 
    event=0xbfffeae0) at kapplication.cpp:552
#25 0x410b526c in QEventLoop::activateTimers (this=0x80edf68)
    at qeventloop_unix.cpp:120
#26 0x4106d799 in QEventLoop::processEvents (this=0x80edf68, 
    flags=<value optimized out>) at qeventloop_x11.cpp:389
#27 0x410d89f1 in QEventLoop::enterLoop (this=0x80edf68) at qeventloop.cpp:198
#28 0x410d8836 in QEventLoop::exec (this=0x80edf68) at qeventloop.cpp:145
#29 0x410c26df in QApplication::exec (this=0xbfffed40) at qapplication.cpp:2759
#30 0x08058fc5 in main (argc=0, argv=0x0)
    at /usr/src/packages/BUILD/kdepim-3.5.3/kontact/src/main.cpp:161





backtrace from ordinary imap connection:

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 1106136832 (LWP 12952)]
[New Thread 1127668656 (LWP 12987)]
[Thread debugging using libthread_db enabled]
[New Thread 1106136832 (LWP 12952)]
[New Thread 1127668656 (LWP 12987)]
[Thread debugging using libthread_db enabled]
[New Thread 1106136832 (LWP 12952)]
[New Thread 1127668656 (LWP 12987)]
[New Thread 1125567408 (LWP 12986)]
[New Thread 1123466160 (LWP 12985)]
[New Thread 1121364912 (LWP 12984)]
[KCrash handler]
#9  0x57e58955 in ?? ()
#10 0x4278fe1c in FolderStorage::label (this=0x41595848) at folderstorage.h:91
#11 0x4281df07 in KMAcctCachedImap::processNewMail (this=0x84cf788, 
    folder=0x84a40a0, recurse=true) at progressmanager.h:324
#12 0x4281e54b in KMAcctCachedImap::processNewMail (this=0x84cf788)
    at /usr/src/packages/BUILD/kdepim-3.5.3/kmail/kmacctcachedimap.cpp:215
#13 0x427b2453 in KMail::AccountManager::processNextCheck (this=0x84aa6e0, 
    _newMail=false)
    at /usr/src/packages/BUILD/kdepim-3.5.3/kmail/accountmanager.cpp:225
#14 0x427b258e in KMail::AccountManager::singleCheckMail (this=0x84aa6e0, 
    account=0x84cf788)
    at /usr/src/packages/BUILD/kdepim-3.5.3/kmail/accountmanager.cpp:126
#15 0x4272cd5e in KMAccount::mailCheck (this=0x84cf788) at kmkernel.h:223
#16 0x4272f07f in KMAccount::qt_invoke (this=0x84cf788, _id=2, _o=0xbfffe750)
    at kmaccount.moc:237
#17 0x42805a5b in KMail::NetworkAccount::qt_invoke (this=0x41595848, 
    _id=1096374344, _o=0x41595848) at networkaccount.moc:77
#18 0x42811165 in KMail::ImapAccountBase::qt_invoke (this=0x84cf788, _id=2, 
    _o=0xbfffe750) at imapaccountbase.moc:296
#19 0x4281dda1 in KMAcctCachedImap::qt_invoke (this=0x84cf788, _id=2, 
    _o=0xbfffe750) at kmacctcachedimap.moc:97
#20 0x4112421e in QObject::activate_signal (this=0x84cc7a0, clist=0x848c350, 
    o=0xbfffe750) at qconnection.h:56
#21 0x411249c6 in QObject::activate_signal (this=0x84cc7a0, signal=2)
    at qobject.cpp:2325
#22 0x41478179 in QTimer::timeout (this=0x41595848) at qmetaobject.h:261
#23 0x4114941f in QTimer::event (this=0x84cc7a0, e=0xbfffeae0)
    at qtimer.cpp:219
#24 0x410c0c2f in QApplication::internalNotify (this=0x41595848, 
    receiver=0x84cc7a0, e=0xbfffeae0) at qevent.h:144
#25 0x410c2813 in QApplication::notify (this=0xbfffed40, receiver=0x84cc7a0, 
    e=0xbfffeae0) at qapplication.cpp:2524
#26 0x40dd4ef1 in KApplication::notify (this=0xbfffed40, receiver=0x84cc7a0, 
    event=0xbfffeae0) at kapplication.cpp:552
#27 0x410b526c in QEventLoop::activateTimers (this=0x80edf58)
    at qeventloop_unix.cpp:120
#28 0x4106d799 in QEventLoop::processEvents (this=0x80edf58, 
    flags=<value optimized out>) at qeventloop_x11.cpp:389
#29 0x410d89f1 in QEventLoop::enterLoop (this=0x80edf58) at qeventloop.cpp:198
#30 0x410d8836 in QEventLoop::exec (this=0x80edf58) at qeventloop.cpp:145
#31 0x410c26df in QApplication::exec (this=0xbfffed40) at qapplication.cpp:2759
#32 0x08058fc5 in main (argc=1096374344, argv=0x41595848)
    at /usr/src/packages/BUILD/kdepim-3.5.3/kontact/src/main.cpp:161

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 1106136832 (LWP 12952)]
[New Thread 1127668656 (LWP 12987)]
[Thread debugging using libthread_db enabled]
[New Thread 1106136832 (LWP 12952)]
[New Thread 1127668656 (LWP 12987)]
[Thread debugging using libthread_db enabled]
[New Thread 1106136832 (LWP 12952)]
[New Thread 1127668656 (LWP 12987)]
[New Thread 1125567408 (LWP 12986)]
[New Thread 1123466160 (LWP 12985)]
[New Thread 1121364912 (LWP 12984)]
[KCrash handler]
#9  0x57e58955 in ?? ()
#10 0x4278fe1c in FolderStorage::label (this=0x41595848) at folderstorage.h:91
#11 0x4281df07 in KMAcctCachedImap::processNewMail (this=0x84cf788, 
    folder=0x84a40a0, recurse=true) at progressmanager.h:324
#12 0x4281e54b in KMAcctCachedImap::processNewMail (this=0x84cf788)
    at /usr/src/packages/BUILD/kdepim-3.5.3/kmail/kmacctcachedimap.cpp:215
#13 0x427b2453 in KMail::AccountManager::processNextCheck (this=0x84aa6e0, 
    _newMail=false)
    at /usr/src/packages/BUILD/kdepim-3.5.3/kmail/accountmanager.cpp:225
#14 0x427b258e in KMail::AccountManager::singleCheckMail (this=0x84aa6e0, 
    account=0x84cf788)
    at /usr/src/packages/BUILD/kdepim-3.5.3/kmail/accountmanager.cpp:126
#15 0x4272cd5e in KMAccount::mailCheck (this=0x84cf788) at kmkernel.h:223
#16 0x4272f07f in KMAccount::qt_invoke (this=0x84cf788, _id=2, _o=0xbfffe750)
    at kmaccount.moc:237
#17 0x42805a5b in KMail::NetworkAccount::qt_invoke (this=0x41595848, 
    _id=1096374344, _o=0x41595848) at networkaccount.moc:77
#18 0x42811165 in KMail::ImapAccountBase::qt_invoke (this=0x84cf788, _id=2, 
    _o=0xbfffe750) at imapaccountbase.moc:296
#19 0x4281dda1 in KMAcctCachedImap::qt_invoke (this=0x84cf788, _id=2, 
    _o=0xbfffe750) at kmacctcachedimap.moc:97
#20 0x4112421e in QObject::activate_signal (this=0x84cc7a0, clist=0x848c350, 
    o=0xbfffe750) at qconnection.h:56
#21 0x411249c6 in QObject::activate_signal (this=0x84cc7a0, signal=2)
    at qobject.cpp:2325
#22 0x41478179 in QTimer::timeout (this=0x41595848) at qmetaobject.h:261
#23 0x4114941f in QTimer::event (this=0x84cc7a0, e=0xbfffeae0)
    at qtimer.cpp:219
#24 0x410c0c2f in QApplication::internalNotify (this=0x41595848, 
    receiver=0x84cc7a0, e=0xbfffeae0) at qevent.h:144
#25 0x410c2813 in QApplication::notify (this=0xbfffed40, receiver=0x84cc7a0, 
    e=0xbfffeae0) at qapplication.cpp:2524
#26 0x40dd4ef1 in KApplication::notify (this=0xbfffed40, receiver=0x84cc7a0, 
    event=0xbfffeae0) at kapplication.cpp:552
#27 0x410b526c in QEventLoop::activateTimers (this=0x80edf58)
    at qeventloop_unix.cpp:120
#28 0x4106d799 in QEventLoop::processEvents (this=0x80edf58, 
    flags=<value optimized out>) at qeventloop_x11.cpp:389
#29 0x410d89f1 in QEventLoop::enterLoop (this=0x80edf58) at qeventloop.cpp:198
#30 0x410d8836 in QEventLoop::exec (this=0x80edf58) at qeventloop.cpp:145
#31 0x410c26df in QApplication::exec (this=0xbfffed40) at qapplication.cpp:2759
#32 0x08058fc5 in main (argc=1096374344, argv=0x41595848)
    at /usr/src/packages/BUILD/kdepim-3.5.3/kontact/src/main.cpp:161

both accounts were configured to show hidden folders. nevertheless, the folders of other users, below the user folder from the imap namespace, were not accessible via cached imap, but with the ordinary imap connection.

with the cached imap, kmail told me that the folder user does not exist.
Comment 1 Andreas Kling 2006-07-31 23:24:41 UTC

*** This bug has been marked as a duplicate of 113329 ***
Comment 2 Tommi Tervo 2006-09-06 10:59:14 UTC
Correct dupe: http://bugs.kde.org/show_bug.cgi?id=117935
Comment 3 Tommi Tervo 2006-09-06 10:59:28 UTC

*** This bug has been marked as a duplicate of 117935 ***