Bug 118014 - crash on kmail start because of broken "search" file
Summary: crash on kmail start because of broken "search" file
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-12-09 15:41 UTC by Michael Monnerie
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
kde crash dump on kmail crashing because of the last search file. (65.59 KB, text/plain)
2005-12-09 15:42 UTC, Michael Monnerie
Details
trace of crash via kde (57.93 KB, text/plain)
2005-12-17 17:51 UTC, Michael Monnerie
Details
errors visible calling kmail from bash (2.03 KB, text/plain)
2005-12-17 17:52 UTC, Michael Monnerie
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Monnerie 2005-12-09 15:41:39 UTC
Version:           1.9 (using KDE KDE 3.5.0)
Installed from:    SuSE RPMs
OS:                Linux

I've had a surprise after my last restart of kmail: on startup, it crashed immediately (bug trace attached). I was getting nervous, but one simple thing made it run again:

in ~/.kde/share/apps/kmail/ I had to delete the
search/.Letzte\ Suche.index.search.ids
file. The contents of this file were:
# KMail-Index-IDs V1002
hexdump of this file:
00000000  23 20 4b 4d 61 69 6c 2d  49 6e 64 65 78 2d 49 44  |# KMail-Index-ID|
00000010  73 20 56 31 30 30 32 0a  2a 78 56 34 12 00 00 00  |s V1002.*xV4....|

I have no idea why it's like this, though.
Comment 1 Michael Monnerie 2005-12-09 15:42:50 UTC
Created attachment 13837 [details]
kde crash dump on kmail crashing because of the last search file.
Comment 2 Thiago Macieira 2005-12-10 18:43:19 UTC
Pasting the backtrace:

[KCrash handler]
#3  0x00002aaaaade8c34 in KMFolder::noContent ()
   from /opt/kde3/lib64/libkmailprivate.so
#4  0x00002aaaaaf82d44 in KMAcctImap::processNewMail ()
   from /opt/kde3/lib64/libkmailprivate.so
#5  0x00002aaaaaef65fc in KMail::AccountManager::processNextCheck ()
   from /opt/kde3/lib64/libkmailprivate.so
#6  0x00002aaaaaef6b4a in KMail::AccountManager::singleCheckMail ()
   from /opt/kde3/lib64/libkmailprivate.so
#7  0x00002aaaaaef70a7 in KMail::AccountManager::checkMail ()
   from /opt/kde3/lib64/libkmailprivate.so
#8  0x00002aaaab04aeba in KMMainWidget::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#9  0x00002aaaabac5b38 in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#10 0x00002aaaabda0f6b in QSignal::signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#11 0x00002aaaabadee94 in QSignal::activate ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#12 0x00002aaaabae56e8 in QSingleShotTimer::event ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#13 0x00002aaaaba6f643 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#14 0x00002aaaaba700d0 in QApplication::notify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#15 0x00002aaaab453a1e in KApplication::notify ()
   from /opt/kde3/lib64/libkdecore.so.4
#16 0x00002aaaaba65937 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#17 0x00002aaaaba264d4 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#18 0x00002aaaaba84283 in QEventLoop::enterLoop ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#19 0x00002aaaaba84182 in QEventLoop::exec ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#20 0x0000000000402b3d in ?? ()
#21 0x00002aaaac2c55aa in __libc_start_main () from /lib64/tls/libc.so.6
Comment 3 Michael Monnerie 2005-12-17 17:35:07 UTC
I have to CHANGE my report: I just got the same type of crash again (immediate crash at startup). I tried to just remove the search file, but it didn't help. So I traced again, and found, that the problem lies in the .kde/share/apps/kmail/imap directory structure. I'll attach the broken structure, although I believe you won't find the error easily: I moved those files away from the imap directory, and after that, kmail could start. I closed it and copied the broken structure back - but kmail could still start. But it doesn't remember how many mails there are in the folders - I have to click on every single one again to see the # of mails.

I also made a crashdump, and called kmail from the command line to see some error messages. Everything attached after this entry.

Still I'm not sure if it's the imap directory structure alone - there must be some other location of the problem also, as after the first successful start, even after copying back the broken structure, it did start up, but obviously ignored the contents.
Comment 4 Michael Monnerie 2005-12-17 17:51:39 UTC
Created attachment 13959 [details]
trace of crash via kde
Comment 5 Michael Monnerie 2005-12-17 17:52:23 UTC
Created attachment 13960 [details]
errors visible calling kmail from bash
Comment 6 Michael Monnerie 2005-12-17 17:53:54 UTC
I couldn't upload the broken imap directory structure, as its about 5MB - I put it on http://zmi.at/x/kmail-imap-structure-broken.tz2 (.tar.bz2)

Comment for that file:
broken imap subdirs that obviously made kmail crash. After moving them away, kmail started w/o error
Comment 7 Andy Neitzke 2005-12-22 06:44:00 UTC
I have had a similar problem -- but in my case the "broken structure" is somewhat simpler:  after an abnormal termination of kmail, I wind up with an empty file in ~/.kde/share/apps/kmail/imap, called "870628286".  Subsequently trying to start kmail leads to an immediate crash.  Removing this "870628286" file lets kmail start up normally, albeit with a few undesired side effects (all folders forget the message sort order, and the body of the message I was looking at right before the crash shows up blank, but can be resurrected by moving it to a different folder.)

This problem is new in KDE 3.5 for me.
Comment 8 Thiago Macieira 2005-12-24 13:55:56 UTC

*** This bug has been marked as a duplicate of 113329 ***