Bug 132638 - Sporadic crashes during email/folder check when TLS is activated for KMAIL - Cyrus IMAP connection
Summary: Sporadic crashes during email/folder check when TLS is activated for KMAIL - ...
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kmail
Classification: Applications
Component: disconnected IMAP (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-19 15:04 UTC by Ralph Moenchmeyer
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Moenchmeyer 2006-08-19 15:04:55 UTC
Version:           Unbekannt (using KDE 3.5.4 Level "a" , unofficial build of SUSE )
Compiler:          Target: x86_64-suse-linux
OS:                Linux (x86_64) release 2.6.16.21-0.13-smp

I have Suse 9.3 and Suse 10.1 with KDE 3.5.4 and Kmail (Kontact version 1.2.3). On the server side there is an OX 5 instalation on a SLES 9 with cyrus imap. There are relatively many and large folders on the imap server. Kmail is setup for a TLS connection (which is recognized when testing the server). I use a disconnected imap (cachedimap) setup within Kmail. A check for new mails is performed every five minutes.  

Both installations lead to periodic crashes of Kmail during the openening of folders on the server and the synchronization. I could not recognize a pattern. The only thing I found out is that it did not yet happen when I deactivated the TLS connection, but that may be accidental. The error occurs both with SuSE 9.3 and SuSE 10.1. It did also occur with KDE 3.4. 

The KDE Bug report says the following: 

Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 47083438788160 (LWP 8143)]
[New Thread 1107310912 (LWP 8147)]
[New Thread 1098918208 (LWP 8146)]
[New Thread 1090525504 (LWP 8145)]
[New Thread 1082132800 (LWP 8144)]
[KCrash handler]
#5  0x00002ad27a18906f in KMAcctCachedImap::processNewMail ()
   from /opt/kde3/lib64/libkmailprivate.so
#6  0x00002ad27a189252 in KMAcctCachedImap::processNewMail ()
   from /opt/kde3/lib64/libkmailprivate.so
#7  0x00002ad27a12e168 in KMail::AccountManager::processNextCheck ()
   from /opt/kde3/lib64/libkmailprivate.so
#8  0x00002ad27a12e4ca in KMail::AccountManager::singleCheckMail ()
   from /opt/kde3/lib64/libkmailprivate.so
#9  0x00002ad27a0bc85f in KMAccount::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#10 0x00002ad27a1732b9 in KMail::NetworkAccount::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#11 0x00002ad27a17fa2d in KMail::ImapAccountBase::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#12 0x00002ad27a187631 in KMAcctCachedImap::qt_invoke ()
   from /opt/kde3/lib64/libkmailprivate.so
#13 0x00002ad27406ca8c in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#14 0x00002ad27406d7a3 in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#15 0x00002ad27408be95 in QTimer::event ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#16 0x00002ad274015a95 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#17 0x00002ad2740166c7 in QApplication::notify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#18 0x00002ad273a170a8 in KApplication::notify ()
   from /opt/kde3/lib64/libkdecore.so.4
#19 0x00002ad27400c005 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#20 0x00002ad273fcc4ed in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#21 0x00002ad27402a7a1 in QEventLoop::enterLoop ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#22 0x00002ad27402a64a in QEventLoop::exec ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#23 0x000000000041537d in main ()
Comment 1 Andreas Kling 2006-08-20 09:47:08 UTC

*** This bug has been marked as a duplicate of 113329 ***