Bug 115508 - kmail crashes on initial mail check
Summary: kmail crashes on initial mail check
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-11-02 07:08 UTC by Andreas Roth
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Roth 2005-11-02 07:08:07 UTC
Version:            (using KDE KDE 3.4.92)
Installed from:    Fedora RPMs
Compiler:          gcc (GCC) 4.0.1 20050727 (Red Hat 4.0.1-5) 
OS:                Linux

When i start kmail the Main Window appears for a very short time. After that the initial mail check is done and kmail crashes immediately. See backtrace below.
I'm using kmail with several IMAP accounts.


Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 46912558635200 (LWP 3141)]
[KCrash handler]
#3  KMAcctImap::processNewMail (this=0x892560, interactive=true)
    at /usr/lib64/qt-3.3/include/qguardedptr.h:117
#4  0x00002aaaaada9de8 in KMail::AccountManager::processNextCheck (
    this=0x7ebb20, _newMail=) at accountmanager.cpp:196
#5  0x00002aaaaada9f66 in KMail::AccountManager::singleCheckMail (
    this=0x7ebb20, account=0x892560, interactive=) at accountmanager.cpp:125
#6  0x00002aaaaadaa0c7 in KMail::AccountManager::checkMail (this=0x7ebb20, 
    _interactive=true) at accountmanager.cpp:312
#7  0x00002aaaaaeace4b in KMMainWidget::qt_invoke (this=0x95bc90, _id=50, 
    _o=0x7ffffff87910) at kmmainwidget.moc:467
#8  0x0000003e50052d3a in QObject::activate_signal ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#9  0x0000003e50360923 in QSignal::signal ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#10 0x0000003e5006c581 in QSignal::activate ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#11 0x0000003e50073d09 in QSingleShotTimer::event ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#12 0x0000003e4fff7cfa in QApplication::internalNotify ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#13 0x0000003e4fff8674 in QApplication::notify ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#14 0x00002aaaae136860 in KApplication::notify ()
   from /opt/kde3/lib64/libkdecore.so.4
#15 0x0000003e4ffedc4c in QEventLoop::activateTimers ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#16 0x0000003e4ffa9d3b in QEventLoop::processEvents ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#17 0x0000003e5000de37 in QEventLoop::enterLoop ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#18 0x0000003e5000dd42 in QEventLoop::exec ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#19 0x0000000000402bc3 in main (argc=) at main.cpp:110
#20 0x00000039a461c3cf in __libc_start_main () from /lib64/libc.so.6
#21 0x0000000000402969 in _start ()
#22 0x00007ffffff88368 in ?? ()
#23 0x0000000000000000 in ?? ()
Comment 1 Tommi Tervo 2005-11-02 15:49:48 UTC

*** This bug has been marked as a duplicate of 113329 ***