Bug 148874 - Kontact crashes when home resides on a Common Internet File System
Summary: Kontact crashes when home resides on a Common Internet File System
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.5
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-16 10:31 UTC by Ronny Standtke
Modified: 2007-08-16 18:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ronny Standtke 2007-08-16 10:31:50 UTC
Version:           1.9.5 (using KDE 3.5.7, Debian Package 4:3.5.7.dfsg.1-1 (lenny/sid))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.18-4-686

In our company the home folders were switched from NFS to CIFS. All KDE users suddenly had severe issues with Kontact. It crashes on startup with the following backtrace:

-----------------
Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1242982720 (LWP 3547)]
[New Thread -1285780592 (LWP 3551)]
[New Thread -1277391984 (LWP 3550)]
[New Thread -1269003376 (LWP 3549)]
[New Thread -1260614768 (LWP 3548)]
[KCrash handler]
#5  0xb509523c in KMFolder::noContent (this=0x820f320)
    at /tmp/buildd/kdepim-3.5.5.dfsg.1/./kmail/kmfolder.cpp:290
#6  0xb5315064 in KMAcctImap::processNewMail (this=0x84ec0b8, 
    interactive=true)
    at /tmp/buildd/kdepim-3.5.5.dfsg.1/./kmail/kmacctimap.cpp:319
#7  0xb51b5130 in KMail::AccountManager::processNextCheck (this=0x84ec350, 
    _newMail=false)
    at /tmp/buildd/kdepim-3.5.5.dfsg.1/./kmail/accountmanager.cpp:197
#8  0xb51b52de in KMail::AccountManager::singleCheckMail (this=0x84ec350, 
    account=0x84ec0b8, interactive=true)
    at /tmp/buildd/kdepim-3.5.5.dfsg.1/./kmail/accountmanager.cpp:125
#9  0xb51b58b5 in KMail::AccountManager::checkMail (this=0x84ec350, 
    _interactive=true)
    at /tmp/buildd/kdepim-3.5.5.dfsg.1/./kmail/accountmanager.cpp:313
#10 0xb5307887 in KMMainWidget::slotCheckMail (this=0x850ad58)
    at /tmp/buildd/kdepim-3.5.5.dfsg.1/./kmail/kmmainwidget.cpp:797
#11 0xb5359971 in KMMainWidget::qt_invoke (this=0x850ad58, _id=50, 
    _o=0xbfccbd88) at ./kmmainwidget.moc:476
#12 0xb6fa0d23 in QObject::activate_signal (this=0x85b1ec0, clist=0x85b1de0, 
    o=0xbfccbd88) at kernel/qobject.cpp:2356
#13 0xb732d360 in QSignal::signal (this=0x85b1ec0, t0=@0x85b1ee8)
    at .moc/debug-shared-mt/moc_qsignal.cpp:100
#14 0xb6fc0d4e in QSignal::activate (this=0x85b1ec0) at kernel/qsignal.cpp:212
#15 0xb6fc87a0 in QSingleShotTimer::event (this=0x85b1e98)
    at kernel/qtimer.cpp:286
#16 0xb6f384e0 in QApplication::internalNotify (this=0xbfccc39c, 
    receiver=0x85b1e98, e=0xbfccc0f8) at kernel/qapplication.cpp:2635
#17 0xb6f3a30f in QApplication::notify (this=0xbfccc39c, receiver=0x85b1e98, 
    e=0xbfccc0f8) at kernel/qapplication.cpp:2358
#18 0xb7654142 in KApplication::notify (this=0xbfccc39c, receiver=0x85b1e98, 
    event=0xbfccc0f8)
    at /tmp/buildd/kdelibs-3.5.7.dfsg.1/./kdecore/kapplication.cpp:550
#19 0xb6ecb595 in QApplication::sendEvent (receiver=0x85b1e98, 
    event=0xbfccc0f8) at ../include/qapplication.h:520
#20 0xb6f2ae6b in QEventLoop::activateTimers (this=0x80a68f8)
    at kernel/qeventloop_unix.cpp:556
#21 0xb6edfa10 in QEventLoop::processEvents (this=0x80a68f8, flags=4)
    at kernel/qeventloop_x11.cpp:389
#22 0xb6f52be6 in QEventLoop::enterLoop (this=0x80a68f8)
    at kernel/qeventloop.cpp:198
#23 0xb6f529f6 in QEventLoop::exec (this=0x80a68f8)
    at kernel/qeventloop.cpp:145
#24 0xb6f3a089 in QApplication::exec (this=0xbfccc39c)
    at kernel/qapplication.cpp:2758
#25 0x0805ac3f in main (argc=)
    at /tmp/buildd/kdepim-3.5.5.dfsg.1/./kontact/src/main.cpp:161
#26 0xb770a030 in __libc_start_main () from /lib/libc.so.6
#27 0x080582b1 in _start () at ../sysdeps/i386/elf/start.S:119
-----------------

After several tries Kontact somehow manages to start up but presents a long list of new mail folders, all named like e.g. cifs4fe4, cifs5c46, cifs5d5f.
This is somewhat catastrophic as the decision to drop NFS in favor of CIFS is probably irrevocable.
Comment 1 Tommi Tervo 2007-08-16 11:28:12 UTC
According to backtrace this crash should be fixed.
http://bugs.kde.org/show_bug.cgi?id=113329
Are you sure that your packages are from KDE 3.5.7? Kmail version should be 1.9.7
Comment 2 Ronny Standtke 2007-08-16 17:50:30 UTC
> Are you sure that your packages are from KDE 3.5.7? Kmail version should be
> 1.9.7

Yes, I am sure, I used the assistant from the help menu! This is current Debian testing. The package kdepim is still 4:3.5.5.dfsg.1-6, while kdelibs is already 4:3.5.7.dfsg.1-1.
Comment 3 Thomas McGuire 2007-08-16 18:19:48 UTC
>The package kdepim is still 4:3.5.5
This bug is fixed in KDEPIM 3.5.7, so you have to upgrade.

*** This bug has been marked as a duplicate of 113329 ***