Bug 126022 - kmail crashed when clicking onto "Check Mail In"
Summary: kmail crashed when clicking onto "Check Mail In"
Status: RESOLVED DUPLICATE of bug 113329
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-21 14:16 UTC by Thorsten Staerk
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Staerk 2006-04-21 14:16:44 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
OS:                Linux

When clicking onto "Check Mail In", kmail crashed with the following full backtrace:


Using host libthread_db library "/lib/tls/libthread_db.so.1".
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
[Thread debugging using libthread_db enabled]
[New Thread 1109216128 (LWP 6231)]
[New Thread 1133173680 (LWP 6719)]
[Thread debugging using libthread_db enabled]
[New Thread 1109216128 (LWP 6231)]
[New Thread 1133173680 (LWP 6719)]
[Thread debugging using libthread_db enabled]
[New Thread 1109216128 (LWP 6231)]
[New Thread 1133173680 (LWP 6719)]
[New Thread 1131072432 (LWP 6718)]
[New Thread 1128971184 (LWP 6717)]
[New Thread 1126869936 (LWP 6716)]
[KCrash handler]
#6  0x42cc90d1 in KMFolder::noContent (this=0x74c084c0) at kmfolder.cpp:288
#7  0x42d5d7d4 in KMAcctImap::processNewMail (this=0x85867a0,
    interactive=true) at kmacctimap.cpp:316
#8  0x42cfe661 in KMail::AccountManager::processNextCheck (this=0x85c8090,
    _newMail=false) at accountmanager.cpp:196
#9  0x42cfe781 in KMail::AccountManager::singleCheckMail (this=0x85c8090,
    account=0x85867a0, interactive=true) at accountmanager.cpp:125
#10 0x42cfe92d in KMail::AccountManager::checkMail (this=0x85c8090,
    _interactive=true) at accountmanager.cpp:312
#11 0x42e1f4d4 in KMMainWidget::slotCheckMail (this=0x8608658)
    at kmmainwidget.cpp:796
#12 0x42e328d9 in KMMainWidget::qt_invoke (this=0x8608658, _id=50,
    _o=0xbf8eef88) at kmmainwidget.moc:472
#13 0x418b6159 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0x418b6600 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0x410e28b5 in KAction::activated (this=0x8679730) at kaction.moc:176
#16 0x410e3701 in KAction::slotActivated (this=0x8679730) at kaction.cpp:1102
#17 0x410e6cab in KAction::qt_invoke (this=0x8679730, _id=15, _o=0xbf8ef0b8)
    at kaction.moc:218
#18 0x410f4787 in KActionMenu::qt_invoke (this=0x8679730, _id=15,
    _o=0xbf8ef0b8) at kactionclasses.moc:1012
#19 0x418b60bc in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0x418b6600 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0x41bfe7bc in QButton::clicked () from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0x41949ff6 in QButton::mouseReleaseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0x411afbcc in KToolBarButton::mouseReleaseEvent (this=0x875ba98,
    e=0xbf8ef5d4) at ktoolbarbutton.cpp:472
#24 0x418eff68 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0x411af128 in KToolBarButton::event (this=0x875ba98, e=0xbf8ef5d4)
    at ktoolbarbutton.cpp:651
#26 0x418569f1 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0x41857b58 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0x413d571d in KApplication::notify (this=0xbf8ef978, receiver=0x875ba98,
    event=0xbf8ef5d4) at kapplication.cpp:550
#29 0x417f1bc8 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0x417f09eb in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0x41804aca in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0x4186d903 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0x4186d7e6 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0x4185633f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0x0805c979 in main (argc=1, argv=0xbf8efb14) at main.cpp:177
Comment 1 Tommi Tervo 2006-04-21 21:03:47 UTC

*** This bug has been marked as a duplicate of 113329 ***