Bug 132669 - Kontact crashes on mail check in cachedimap
Summary: Kontact crashes on mail check in cachedimap
Status: RESOLVED DUPLICATE of bug 117935
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.1
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-20 02:44 UTC by Thomas Kunz
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Kunz 2006-08-20 02:44:50 UTC
Version:           1.9.1 (using KDE 3.5.2, Kubuntu Package 4:3.5.2-0ubuntu18.1 dapper)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.15-23-386

The program crashes sometimes when kmail runs a mailcheck on cachedimap accounts. It is not systematic and happens only in 1-2% of the checks. I have two cachedimap accounts and two pop accounts in kmail which all have the same check interval, all using ssl and for the cachedimap account "show only subscribed folders" activated.

Backtrace:
(no debugging symbols found)
[KCrash handler]
#6  0xb573bf69 in KMAcctCachedImap::processNewMail ()
   from /usr/lib/libkmailprivate.so
#7  0xb573c13a in KMAcctCachedImap::processNewMail ()
   from /usr/lib/libkmailprivate.so
#8  0xb56db2bc in KMail::AccountManager::processNextCheck ()
   from /usr/lib/libkmailprivate.so
#9  0xb56db48e in KMail::AccountManager::singleCheckMail ()
   from /usr/lib/libkmailprivate.so
#10 0xb566767e in KMAccount::mailCheck () from /usr/lib/libkmailprivate.so
#11 0xb56678b7 in KMAccount::qt_invoke () from /usr/lib/libkmailprivate.so
#12 0xb5725fa9 in KMail::NetworkAccount::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#13 0xb5731bbf in KMail::ImapAccountBase::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#14 0xb573a8b4 in KMAcctCachedImap::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#15 0xb705feb9 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#16 0xb7060954 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#17 0xb73f539e in QTimer::timeout () from /usr/lib/libqt-mt.so.3
#18 0xb7084eb1 in QTimer::event () from /usr/lib/libqt-mt.so.3
#19 0xb6ff5e56 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#20 0xb6ff6052 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#21 0xb76f3d7d in KApplication::notify () from /usr/lib/libkdecore.so.4
#22 0xb6f87157 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#23 0xb6fe7843 in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#24 0xb6f9af67 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#25 0xb700e947 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#26 0xb700e86a in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#27 0xb6ff4965 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#28 0x0805ab01 in ?? ()
#29 0xbfd62fe0 in ?? ()
#30 0x00000001 in ?? ()
#31 0x00000001 in ?? ()
#32 0x00000000 in ?? ()
Comment 1 Andreas Kling 2006-08-20 09:47:30 UTC

*** This bug has been marked as a duplicate of 113329 ***
Comment 2 Tommi Tervo 2006-09-06 11:01:41 UTC
...
Comment 3 Tommi Tervo 2006-09-06 11:01:53 UTC

*** This bug has been marked as a duplicate of 117935 ***