Bug 253031 - Crash of the IMAP resource (Akonadi::Entity::Entity, assignEntityPrivate)
Summary: Crash of the IMAP resource (Akonadi::Entity::Entity, assignEntityPrivate)
Status: RESOLVED UNMAINTAINED
Alias: None
Product: Akonadi
Classification: Unclassified
Component: libakonadi (show other bugs)
Version: 4.9
Platform: Compiled Sources Linux
: NOR crash with 40 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 258430 259924 264994 266108 275893 280149 280961 282060 283341 283593 284022 288785 290134 290342 292983 293311 293820 294453 297038 299330 301006 301110 306555 308691 331499 338338 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-02 16:05 UTC by LuHe
Modified: 2017-01-07 22:42 UTC (History)
33 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.95 KB, text/plain)
2011-01-13 19:42 UTC, desaparecido
Details
New crash information added by DrKonqi (5.30 KB, text/plain)
2011-09-27 10:21 UTC, Alexey Bychko
Details
New crash information added by DrKonqi (6.09 KB, text/plain)
2011-10-29 00:57 UTC, Richard de Vries
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LuHe 2010-10-02 16:05:47 UTC
Application: akonadi_imap_resource (0.1)
KDE Platform Version: 4.5.70 (4.6 >= 20100927) (Compiled from sources)
Qt Version: 4.7.0
Operating System: Linux 2.6.34.6-54.fc13.x86_64 x86_64
Distribution: "Fedora release 13 (Goddard)"

-- Information about the crash:
- What I was doing when the application crashed:
The resource crashes everytime when I want to fetch my mails from my Gmail account. This happens also in disconnected mode.

I can reproduce this with KDE compiled from SVN (revision 1181712) in a seperate user account *and* with the latest beta of Kmail on the Fedora 14 Alpha KDE Live CD with the kde-redhat repository enabled.

- Custom settings of the application:
Gmail account configured

The crash can be reproduced every time.

-- Backtrace:
Application: Akonadi Resource (akonadi_imap_resource), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f9d68fa8760 (LWP 27551))]

Thread 3 (Thread 0x7f9d5e360710 (LWP 27553)):
#0  0x0000003fb88d7de3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003fbac3f849 in ?? () from /lib64/libglib-2.0.so.0
#2  0x0000003fbac3fc9c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007f9d6e3ca5bc in QEventDispatcherGlib::processEvents (this=0x26f3160, flags=...) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:417
#4  0x00007f9d6e38d79c in QEventLoop::processEvents (this=0x7f9d5e35fd80, flags=...) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qeventloop.cpp:149
#5  0x00007f9d6e38d8f2 in QEventLoop::exec (this=0x7f9d5e35fd80, flags=...) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qeventloop.cpp:201
#6  0x00007f9d6e26943d in QThread::exec (this=0x27279f0) at /home/kde-devel/kdesvn/qt-copy/src/corelib/thread/qthread.cpp:490
#7  0x00007f9d6cc33b43 in KIMAP::SessionThread::run (this=0x27279f0) at /home/kde-devel/kdesvn/kdepimlibs/kimap/sessionthread.cpp:166
#8  0x00007f9d6e26bcf4 in QThreadPrivate::start (arg=0x27279f0) at /home/kde-devel/kdesvn/qt-copy/src/corelib/thread/qthread_unix.cpp:266
#9  0x0000003eaf407761 in start_thread (arg=0x7f9d5e360710) at pthread_create.c:301
#10 0x0000003fb88e14ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f9d5d95f710 (LWP 27554)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1  0x00007f9d6e26d257 in QWaitConditionPrivate::wait (this=0x282a3b0, time=30000) at /home/kde-devel/kdesvn/qt-copy/src/corelib/thread/qwaitcondition_unix.cpp:86
#2  0x00007f9d6e26d01b in QWaitCondition::wait (this=0x282b228, mutex=0x282b220, time=30000) at /home/kde-devel/kdesvn/qt-copy/src/corelib/thread/qwaitcondition_unix.cpp:160
#3  0x00007f9d6e25cd46 in QThreadPoolThread::run (this=0x2827890) at /home/kde-devel/kdesvn/qt-copy/src/corelib/concurrent/qthreadpool.cpp:140
#4  0x00007f9d6e26bcf4 in QThreadPrivate::start (arg=0x2827890) at /home/kde-devel/kdesvn/qt-copy/src/corelib/thread/qthread_unix.cpp:266
#5  0x0000003eaf407761 in start_thread (arg=0x7f9d5d95f710) at pthread_create.c:301
#6  0x0000003fb88e14ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f9d68fa8760 (LWP 27551)):
[KCrash Handler]
#6  ref (one=..., other=...) at /home/kde-devel/qt4/include/QtCore/qatomic_x86_64.h:121
#7  QSharedDataPointer (one=..., other=...) at /home/kde-devel/qt4/include/QtCore/qshareddata.h:93
#8  assignEntityPrivate (one=..., other=...) at /home/kde-devel/kdesvn/kdepimlibs/akonadi/entity.cpp:49
#9  0x00007f9d6ea36214 in Akonadi::Entity::Entity (this=<value optimized out>, other=<value optimized out>) at /home/kde-devel/kdesvn/kdepimlibs/akonadi/entity.cpp:56
#10 0x000000000041fe89 in ImapResource::onIdleCollectionFetchDone (this=0x26d4970, job=<value optimized out>) at /home/kde-devel/kdesvn/kdepim/runtime/resources/imap/imapresource.cpp:485
#11 0x0000000000420e35 in ImapResource::qt_metacall (this=0x26d4970, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0x7fffc8da60e0)
    at /home/kde-devel/kdesvn/build/kdepim/runtime/resources/imap/imapresource.moc:135
#12 0x00007f9d6e3981e7 in QMetaObject::metacall (object=0x26d4970, cl=QMetaObject::InvokeMetaMethod, idx=62, argv=0x7fffc8da60e0)
    at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qmetaobject.cpp:237
#13 0x00007f9d6e3ad957 in QMetaObject::activate (sender=0x281d0b0, m=0x7f9d6b26c660, local_signal_index=3, argv=0x7fffc8da60e0) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qobject.cpp:3280
#14 0x00007f9d6aee16c2 in KJob::result (this=<value optimized out>, _t1=0x281d0b0) at /home/kde-devel/kdesvn/build/kdelibs/kdecore/kjob.moc:194
#15 0x00007f9d6aee1980 in KJob::emitResult (this=0x281d0b0) at /home/kde-devel/kdesvn/kdelibs/kdecore/jobs/kjob.cpp:312
#16 0x00007f9d6ead0261 in delayedEmitResult (this=0x281d0b0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x2822c90) at /home/kde-devel/kdesvn/kdepimlibs/akonadi/job.cpp:143
#17 Akonadi::Job::qt_metacall (this=0x281d0b0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x2822c90) at /home/kde-devel/kdesvn/build/kdepimlibs/akonadi/job.moc:91
#18 0x00007f9d6ea644a5 in Akonadi::CollectionFetchJob::qt_metacall (this=0x281d0b0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x2822c90)
    at /home/kde-devel/kdesvn/build/kdepimlibs/akonadi/collectionfetchjob.moc:73
#19 0x00007f9d6e3981e7 in QMetaObject::metacall (object=0x281d0b0, cl=QMetaObject::InvokeMetaMethod, idx=34, argv=0x2822c90) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qmetaobject.cpp:237
#20 0x00007f9d6e3a7db4 in QMetaCallEvent::placeMetaCall (this=0x27e52f0, object=0x281d0b0) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qobject.cpp:534
#21 0x00007f9d6e3a90c7 in QObject::event (this=0x281d0b0, e=0x27e52f0) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qobject.cpp:1219
#22 0x00007f9d6d3f1f6c in QApplicationPrivate::notify_helper (this=0x25d4bb0, receiver=0x281d0b0, e=0x27e52f0) at /home/kde-devel/kdesvn/qt-copy/src/gui/kernel/qapplication.cpp:4397
#23 0x00007f9d6d3ef40b in QApplication::notify (this=0x7fffc8da6f60, receiver=0x281d0b0, e=0x27e52f0) at /home/kde-devel/kdesvn/qt-copy/src/gui/kernel/qapplication.cpp:3799
#24 0x00007f9d6b4b3a36 in KApplication::notify (this=0x7fffc8da6f60, receiver=0x281d0b0, event=0x27e52f0) at /home/kde-devel/kdesvn/kdelibs/kdeui/kernel/kapplication.cpp:311
#25 0x00007f9d6e38fd5e in QCoreApplication::notifyInternal (this=0x7fffc8da6f60, receiver=0x281d0b0, event=0x27e52f0) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qcoreapplication.cpp:732
#26 0x00007f9d6e393cb7 in QCoreApplication::sendEvent (receiver=0x281d0b0, event=0x27e52f0) at ../../include/QtCore/../../../../qt-copy/src/corelib/kernel/qcoreapplication.h:215
#27 0x00007f9d6e390fbf in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x25ba720) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qcoreapplication.cpp:1373
#28 0x00007f9d6e390bdf in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qcoreapplication.cpp:1266
#29 0x00007f9d6e3cacef in QCoreApplication::sendPostedEvents () at ../../include/QtCore/../../../../qt-copy/src/corelib/kernel/qcoreapplication.h:220
#30 0x00007f9d6e3c9c8d in postEventSourceDispatch (s=0x25d86c0) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:277
#31 0x0000003fbac3bd02 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#32 0x0000003fbac3fae8 in ?? () from /lib64/libglib-2.0.so.0
#33 0x0000003fbac3fc9c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#34 0x00007f9d6e3ca599 in QEventDispatcherGlib::processEvents (this=0x25b9dd0, flags=...) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:415
#35 0x00007f9d6d4cd670 in QGuiEventDispatcherGlib::processEvents (this=0x25b9dd0, flags=...) at /home/kde-devel/kdesvn/qt-copy/src/gui/kernel/qguieventdispatcher_glib.cpp:204
#36 0x00007f9d6e38d79c in QEventLoop::processEvents (this=0x7fffc8da6ee0, flags=...) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qeventloop.cpp:149
#37 0x00007f9d6e38d8f2 in QEventLoop::exec (this=0x7fffc8da6ee0, flags=...) at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qeventloop.cpp:201
#38 0x00007f9d6e39045a in QCoreApplication::exec () at /home/kde-devel/kdesvn/qt-copy/src/corelib/kernel/qcoreapplication.cpp:1009
#39 0x00007f9d6d3eef80 in QApplication::exec () at /home/kde-devel/kdesvn/qt-copy/src/gui/kernel/qapplication.cpp:3673
#40 0x00007f9d6eaeb362 in Akonadi::ResourceBase::init (r=0x26d4970) at /home/kde-devel/kdesvn/kdepimlibs/akonadi/resourcebase.cpp:282
#41 0x000000000041f978 in init<ImapResource> (argc=<value optimized out>, argv=<value optimized out>) at /home/kde-devel/kde/include/akonadi/resourcebase.h:187
#42 main (argc=<value optimized out>, argv=<value optimized out>) at /home/kde-devel/kdesvn/kdepim/runtime/resources/imap/imapresource.cpp:579

Reported using DrKonqi
Comment 1 Radu 2010-12-15 18:26:10 UTC
I can't reproduce this bug in kde 4.6 beta 1, on openSuse 11.4 Milestone 4. It might have been fixed.
Comment 2 Volker Krause 2010-12-30 14:05:22 UTC
*** Bug 259924 has been marked as a duplicate of this bug. ***
Comment 3 desaparecido 2011-01-13 19:42:06 UTC
Created attachment 55976 [details]
New crash information added by DrKonqi

akonadi_imap_resource (0.1) on KDE Platform 4.6.41 (4.7 >= 20110106) using Qt 4.7.1

- What I was doing when the application crashed:
start with IMAP gmail disconnected account, only 1 fail of 3 account, same config for 3 accounts. In my INBOX of fail account I have "nothing" even that is marked like i have e-mails (with another email reader there's no problem to read that INBOX).

- Custom settings of the application: 
IMAP disconnected gmail account, with KDE snapshot 4.6.41

-- Backtrace (Reduced):
#7  QSharedDataPointer (one=..., other=...) at /usr/include/QtCore/qshareddata.h:93
#8  assignEntityPrivate (one=..., other=...) at /home/build/build/i686/kdepimlibs/src/kdepimlibs/akonadi/entity.cpp:49
#9  0xb75d0b2a in Akonadi::Entity::Entity (this=0xbfac176c, other=...) at /home/build/build/i686/kdepimlibs/src/kdepimlibs/akonadi/entity.cpp:56
#10 0xb75fe6f4 in Akonadi::Collection::Collection (this=0xbfac176c, other=...) at /home/build/build/i686/kdepimlibs/src/kdepimlibs/akonadi/collection.cpp:72
#11 0x080654b2 in ImapResource::onIdleCollectionFetchDone (this=0x8cc9550, job=0x8e49170) at /home/build/build/i686/kdepim/src/kdepim/runtime/resources/imap/imapresource.cpp:503
Comment 4 Christophe Giboudeaux 2011-07-13 14:52:06 UTC
*** Bug 275893 has been marked as a duplicate of this bug. ***
Comment 5 Christophe Giboudeaux 2011-07-13 14:52:16 UTC
*** Bug 266108 has been marked as a duplicate of this bug. ***
Comment 6 Christophe Giboudeaux 2011-08-28 16:20:32 UTC
*** Bug 280149 has been marked as a duplicate of this bug. ***
Comment 7 Christophe Giboudeaux 2011-08-28 22:19:20 UTC
*** Bug 280961 has been marked as a duplicate of this bug. ***
Comment 8 Kevin Ottens 2011-09-17 09:13:50 UTC
Is it still happening for you with 4.7.x? I've been unable to reproduce that one, it just works for me.

In case you still experience this please feel free to reopen. In such a case, we would need much more information like the actual IMAP server used and so on. In that report it is actually unclear if the problem happens on the GMail or Exchange resource.

Regarding GMail, there's an actual bug (bug:258635 but with different symptom) patch is coming, but apart from that I could download 40k from several folders just fine and read them.
Comment 9 Christoph Feck 2011-09-17 10:47:15 UTC
Well, the last two duplicates are from 4.7, so it is still happening.
Comment 10 Dirk Schoebel 2011-09-17 10:59:09 UTC
It obviously (as the last duplicate shows) crashes for me with 4.7.x, the current, still crashing version, is 4.7.1.
The IMAP server i'm using is cyrus imapd 2.3.16.
I have 3 accounts simultanously on the server and the only account crashing is the one providing kolab resources (calendar, contacts, notes).
Comment 11 Alexey Bychko 2011-09-27 10:21:32 UTC
Created attachment 64005 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.7) on KDE Platform 4.7.1 (4.7.1) using Qt 4.7.4

- What I was doing when the application crashed:
system login -> entered kwallet password -> akonadi resource crashed. actually
actually, gmail account in kmail settings has "can't start" state. so, unable to sync imap folders

-- Backtrace (Reduced):
#7  0x00007f08057eb064 in Akonadi::Entity::Entity(Akonadi::Entity const&) () from /usr/lib64/libakonadi-kde.so.4
#8  0x000000000041bcc6 in ImapResource::onIdleCollectionFetchDone (this=0x13f35f0, job=<optimized out>) at /var/tmp/portage/kde-base/kdepim-runtime-4.7.1/work/kdepim-runtime-4.7.1/resources/imap/imapresource.cpp:504
#9  0x000000000041c445 in ImapResource::qt_metacall (this=0x13f35f0, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0x7fff3e840f60) at /var/tmp/portage/kde-base/kdepim-runtime-4.7.1/work/kdepim-runtime-4.7.1_build/resources/imap/imapresource.moc:135
[...]
#11 0x00007f0802082bc2 in KJob::result(KJob*) () from /usr/lib64/libkdecore.so.5
#12 0x00007f0802082c00 in KJob::emitResult() () from /usr/lib64/libkdecore.so.5
Comment 12 Dirk Schoebel 2011-10-02 17:04:37 UTC
> In case you still experience this please feel free to reopen. In such a case,
> we would need much more information like the actual IMAP server used and so on.
> In that report it is actually unclear if the problem happens on the GMail or
> Exchange resource.

I can't reopen, please someone being authorized to do so please reopen this bug. I'll gladly provide more information, as long as this will be resolved rather sooner than later, since it is really annoying.
Comment 13 Alexey Bychko 2011-10-02 17:43:20 UTC
it works for me for several days after deleting gmail imap account and re-creating
Comment 14 Christophe Giboudeaux 2011-10-04 19:49:14 UTC
*** Bug 283341 has been marked as a duplicate of this bug. ***
Comment 15 Richard de Vries 2011-10-29 00:57:12 UTC
Created attachment 65001 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.7) on KDE Platform 4.7.2 (4.7.2) using Qt 4.7.4

- What I was doing when the application crashed:

I used the wizard to set up KMail for Gmail. This produced this bug. I then tried several other things, like removing the account and setting it up manually. Sometimes it fetches all mail headers, sometimes it doesn't, but it crashes everytime. After the crash, KMail shows the mailheaders it has retrieved, but it won't fetch the content or update mail folders. It just does nothing (no error messages, for example).
I should perhaps add that I installed Kubuntu from the mac-iso.

-- Backtrace (Reduced):
#6  QSharedDataPointer (o=..., this=0x7fffd50ecee0) at /usr/include/qt4/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at ../../akonadi/entity.cpp:49
#8  0x00007f7ca7979934 in Akonadi::Entity::Entity (this=<optimized out>, other=<optimized out>) at ../../akonadi/entity.cpp:56
#9  0x000000000041959f in ImapResource::onIdleCollectionFetchDone (this=0x90dba0, job=0xb590d0) at ../../../resources/imap/imapresource.cpp:504
#10 0x000000000041a235 in ImapResource::qt_metacall (this=0x90dba0, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0x7fffd50ed0e0) at ./imapresource.moc:135
Comment 16 Christophe Giboudeaux 2011-11-17 23:46:52 UTC
*** Bug 258430 has been marked as a duplicate of this bug. ***
Comment 17 Christophe Giboudeaux 2011-11-17 23:47:04 UTC
*** Bug 264994 has been marked as a duplicate of this bug. ***
Comment 18 Richard de Vries 2011-11-18 15:33:47 UTC
(In reply to comment #15)
> Created an attachment (id=65001) [details]
> New crash information added by DrKonqi
> 
> akonadi_imap_resource (4.7) on KDE Platform 4.7.2 (4.7.2) using Qt 4.7.4
> 
> - What I was doing when the application crashed:
> 
> I used the wizard to set up KMail for Gmail. This produced this bug. I then
> tried several other things, like removing the account and setting it up
> manually. Sometimes it fetches all mail headers, sometimes it doesn't, but it
> crashes everytime. After the crash, KMail shows the mailheaders it has
> retrieved, but it won't fetch the content or update mail folders. It just does
> nothing (no error messages, for example).
> I should perhaps add that I installed Kubuntu from the mac-iso.
> 
> -- Backtrace (Reduced):
> #6  QSharedDataPointer (o=..., this=0x7fffd50ecee0) at
> /usr/include/qt4/QtCore/qshareddata.h:93
> #7  assignEntityPrivate (one=..., other=...) at ../../akonadi/entity.cpp:49
> #8  0x00007f7ca7979934 in Akonadi::Entity::Entity (this=<optimized out>,
> other=<optimized out>) at ../../akonadi/entity.cpp:56
> #9  0x000000000041959f in ImapResource::onIdleCollectionFetchDone
> (this=0x90dba0, job=0xb590d0) at ../../../resources/imap/imapresource.cpp:504
> #10 0x000000000041a235 in ImapResource::qt_metacall (this=0x90dba0,
> _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0x7fffd50ed0e0) at
> ./imapresource.moc:135

After trying a few times more, I got my gmail-account to work. I have no idea as to what I did right this time, or whether some component was updated resolving the issue. 'Interval mail checking' is not working, though; I have to manually check my mail. This may be an unrelated issue, of course.
Comment 19 Christophe Giboudeaux 2011-12-13 09:33:40 UTC
*** Bug 288785 has been marked as a duplicate of this bug. ***
Comment 20 Christophe Giboudeaux 2012-01-02 12:34:31 UTC
*** Bug 290342 has been marked as a duplicate of this bug. ***
Comment 21 Christophe Giboudeaux 2012-01-02 13:49:23 UTC
*** Bug 290134 has been marked as a duplicate of this bug. ***
Comment 22 David Faure 2012-01-05 11:32:55 UTC
*** Bug 282060 has been marked as a duplicate of this bug. ***
Comment 23 David Faure 2012-01-05 11:33:36 UTC
*** Bug 283593 has been marked as a duplicate of this bug. ***
Comment 24 Christophe Giboudeaux 2012-02-03 13:06:52 UTC
*** Bug 292983 has been marked as a duplicate of this bug. ***
Comment 25 Christophe Giboudeaux 2012-02-04 17:53:41 UTC
*** Bug 293311 has been marked as a duplicate of this bug. ***
Comment 26 Christophe Giboudeaux 2012-03-30 13:33:17 UTC
*** Bug 297038 has been marked as a duplicate of this bug. ***
Comment 27 Christophe Giboudeaux 2012-03-30 13:33:28 UTC
*** Bug 294453 has been marked as a duplicate of this bug. ***
Comment 28 Christophe Giboudeaux 2012-03-30 13:33:37 UTC
*** Bug 293820 has been marked as a duplicate of this bug. ***
Comment 29 Christophe Giboudeaux 2012-05-09 13:32:31 UTC
*** Bug 299330 has been marked as a duplicate of this bug. ***
Comment 30 Jekyll Wu 2012-06-02 00:00:29 UTC
*** Bug 301006 has been marked as a duplicate of this bug. ***
Comment 31 Jekyll Wu 2012-07-06 19:13:30 UTC
*** Bug 301110 has been marked as a duplicate of this bug. ***
Comment 32 Myriam Schweingruber 2012-08-18 22:00:59 UTC
*** Bug 284022 has been marked as a duplicate of this bug. ***
Comment 33 Myriam Schweingruber 2012-09-10 18:56:54 UTC
*** Bug 306555 has been marked as a duplicate of this bug. ***
Comment 34 Myriam Schweingruber 2012-09-10 18:57:39 UTC
Confirmed by duplicates.
Comment 35 Christophe Giboudeaux 2012-09-13 14:39:53 UTC
Did anyone reproduce  this crash with kdepim-runtime 4.9 ?
Comment 36 Peder Chr. Nørgaard 2012-09-18 13:44:04 UTC
Yes, I just verified (i Kmail, by trying to save a new mail as a draft), that the bug is still alive and kicking and easy to reproduce.  This was done on a Kubuntu 12:10 Beta 1 system.

% dpkg -l kmail
ii  kmail                                   4:4.9.1-0ubuntu1         amd64                    full featured graphical email client
Comment 37 Jekyll Wu 2012-11-08 06:58:01 UTC
*** Bug 308691 has been marked as a duplicate of this bug. ***
Comment 38 Jekyll Wu 2014-03-10 09:03:39 UTC
*** Bug 331499 has been marked as a duplicate of this bug. ***
Comment 39 Christoph Feck 2014-08-17 20:04:14 UTC
*** Bug 338338 has been marked as a duplicate of this bug. ***
Comment 40 Denis Kurz 2016-09-24 20:42:22 UTC
This bug has only been reported for versions older than KDEPIM 4.14 (at most akonadi-1.3). Can anyone tell if this bug still present?

If noone confirms this bug for a recent version of akonadi (part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 41 Denis Kurz 2017-01-07 22:21:45 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.