Bug 259924 - Crash at the end of automatic Akonadi migration from KDE 4.5
Summary: Crash at the end of automatic Akonadi migration from KDE 4.5
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-15 09:24 UTC by René Krell
Modified: 2010-12-30 14:05 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description René Krell 2010-12-15 09:24:19 UTC
Application: akonadi_imap_resource (0.1)
KDE Platform Version: 4.5.85 (4.6 Beta2)
Qt Version: 4.7.1
Operating System: Linux 2.6.34.7-0.5-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
After starting Kontact with KMail the migration tool was automatically launched, reporting a successful migration. Even before that report windows of the migration tool closes I get this crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Akonadi Resource (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f50bb914760 (LWP 22039))]

Thread 2 (Thread 0x7f50a953d710 (LWP 22041)):
#0  0x00007f50b74886b3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f50b5df3fd4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f50b5df4510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f50badbfae6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007f50bad94262 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f50bad94475 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f50baca71a4 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007f50b9a25c43 in ?? () from /usr/lib64/libkimap.so.4
#8  0x00007f50baca9a1e in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f50b6d4fa4f in start_thread (arg=0x7f50a953d710) at pthread_create.c:297
#10 0x00007f50b749182d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f50bb914760 (LWP 22039)):
[KCrash Handler]
#6  QSharedDataPointer (one=..., other=...) at /usr/include/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at /usr/src/debug/kdepimlibs-4.5.85/akonadi/entity.cpp:49
#8  0x00007f50bb3d4da4 in Akonadi::Entity::Entity (this=<value optimized out>, other=<value optimized out>) at /usr/src/debug/kdepimlibs-4.5.85/akonadi/entity.cpp:56
#9  0x0000000000421a26 in _start ()

Possible duplicates by query: bug 258684, bug 258430, bug 253031, bug 250078.

Reported using DrKonqi
Comment 1 Volker Krause 2010-12-30 14:05:22 UTC

*** This bug has been marked as a duplicate of bug 253031 ***