Bug 282060 - Crash when deleting IMAP messages
Summary: Crash when deleting IMAP messages
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 4.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 278276 278799 280137 280728 287011 290189 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-15 08:02 UTC by Thomas Tanghus
Modified: 2012-01-05 11:32 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Tanghus 2011-09-15 08:02:17 UTC
Application: kontact (4.7.0 )
KDE Platform Version: 4.7.00 (4.7.0)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

I had just copied an online IMAP folder from one account (Gmail) to another account (Courier). After that I selected all messages in the original folder (Gmail) and pushed the 'move to trash' icon (which is configured to move msgs to the Gmail trash folder). Crash.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76d6730 (LWP 3106))]

Thread 3 (Thread 0xb6938b70 (LWP 3107)):
#0  0x006bb416 in __kernel_vsyscall ()
#1  0x0677348c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0x018d73fd in __pthread_cond_wait (cond=0x4a9b7f0, mutex=0x4a9b7d8) at forward.c:139
#3  0x044e5b57 in scavengerThread (context=0x4a96700) at wtf/FastMalloc.cpp:2378
#4  WTF::TCMalloc_PageHeap::runScavengerThread (context=0x4a96700) at wtf/FastMalloc.cpp:1497
#5  0x0676ee99 in start_thread (arg=0xb6938b70) at pthread_create.c:304
#6  0x018c973e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xb49c6b70 (LWP 10968)):
#0  0x018d765b in pthread_mutex_unlock (mutex=0x92fb49c) at forward.c:184
#1  0x01de2648 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x01de303a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01de3524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x00c69577 in QEventDispatcherGlib::processEvents (this=0x91f09c8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00c3b289 in QEventLoop::processEvents (this=0xb49c6270, flags=...) at kernel/qeventloop.cpp:149
#6  0x00c3b522 in QEventLoop::exec (this=0xb49c6270, flags=...) at kernel/qeventloop.cpp:201
#7  0x00b452a0 in QThread::exec (this=0x9000df8) at thread/qthread.cpp:492
#8  0x00c1cfdb in QInotifyFileSystemWatcherEngine::run (this=0x9000df8) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00b47da2 in QThreadPrivate::start (arg=0x9000df8) at thread/qthread_unix.cpp:320
#10 0x0676ee99 in start_thread (arg=0xb49c6b70) at pthread_create.c:304
#11 0x018c973e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb76d6730 (LWP 3106)):
[KCrash Handler]
#7  QSharedDataPointer (one=..., other=...) at /usr/include/qt4/QtCore/qshareddata.h:93
#8  assignEntityPrivate (one=..., other=...) at ../../akonadi/entity.cpp:49
#9  0x0896e18a in Akonadi::Entity::Entity (this=0xbfe6fae8, other=...) at ../../akonadi/entity.cpp:56
#10 0x0899e7f4 in Akonadi::Collection::Collection (this=0xbfe6fae8, other=...) at ../../akonadi/collection.cpp:72
#11 0x066d26bc in MailCommon::FolderCollection::collection() const () from /usr/lib/libmailcommon.so.4
#12 0x04d6bba8 in KMMainWidget::trashMessageSelected(long) () from /usr/lib/libkmailprivate.so.4
#13 0x04d6bd71 in KMMainWidget::slotTrashSelectedMessages() () from /usr/lib/libkmailprivate.so.4
#14 0x04d81fe1 in KMMainWidget::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkmailprivate.so.4
#15 0x00c426ba in QMetaObject::metacall (object=0x90997e0, cl=QMetaObject::InvokeMetaMethod, idx=31, argv=0xbfe6fc58) at kernel/qmetaobject.cpp:237
#16 0x00c524ff in QMetaObject::activate (sender=0x913ee50, m=0x17d93f8, local_signal_index=1, argv=0xbfe6fc58) at kernel/qobject.cpp:3287
#17 0x00e9f8d9 in QAction::triggered (this=0x913ee50, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#18 0x00e9fb38 in QAction::activate (this=0x913ee50, event=QAction::Trigger) at kernel/qaction.cpp:1257
#19 0x0137cce2 in trigger (this=0x91e52b0) at ../../include/QtGui/../../src/gui/kernel/qaction.h:218
#20 QToolButton::nextCheckState (this=0x91e52b0) at widgets/qtoolbutton.cpp:1147
#21 0x012abb53 in QAbstractButtonPrivate::click (this=0xc1db580) at widgets/qabstractbutton.cpp:528
#22 0x012abe4e in QAbstractButton::mouseReleaseEvent (this=0x91e52b0, e=0xbfe703e4) at widgets/qabstractbutton.cpp:1121
#23 0x0137cdcc in QToolButton::mouseReleaseEvent (this=0x91e52b0, e=0xbfe703e4) at widgets/qtoolbutton.cpp:721
#24 0x00eff13a in QWidget::event (this=0x91e52b0, event=0xbfe703e4) at kernel/qwidget.cpp:8259
#25 0x012aae9e in QAbstractButton::event (this=0x91e52b0, e=0xbfe703e4) at widgets/qabstractbutton.cpp:1080
#26 0x0137e4fa in QToolButton::event (this=0x91e52b0, event=0xbfe703e4) at widgets/qtoolbutton.cpp:1163
#27 0x00ea6d24 in QApplicationPrivate::notify_helper (this=0x8b91028, receiver=0x91e52b0, e=0xbfe703e4) at kernel/qapplication.cpp:4462
#28 0x00eac201 in QApplication::notify (this=0xbfe70c74, receiver=0x91e52b0, e=0xbfe703e4) at kernel/qapplication.cpp:4023
#29 0x004e293a in KApplication::notify (this=0xbfe70c74, receiver=0x91e52b0, event=0xbfe703e4) at ../../kdeui/kernel/kapplication.cpp:311
#30 0x00c3c0bb in QCoreApplication::notifyInternal (this=0xbfe70c74, receiver=0x91e52b0, event=0xbfe703e4) at kernel/qcoreapplication.cpp:731
#31 0x00ea7c3b in sendSpontaneousEvent (receiver=0x91e52b0, event=0xbfe703e4, alienWidget=0x91e52b0, nativeWidget=0x8cde308, buttonDown=0x17f5c60, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#32 QApplicationPrivate::sendMouseEvent (receiver=0x91e52b0, event=0xbfe703e4, alienWidget=0x91e52b0, nativeWidget=0x8cde308, buttonDown=0x17f5c60, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3120
#33 0x00f3304c in QETWidget::translateMouseEvent (this=0x8cde308, event=0xbfe7090c) at kernel/qapplication_x11.cpp:4558
#34 0x00f319b5 in QApplication::x11ProcessEvent (this=0xbfe70c74, event=0xbfe7090c) at kernel/qapplication_x11.cpp:3680
#35 0x00f5d5f4 in x11EventSourceDispatch (s=0x8b96240, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#36 0x01de2aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#37 0x01de3270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01de3524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x00c6953c in QEventDispatcherGlib::processEvents (this=0x8b4dac8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#40 0x00f5d1e5 in QGuiEventDispatcherGlib::processEvents (this=0x8b4dac8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00c3b289 in QEventLoop::processEvents (this=0xbfe70bd4, flags=...) at kernel/qeventloop.cpp:149
#42 0x00c3b522 in QEventLoop::exec (this=0xbfe70bd4, flags=...) at kernel/qeventloop.cpp:201
#43 0x00c3fecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#44 0x00ea48e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#45 0x0804b587 in _start ()

This bug may be a duplicate of or related to bug 280137, bug 278799.

Possible duplicates by query: bug 282036, bug 280961, bug 280149, bug 280137, bug 278824.

Reported using DrKonqi
Comment 1 Christophe Marin 2011-09-24 15:21:47 UTC
*** Bug 280137 has been marked as a duplicate of this bug. ***
Comment 2 Christophe Marin 2011-09-24 15:39:18 UTC
*** Bug 278799 has been marked as a duplicate of this bug. ***
Comment 3 Christophe Marin 2011-09-24 15:41:41 UTC
*** Bug 278276 has been marked as a duplicate of this bug. ***
Comment 4 Allen Winter 2011-11-13 01:37:43 UTC
looks like this may have been fixed in the meantime.

is anyone still experiencing this crash with 4.7.2 or above?
Comment 5 Christophe Marin 2011-11-19 20:02:41 UTC
*** Bug 287011 has been marked as a duplicate of this bug. ***
Comment 6 Christophe Marin 2011-11-19 20:03:07 UTC
(In reply to comment #4)
> looks like this may have been fixed in the meantime.
> 
> is anyone still experiencing this crash with 4.7.2 or above?

287011 happened with 4.7.3
Comment 7 Christophe Marin 2011-12-13 23:59:17 UTC
*** Bug 280728 has been marked as a duplicate of this bug. ***
Comment 8 Christophe Marin 2012-01-02 12:35:55 UTC
*** Bug 290189 has been marked as a duplicate of this bug. ***
Comment 9 Christophe Marin 2012-01-02 12:36:48 UTC
from bug 290189

-- Information about the crash:
- What I was doing when the application crashed:
Akonadi crash happens short after KDE login, at first attempt to read mails.

[...]

Akonadi is requesting the kwallet password: "Das Programm "Googlemail 1 vom Typ
IMAP-E-Mail Server" hat die Öffnung der digitalen Brieftasche "kwallet"
angefordert. Bitte geben Sie unten das Passwort dafür ein."

The crash happens just after entering the kwallet password. 

At next trial to receive Emails from googlemail account Akonadi is requesting
the kwallet password again. Access to the kwallet is not stored in the case,
Akonadi is crashing.
Comment 10 David Faure 2012-01-05 11:32:55 UTC

*** This bug has been marked as a duplicate of bug 253031 ***