Bug 290342 - I-Map-crash
Summary: I-Map-crash
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-01 18:45 UTC by Dieter Roemer
Modified: 2012-01-02 12:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dieter Roemer 2012-01-01 18:45:48 UTC
Application: akonadi_imap_resource (4.7)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: Crash happened during system start, when the i-map-server started and tryed to connect to t-online.

The crash can be reproduced every time.

-- Backtrace:
Application: T-Online of type IMAP-E-Mail-Server (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb823def780 (LWP 3633))]

Thread 2 (Thread 0x7fb811dc3700 (LWP 4408)):
#0  0x00007fff1974592c in clock_gettime ()
#1  0x00007fb81e42207b in __GI_clock_gettime (clock_id=1, tp=0x7fb811dc2b50) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007fb8231a0074 in do_gettime (frac=0x7fb811dc2b68, sec=0x7fb811dc2b60) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fb8232626ed in QTimerInfoList::updateCurrentTime (this=0x19abfe0) at kernel/qeventdispatcher_unix.cpp:339
#5  0x00007fb823262a33 in QTimerInfoList::timerWait (this=0x19abfe0, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#6  0x00007fb82326144c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fb811dc2c4c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fb8232614f5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fb81e16bff2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007fb81e16cdfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007fb81e16d429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fb823261f3e in QEventDispatcherGlib::processEvents (this=0x19f0ea0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#12 0x00007fb823235cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fb823235ef7 in QEventLoop::exec (this=0x7fb811dc2de0, flags=...) at kernel/qeventloop.cpp:201
#14 0x00007fb82314d27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#15 0x00007fb821e75c13 in KIMAP::SessionThread::run (this=0x19f1170) at ../../kimap/sessionthread.cpp:169
#16 0x00007fb82314fd05 in QThreadPrivate::start (arg=0x19f1170) at thread/qthread_unix.cpp:331
#17 0x00007fb81f0d5efc in start_thread (arg=0x7fb811dc3700) at pthread_create.c:304
#18 0x00007fb81f82689d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb823def780 (LWP 3633)):
[KCrash Handler]
#6  QSharedDataPointer (o=..., this=0x7fff1972a550) at /usr/include/qt4/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at ../../akonadi/entity.cpp:49
#8  0x00007fb823855ba4 in Akonadi::Entity::Entity (this=<optimized out>, other=<optimized out>) at ../../akonadi/entity.cpp:56
#9  0x000000000041959f in ImapResource::onIdleCollectionFetchDone (this=0x19c2fa0, job=0x1966bb0) at ../../../resources/imap/imapresource.cpp:504
#10 0x000000000041a235 in ImapResource::qt_metacall (this=0x19c2fa0, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0x7fff1972a750) at ./imapresource.moc:135
#11 0x00007fb823249eba in QMetaObject::activate (sender=0x1966bb0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff1972a750) at kernel/qobject.cpp:3278
#12 0x00007fb8201325b2 in KJob::result (this=<optimized out>, _t1=0x1966bb0) at ./kjob.moc:194
#13 0x00007fb8201325f0 in KJob::emitResult (this=0x1966bb0) at ../../kdecore/jobs/kjob.cpp:312
#14 0x00007fb82391306d in Akonadi::Job::qt_metacall (this=0x1966bb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x1cb5730) at ./job.moc:91
#15 0x00007fb82388f8e5 in Akonadi::CollectionFetchJob::qt_metacall (this=0x1966bb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x1cb5730) at ./collectionfetchjob.moc:75
#16 0x00007fb82324da5e in QObject::event (this=0x1966bb0, e=<optimized out>) at kernel/qobject.cpp:1217
#17 0x00007fb8225e7424 in notify_helper (e=0x19afb40, receiver=0x1966bb0, this=0x181b910) at kernel/qapplication.cpp:4486
#18 QApplicationPrivate::notify_helper (this=0x181b910, receiver=0x1966bb0, e=0x19afb40) at kernel/qapplication.cpp:4458
#19 0x00007fb8225ec291 in QApplication::notify (this=0x7fff1972afd0, receiver=0x1966bb0, e=0x19afb40) at kernel/qapplication.cpp:4365
#20 0x00007fb820702126 in KApplication::notify (this=0x7fff1972afd0, receiver=0x1966bb0, event=0x19afb40) at ../../kdeui/kernel/kapplication.cpp:311
#21 0x00007fb823236afc in QCoreApplication::notifyInternal (this=0x7fff1972afd0, receiver=0x1966bb0, event=0x19afb40) at kernel/qcoreapplication.cpp:787
#22 0x00007fb82323a51f in sendEvent (event=0x19afb40, receiver=0x1966bb0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#23 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x17ee800) at kernel/qcoreapplication.cpp:1428
#24 0x00007fb823261a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#25 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#26 0x00007fb81e16ca5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007fb81e16d258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fb81e16d429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fb823261ed6 in QEventDispatcherGlib::processEvents (this=0x17f0210, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#30 0x00007fb82268f07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007fb823235cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007fb823235ef7 in QEventLoop::exec (this=0x7fff1972af50, flags=...) at kernel/qeventloop.cpp:201
#33 0x00007fb82323a789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#34 0x00007fb82392a666 in Akonadi::ResourceBase::init (r=0x19c2fa0) at ../../akonadi/resourcebase.cpp:393
#35 0x000000000041a716 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:188
#36 0x00007fb81f76630d in __libc_start_main (main=0x415050 <main(int, char**)>, argc=3, ubp_av=0x7fff1972b0e8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff1972b0d8) at libc-start.c:226
#37 0x0000000000415205 in _start ()

Possible duplicates by query: bug 290189, bug 288785, bug 287011, bug 285883, bug 283341.

Reported using DrKonqi
Comment 1 Christophe Marin 2012-01-02 12:34:31 UTC

*** This bug has been marked as a duplicate of bug 253031 ***