Bug 297038 - Kmail crashes when save message as draft
Summary: Kmail crashes when save message as draft
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-29 14:02 UTC by SErgio BELKin
Modified: 2013-02-08 15:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.34 KB, text/plain)
2013-02-08 15:32 UTC, shining
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SErgio BELKin 2012-03-29 14:02:53 UTC
Application: kontact (4.8.1)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.3.0-4.fc16.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:

Saving mail as a draft one. It happens always when trying to do that.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f8e96585840 (LWP 27560))]

Thread 3 (Thread 0x7f8e89b3f700 (LWP 27561)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x00000030c09b86ec in WTF::TCMalloc_PageHeap::scavengerThread (this=0x30c137cc20) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00000030c09b8819 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003115207d90 in start_thread (arg=0x7f8e89b3f700) at pthread_create.c:309
#4  0x0000003114af0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f8e89226700 (LWP 27562)):
#0  0x0000003114ae85c3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003116a44fd8 in g_main_context_poll (n_fds=1, fds=0x7f8e840013e0, priority=<optimized out>, timeout=3523, context=0x7f8e840009a0) at gmain.c:3402
#2  g_main_context_iterate (context=0x7f8e840009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3084
#3  0x0000003116a4549c in g_main_context_iteration (context=0x7f8e840009a0, may_block=1) at gmain.c:3152
#4  0x0000003c0f7a7dc6 in QEventDispatcherGlib::processEvents (this=0x7f8e840008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003c0f778182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003c0f7783d7 in QEventLoop::exec (this=0x7f8e89225d40, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003c0f678b27 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x0000003c0f67bb6b in QThreadPrivate::start (arg=0xfcf930) at thread/qthread_unix.cpp:298
#9  0x0000003115207d90 in start_thread (arg=0x7f8e89226700) at pthread_create.c:309
#10 0x0000003114af0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f8e96585840 (LWP 27560)):
[KCrash Handler]
#6  QSharedDataPointer (o=..., this=0x7fff47b81480) at /usr/include/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at /usr/src/debug/kdepimlibs-4.8.1/akonadi/entity.cpp:49
#8  0x00000030bd68082e in Akonadi::Entity::operator= (this=0x7fff47b814c0, other=<optimized out>) at /usr/src/debug/kdepimlibs-4.8.1/akonadi/entity.cpp:116
#9  0x00000030c687d875 in operator= (this=0x7fff47b814c0) at /usr/include/kde4/akonadi/collection.h:75
#10 Message::ComposerViewBase::slotSaveMessage (this=0x15f77b0, job=0x225a9e0) at /usr/src/debug/kdepim-4.8.1/messagecomposer/composerviewbase.cpp:944
#11 0x0000003c0f78cce1 in QMetaObject::activate (sender=0x225a9e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff47b81670) at kernel/qobject.cpp:3547
#12 0x0000003c10d41fc2 in KJob::result (this=<optimized out>, _t1=0x225a9e0) at /usr/src/debug/kdelibs-4.8.1/x86_64-redhat-linux-gnu/kdecore/kjob.moc:208
#13 0x0000003c10d42000 in KJob::emitResult (this=0x225a9e0) at /usr/src/debug/kdelibs-4.8.1/kdecore/jobs/kjob.cpp:318
#14 0x0000003c0f791f16 in QObject::event (this=0x225a9e0, e=<optimized out>) at kernel/qobject.cpp:1195
#15 0x00000030b83c9994 in notify_helper (e=0x2225bc0, receiver=0x225a9e0, this=0xe62340) at kernel/qapplication.cpp:4550
#16 QApplicationPrivate::notify_helper (this=0xe62340, receiver=0x225a9e0, e=0x2225bc0) at kernel/qapplication.cpp:4522
#17 0x00000030b83ce813 in QApplication::notify (this=0x7fff47b82030, receiver=0x225a9e0, e=0x2225bc0) at kernel/qapplication.cpp:4411
#18 0x00000030b9a51d56 in KApplication::notify (this=0x7fff47b82030, receiver=0x225a9e0, event=0x2225bc0) at /usr/src/debug/kdelibs-4.8.1/kdeui/kernel/kapplication.cpp:311
#19 0x0000003c0f77904c in QCoreApplication::notifyInternal (this=0x7fff47b82030, receiver=0x225a9e0, event=0x2225bc0) at kernel/qcoreapplication.cpp:876
#20 0x0000003c0f77cada in sendEvent (event=0x2225bc0, receiver=0x225a9e0) at kernel/qcoreapplication.h:231
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xe1b600) at kernel/qcoreapplication.cpp:1500
#22 0x0000003c0f7a7933 in sendPostedEvents () at kernel/qcoreapplication.h:236
#23 postEventSourceDispatch (s=0xe54370) at kernel/qeventdispatcher_glib.cpp:279
#24 0x0000003116a44acd in g_main_dispatch (context=0xe54280) at gmain.c:2441
#25 g_main_context_dispatch (context=0xe54280) at gmain.c:3011
#26 0x0000003116a452c8 in g_main_context_iterate (context=0xe54280, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3089
#27 0x0000003116a4549c in g_main_context_iteration (context=0xe54280, may_block=1) at gmain.c:3152
#28 0x0000003c0f7a7d5f in QEventDispatcherGlib::processEvents (this=0xe1cee0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#29 0x00000030b846c66e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#30 0x0000003c0f778182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x0000003c0f7783d7 in QEventLoop::exec (this=0x7fff47b81fc0, flags=...) at kernel/qeventloop.cpp:204
#32 0x0000003c0f77cdd5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#33 0x00000000004036e9 in main (argc=1, argv=0x7fff47b82658) at /usr/src/debug/kdepim-4.8.1/kontact/src/main.cpp:218

Possible duplicates by query: bug 284842, bug 284505, bug 283619, bug 283593, bug 283364.

Reported using DrKonqi
Comment 1 Christophe Marin 2012-03-30 13:33:17 UTC

*** This bug has been marked as a duplicate of bug 253031 ***
Comment 2 shining 2013-02-08 15:32:14 UTC
Created attachment 77020 [details]
New crash information added by DrKonqi

kontact (4.8.5) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.1

- What I was doing when the application crashed:

I clicked the close button of an email i was editing before. A dialog asked me to save it in the draft folder and I accepted. Immediately kontact crashed.

-- Backtrace (Reduced):
#6  QSharedDataPointer (o=..., this=0x7fff2ce4ef60) at /usr/include/qt4/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at ../../akonadi/entity.cpp:49
#8  0x00007fc04d501c9e in Akonadi::Entity::operator= (this=0x7fff2ce4efa0, other=...) at ../../akonadi/entity.cpp:116
#9  0x00007fbfed3093f5 in operator= (this=0x7fff2ce4efa0) at /usr/include/akonadi/collection.h:75
#10 Message::ComposerViewBase::slotSaveMessage (this=0x110a510, job=0x4531480) at ../../messagecomposer/composerviewbase.cpp:947