Bug 280149 - IMAP Akonadi Client crashes during IMAP folder selection
Summary: IMAP Akonadi Client crashes during IMAP folder selection
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-15 19:48 UTC by John Gorkos
Modified: 2011-08-28 16:20 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Gorkos 2011-08-15 19:48:15 UTC
Application: akonadi_imap_resource (4.7)
KDE Platform Version: 4.7.00 (4.7.0)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-10-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
If all remote folders are Deselected in the local subscriptions dialog, the Akonadi client associated with the IMAP client will segfault and crash.
This was with an Exchange IMAP server.

-- Backtrace:
Application: Akonadi Resource (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1d74a98780 (LWP 5634))]

Thread 7 (Thread 0x7f1d637fe700 (LWP 5669)):
#0  0x00007f1d70565f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f1d6eebd104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1d6eebd639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1d73f18446 in QEventDispatcherGlib::processEvents (this=0x272ace0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f1d73eec882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f1d73eecabc in QEventLoop::exec (this=0x7f1d637fdde0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f1d73e03924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f1d72b8b043 in KIMAP::SessionThread::run (this=0x272f210) at ../../kimap/sessionthread.cpp:166
#8  0x00007f1d73e06175 in QThreadPrivate::start (arg=0x272f210) at thread/qthread_unix.cpp:320
#9  0x00007f1d6fe20d8c in start_thread (arg=0x7f1d637fe700) at pthread_create.c:304
#10 0x00007f1d7057304d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f1d5bfff700 (LWP 5782)):
#0  0x00007f1d6fe233c4 in __pthread_mutex_lock (mutex=0x2bbdec8) at pthread_mutex_lock.c:61
#1  0x00007f1d6eebc0d3 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1d6eebcf9d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1d6eebd639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1d73f18446 in QEventDispatcherGlib::processEvents (this=0x2bb2c50, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f1d73eec882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f1d73eecabc in QEventLoop::exec (this=0x7f1d5bffedd0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f1d73e03924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007f1d73ecec2f in QInotifyFileSystemWatcherEngine::run (this=0x2bb2330) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f1d73e06175 in QThreadPrivate::start (arg=0x2bb2330) at thread/qthread_unix.cpp:320
#10 0x00007f1d6fe20d8c in start_thread (arg=0x7f1d5bfff700) at pthread_create.c:304
#11 0x00007f1d7057304d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f1d62a1b700 (LWP 21462)):
#0  0x00007f1d70565f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f1d6eebd104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1d6eebd639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1d73f18446 in QEventDispatcherGlib::processEvents (this=0x2a24950, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f1d73eec882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f1d73eecabc in QEventLoop::exec (this=0x7f1d62a1ade0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f1d73e03924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f1d72b8b043 in KIMAP::SessionThread::run (this=0x2997c90) at ../../kimap/sessionthread.cpp:166
#8  0x00007f1d73e06175 in QThreadPrivate::start (arg=0x2997c90) at thread/qthread_unix.cpp:320
#9  0x00007f1d6fe20d8c in start_thread (arg=0x7f1d62a1b700) at pthread_create.c:304
#10 0x00007f1d7057304d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f1d5a297700 (LWP 22428)):
#0  0x00007f1d70565f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f1d6eebd104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1d6eebd639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1d73f18446 in QEventDispatcherGlib::processEvents (this=0x2d5a640, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f1d73eec882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f1d73eecabc in QEventLoop::exec (this=0x7f1d5a296de0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f1d73e03924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f1d72b8b043 in KIMAP::SessionThread::run (this=0x2e7aa90) at ../../kimap/sessionthread.cpp:166
#8  0x00007f1d73e06175 in QThreadPrivate::start (arg=0x2e7aa90) at thread/qthread_unix.cpp:320
#9  0x00007f1d6fe20d8c in start_thread (arg=0x7f1d5a297700) at pthread_create.c:304
#10 0x00007f1d7057304d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f1d59295700 (LWP 22474)):
#0  0x00007f1d70565f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f1d6eebd104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1d6eebd639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1d73f18446 in QEventDispatcherGlib::processEvents (this=0x2ba51e0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f1d73eec882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f1d73eecabc in QEventLoop::exec (this=0x7f1d59294de0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f1d73e03924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f1d72b8b043 in KIMAP::SessionThread::run (this=0x7f1d5c0047a0) at ../../kimap/sessionthread.cpp:166
#8  0x00007f1d73e06175 in QThreadPrivate::start (arg=0x7f1d5c0047a0) at thread/qthread_unix.cpp:320
#9  0x00007f1d6fe20d8c in start_thread (arg=0x7f1d59295700) at pthread_create.c:304
#10 0x00007f1d7057304d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f1d58a94700 (LWP 22488)):
#0  0x00007f1d70565f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f1d6eebd104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1d6eebd639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1d73f18446 in QEventDispatcherGlib::processEvents (this=0x2c6e020, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f1d73eec882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f1d73eecabc in QEventLoop::exec (this=0x7f1d58a93de0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f1d73e03924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f1d72b8b043 in KIMAP::SessionThread::run (this=0x2be8800) at ../../kimap/sessionthread.cpp:166
#8  0x00007f1d73e06175 in QThreadPrivate::start (arg=0x2be8800) at thread/qthread_unix.cpp:320
#9  0x00007f1d6fe20d8c in start_thread (arg=0x7f1d58a94700) at pthread_create.c:304
#10 0x00007f1d7057304d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1d74a98780 (LWP 5634)):
[KCrash Handler]
#6  QSharedDataPointer (one=..., other=...) at /usr/include/qt4/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at ../../akonadi/entity.cpp:49
#8  0x00007f1d7450a334 in Akonadi::Entity::Entity (this=0x7fffe09c5fa0, other=<value optimized out>) at ../../akonadi/entity.cpp:56
#9  0x0000000000419aab in ImapResource::onIdleCollectionFetchDone (this=0x27ddbd0, job=0x2d6ef10) at ../../../resources/imap/imapresource.cpp:504
#10 0x000000000041a245 in ImapResource::qt_metacall (this=0x27ddbd0, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0x7fffe09c60c0) at ./imapresource.moc:135
#11 0x00007f1d73f025f8 in QMetaObject::activate (sender=0x2d6ef10, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffe09c60c0) at kernel/qobject.cpp:3287
#12 0x00007f1d70e6bdb2 in KJob::result (this=<value optimized out>, _t1=0x2d6ef10) at ./kjob.moc:194
#13 0x00007f1d70e6bdf0 in KJob::emitResult (this=0x2d6ef10) at ../../kdecore/jobs/kjob.cpp:312
#14 0x00007f1d745c5acd in Akonadi::Job::qt_metacall (this=0x2d6ef10, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x2d3e530) at ./job.moc:91
#15 0x00007f1d74542395 in Akonadi::CollectionFetchJob::qt_metacall (this=0x2d6ef10, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x2d3e530) at ./collectionfetchjob.moc:75
#16 0x00007f1d73f0149a in QObject::event (this=0x2d6ef10, e=<value optimized out>) at kernel/qobject.cpp:1226
#17 0x00007f1d732aa9f4 in QApplicationPrivate::notify_helper (this=0x26a64b0, receiver=0x2d6ef10, e=0x2f2a390) at kernel/qapplication.cpp:4462
#18 0x00007f1d732af3ba in QApplication::notify (this=<value optimized out>, receiver=0x2d6ef10, e=0x2f2a390) at kernel/qapplication.cpp:4341
#19 0x00007f1d71431796 in KApplication::notify (this=0x7fffe09c6b00, receiver=0x2d6ef10, event=0x2f2a390) at ../../kdeui/kernel/kapplication.cpp:311
#20 0x00007f1d73eed49c in QCoreApplication::notifyInternal (this=0x7fffe09c6b00, receiver=0x2d6ef10, event=0x2f2a390) at kernel/qcoreapplication.cpp:731
#21 0x00007f1d73ef0c25 in sendEvent (receiver=0x0, event_type=0, data=0x265bdf0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x265bdf0) at kernel/qcoreapplication.cpp:1372
#23 0x00007f1d73f18253 in sendPostedEvents (s=0x26aa9c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#24 postEventSourceDispatch (s=0x26aa9c0) at kernel/qeventdispatcher_glib.cpp:277
#25 0x00007f1d6eebcbcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f1d6eebd3a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f1d6eebd639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f1d73f183ef in QEventDispatcherGlib::processEvents (this=0x265b5d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#29 0x00007f1d733544de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x00007f1d73eec882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007f1d73eecabc in QEventLoop::exec (this=0x7fffe09c6a80, flags=...) at kernel/qeventloop.cpp:201
#32 0x00007f1d73ef0ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#33 0x00007f1d745dcd36 in Akonadi::ResourceBase::init (r=0x27ddbd0) at ../../akonadi/resourcebase.cpp:393
#34 0x0000000000417c46 in init<ImapResource> (argc=<value optimized out>, argv=<value optimized out>) at /usr/include/akonadi/resourcebase.h:188
#35 main (argc=<value optimized out>, argv=<value optimized out>) at ../../../resources/imap/imapresource.cpp:598

Possible duplicates by query: bug 280137, bug 278824, bug 278799, bug 277930, bug 275933.

Reported using DrKonqi
Comment 1 Christophe Marin 2011-08-28 16:20:32 UTC

*** This bug has been marked as a duplicate of bug 253031 ***