Bug 284022 - Kmail crashes during configuring EMail accounts
Summary: Kmail crashes during configuring EMail accounts
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 290472 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-14 18:34 UTC by Andreas Hencke
Modified: 2012-08-18 22:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Hencke 2011-10-14 18:34:09 UTC
Application: kmail (4.7.2)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
After purging and reinstalling kmail2 (migration after upgrading to kubuntu oneiric failed), I configured my EMail accounts (pop and imap). During that, kmail crashed.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0xb6168730 (LWP 2566))]

Thread 4 (Thread 0xb4e30b70 (LWP 2570)):
#0  0x00ea9416 in __kernel_vsyscall ()
#1  0x01d48a5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x01a4fcfc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb71a6883 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0xb71a699f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0x01d44d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x01a420ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 3 (Thread 0xb4507b70 (LWP 2571)):
#0  0x00ea9416 in __kernel_vsyscall ()
#1  0x01a3340e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x02c3f34b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x02c30896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x02c30c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x021f2b37 in QEventDispatcherGlib::processEvents (this=0x8d17028, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x021c31dd in QEventLoop::processEvents (this=0xb45072c0, flags=...) at kernel/qeventloop.cpp:149
#7  0x021c3421 in QEventLoop::exec (this=0xb45072c0, flags=...) at kernel/qeventloop.cpp:201
#8  0x020c690b in QThread::exec (this=0x8d16438) at thread/qthread.cpp:498
#9  0x020c69fb in QThread::run (this=0x8d16438) at thread/qthread.cpp:565
#10 0x020c97b3 in QThreadPrivate::start (arg=0x8d16438) at thread/qthread_unix.cpp:331
#11 0x01d44d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x01a420ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xb288db70 (LWP 2574)):
#0  0x02c2fb52 in g_main_context_query () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x02c30664 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x02c30c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x021f2b37 in QEventDispatcherGlib::processEvents (this=0x8fbc6d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x021c31dd in QEventLoop::processEvents (this=0xb288d290, flags=...) at kernel/qeventloop.cpp:149
#5  0x021c3421 in QEventLoop::exec (this=0xb288d290, flags=...) at kernel/qeventloop.cpp:201
#6  0x020c690b in QThread::exec (this=0x8e577a0) at thread/qthread.cpp:498
#7  0x021a3e2d in QInotifyFileSystemWatcherEngine::run (this=0x8e577a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x020c97b3 in QThreadPrivate::start (arg=0x8e577a0) at thread/qthread_unix.cpp:331
#9  0x01d44d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x01a420ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb6168730 (LWP 2566)):
[KCrash Handler]
#7  0x01da9684 in ?? () from /usr/lib/libakonadi-kde.so.4
#8  0x01da976b in Akonadi::Entity::Entity(Akonadi::Entity const&) () from /usr/lib/libakonadi-kde.so.4
#9  0x01dda3d3 in Akonadi::Collection::Collection(Akonadi::Collection const&) () from /usr/lib/libakonadi-kde.so.4
#10 0x0868661d in MailCommon::FolderCollection::collection() const () from /usr/lib/libmailcommon.so.4
#11 0x00da8f73 in KMMainWidget::slotDelayedRemoveFolder(KJob*) () from /usr/lib/libkmailprivate.so.4
#12 0x00dbf696 in KMMainWidget::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkmailprivate.so.4
#13 0x021cab7d in metacall (argv=0xbfa99f68, idx=75, cl=QMetaObject::InvokeMetaMethod, object=0x8b96150) at kernel/qmetaobject.cpp:237
#14 QMetaObject::metacall (object=0x8b96150, cl=QMetaObject::InvokeMetaMethod, idx=75, argv=0xbfa99f68) at kernel/qmetaobject.cpp:232
#15 0x021d9a6a in QMetaObject::activate (sender=0xa6ee148, m=0x9ff58c, local_signal_index=3, argv=0xbfa99f68) at kernel/qobject.cpp:3278
#16 0x00851eb5 in KJob::result(KJob*) () from /usr/lib/libkdecore.so.5
#17 0x00851f08 in KJob::emitResult() () from /usr/lib/libkdecore.so.5
#18 0x01e7525e in ?? () from /usr/lib/libakonadi-kde.so.4
#19 0x01e75f6f in Akonadi::Job::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libakonadi-kde.so.4
#20 0x01de8e22 in Akonadi::CollectionFetchJob::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libakonadi-kde.so.4
#21 0x021cab7d in metacall (argv=0xac93570, idx=34, cl=QMetaObject::InvokeMetaMethod, object=0xa6ee148) at kernel/qmetaobject.cpp:237
#22 QMetaObject::metacall (object=0xa6ee148, cl=QMetaObject::InvokeMetaMethod, idx=34, argv=0xac93570) at kernel/qmetaobject.cpp:232
#23 0x021d5685 in QMetaCallEvent::placeMetaCall (this=0x9555238, object=0xa6ee148) at kernel/qobject.cpp:535
#24 0x021dcb52 in QObject::event (this=0xa6ee148, e=0x9555238) at kernel/qobject.cpp:1217
#25 0x01001d54 in notify_helper (e=0x9555238, receiver=0xa6ee148, this=0x8900380) at kernel/qapplication.cpp:4486
#26 QApplicationPrivate::notify_helper (this=0x8900380, receiver=0xa6ee148, e=0x9555238) at kernel/qapplication.cpp:4458
#27 0x01007103 in QApplication::notify (this=0x9555238, receiver=0xa6ee148, e=0x9555238) at kernel/qapplication.cpp:3886
#28 0x004ec681 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#29 0x021c419e in QCoreApplication::notifyInternal (this=0xbfa9a76c, receiver=0xa6ee148, event=0x9555238) at kernel/qcoreapplication.cpp:787
#30 0x021c7f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x88d1300) at kernel/qcoreapplication.cpp:1428
#32 0x021c80ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#33 0x021f26a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#34 postEventSourceDispatch (s=0x88feac0) at kernel/qeventdispatcher_glib.cpp:277
#35 0x02c3025f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#36 0x02c30990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#37 0x02c30c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x021f2ada in QEventDispatcherGlib::processEvents (this=0x88d2268, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#39 0x010b9e3a in QGuiEventDispatcherGlib::processEvents (this=0x88d2268, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x021c31dd in QEventLoop::processEvents (this=0xbfa9a684, flags=...) at kernel/qeventloop.cpp:149
#41 0x021c3421 in QEventLoop::exec (this=0xbfa9a684, flags=...) at kernel/qeventloop.cpp:201
#42 0x021c819d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#43 0x00fff8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#44 0x0804a266 in ?? ()
#45 0x01989113 in __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
#46 0x0804a709 in _start ()

Possible duplicates by query: bug 282060, bug 278645.

Reported using DrKonqi
Comment 1 Christophe Marin 2012-01-06 17:49:17 UTC
*** Bug 290472 has been marked as a duplicate of this bug. ***
Comment 2 Christophe Marin 2012-01-06 17:49:41 UTC
from bug 290482

Ran the import wizard (from Evolution) and ended up with a pile of directories
(added the wrong thing).  Selected the root of the tree of created directories
and selected Delete.  KMail began deleting directories then crashed after about
two minutes (it had not completed).  There were hundreds of directories -
possibly an out-of-memory situation?
Comment 3 Myriam Schweingruber 2012-08-18 22:00:59 UTC

*** This bug has been marked as a duplicate of bug 253031 ***