Bug 266108 - akonadi_imap_resource immediate crash on open of Kontact/KMail (kdepim46)
Summary: akonadi_imap_resource immediate crash on open of Kontact/KMail (kdepim46)
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.6
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-12 00:09 UTC by _
Modified: 2011-07-13 14:52 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.42 KB, text/plain)
2011-06-16 13:16 UTC, Kai Krakow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ 2011-02-12 00:09:57 UTC
Version:           4.6 (using KDE 4.6.0) 
OS:                Linux

after clean reboot, on 1st (and subsequent) attempt to open Kontact or Kmail:

Application: Akonadi Resource (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0ee4820760 (LWP 7235))]

Thread 3 (Thread 0x7f0ed211d710 (LWP 7237)):
#0  0x00007f0ee03516b3 in poll () from /lib64/libc.so.6
#1  0x00007f0edecb95c4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f0edecb9b00 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f0ee3cacae6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007f0ee3c81262 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f0ee3c81475 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f0ee3b941a4 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007f0ee2921cf3 in ?? () from /usr/lib64/libkimap.so.4
#8  0x00007f0ee3b96a1e in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f0edfc18a4f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f0ee035a82d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f0ed191c710 (LWP 7238)):
#0  0x00007f0edfc1d709 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0ee3b97072 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f0ee3b8ce98 in ?? () from /usr/lib64/libQtCore.so.4
#3  0x00007f0ee3b96a1e in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f0edfc18a4f in start_thread () from /lib64/libpthread.so.0
#5  0x00007f0ee035a82d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0ee4820760 (LWP 7235)):
[KCrash Handler]
#6  QSharedDataPointer (one=..., other=...) at /usr/include/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at /usr/src/debug/kdepimlibs-4.6.0svn.rev1216163/akonadi/entity.cpp:49
#8  0x00007f0ee42a6324 in Akonadi::Entity::Entity (this=<value optimized out>, other=<value optimized out>) at /usr/src/debug/kdepimlibs-4.6.0svn.rev1216163/akonadi/entity.cpp:56
#9  0x0000000000423c06 in _start ()

Reproducible: Always
Comment 1 Kai Krakow 2011-06-16 13:16:22 UTC
Created attachment 61050 [details]
New crash information added by DrKonqi

akonadi_imap_resource (0.1) on KDE Platform 4.6.4 (4.6.4) using Qt 4.7.2

- What I was doing when the application crashed:

Started kmail and closed it again after a few seconds. Just before I clicked the close button, the akonadi crash report popped up.

-- Backtrace (Reduced):
#6  QSharedDataPointer (one=..., other=...) at /usr/include/qt4/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at /var/tmp/portage/kde-base/kdepimlibs-4.6.4/work/kdepimlibs-4.6.4/akonadi/entity.cpp:49
#8  0x00007f576de0e134 in Akonadi::Entity::Entity (this=0x7fff3bee8320, other=...) at /var/tmp/portage/kde-base/kdepimlibs-4.6.4/work/kdepimlibs-4.6.4/akonadi/entity.cpp:56
#9  0x0000000000424b38 in ImapResource::onIdleCollectionFetchDone (this=0x2260310, job=<value optimized out>) at /var/tmp/portage/kde-base/kdepim-runtime-4.6.0/work/kdepim-runtime-4.6.0/resources/imap/imapresource.cpp:503
#10 0x00000000004255a5 in ImapResource::qt_metacall (this=0x2260310, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff3bee8490) at /var/tmp/portage/kde-base/kdepim-runtime-4.6.0/work/kdepim-runtime-4.6.0_build/resources/imap/imapresource.moc:135
Comment 2 Christophe Marin 2011-07-13 14:52:16 UTC

*** This bug has been marked as a duplicate of bug 253031 ***