Bug 299330 - Kontact crashes while fetching imap gmail and deleting local folder
Summary: Kontact crashes while fetching imap gmail and deleting local folder
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-03 21:04 UTC by Irenux
Modified: 2012-05-09 13:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Irenux 2012-05-03 21:04:56 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Kontact was fetching mail from two newly set up gmail imap accounts while I was at the same time deleting two local mail folders.

Also Akonadi keeps giving messages about being disconnected from the server on imap accounts on another domain, and reports that imap is broken as well.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f5518c2d7c0 (LWP 5246))]

Thread 4 (Thread 0x7f54fc119700 (LWP 5254)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f551542ddec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f551542df19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f55108f4e9a in start_thread (arg=0x7f54fc119700) at pthread_create.c:308
#4  0x00007f551615f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f54fb800700 (LWP 5255)):
#0  0x00007ffff2dff8de in ?? ()
#1  0x00007f550ec5815d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007f55167fcbb4 in do_gettime (frac=0x7f54fb7ffba8, sec=0x7f54fb7ffba0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f55168d4b8d in QTimerInfoList::updateCurrentTime (this=0x7f54f4002860) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f55168d4ec3 in QTimerInfoList::timerWait (this=0x7f54f4002860, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007f55168d397c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f54fb7ffc5c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f551042771e in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f5510427f1b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f5510428124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f55168d4426 in QEventDispatcherGlib::processEvents (this=0x7f54f40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0x00007f55168a3c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x00007f55168a3ed7 in QEventLoop::exec (this=0x7f54fb7ffdc0, flags=...) at kernel/qeventloop.cpp:204
#13 0x00007f55167a2fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#14 0x00007f55167a5fcb in QThreadPrivate::start (arg=0x21b2c60) at thread/qthread_unix.cpp:298
#15 0x00007f55108f4e9a in start_thread (arg=0x7f54fb800700) at pthread_create.c:308
#16 0x00007f551615f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#17 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f54a7da0700 (LWP 5279)):
#0  0x00007f5516153b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f5510427ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5510428124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f55168d4426 in QEventDispatcherGlib::processEvents (this=0x7f54a00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f55168a3c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f55168a3ed7 in QEventLoop::exec (this=0x7f54a7d9fd90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f55167a2fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f55168839ff in QInotifyFileSystemWatcherEngine::run (this=0x29aa2f0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f55167a5fcb in QThreadPrivate::start (arg=0x29aa2f0) at thread/qthread_unix.cpp:298
#9  0x00007f55108f4e9a in start_thread (arg=0x7f54a7da0700) at pthread_create.c:308
#10 0x00007f551615f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5518c2d7c0 (LWP 5246)):
[KCrash Handler]
#6  QSharedDataPointer (o=..., this=0x7ffff2d71000) at /usr/include/qt4/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at ../../akonadi/entity.cpp:49
#8  0x00007f5512c20b24 in Akonadi::Entity::Entity (this=0x7ffff2d710e0, other=...) at ../../akonadi/entity.cpp:56
#9  0x00007f54b1f618ad in MailCommon::FolderCollection::collection (this=<optimized out>) at ../../mailcommon/foldercollection.cpp:150
#10 0x00007f54b233c1dd in KMMainWidget::slotDelayedRemoveFolder (this=0x2734c90, job=<optimized out>) at ../../kmail/kmmainwidget.cpp:1789
#11 0x00007f54b23457d1 in KMMainWidget::qt_static_metacall (_o=0x2734c90, _c=<optimized out>, _id=<optimized out>, _a=0x7ffff2d715d0) at ./kmmainwidget.moc:379
#12 0x00007f55168b9281 in QMetaObject::activate (sender=0x3db68d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffff2d715d0) at kernel/qobject.cpp:3547
#13 0x00007f5516d2e822 in KJob::result (this=<optimized out>, _t1=0x3db68d0) at ./kjob.moc:208
#14 0x00007f5516d2e860 in KJob::emitResult (this=0x3db68d0) at ../../kdecore/jobs/kjob.cpp:318
#15 0x00007f55168be446 in QObject::event (this=0x3db68d0, e=<optimized out>) at kernel/qobject.cpp:1195
#16 0x00007f5517299894 in notify_helper (e=0x3df3060, receiver=0x3db68d0, this=0x2068df0) at kernel/qapplication.cpp:4559
#17 QApplicationPrivate::notify_helper (this=0x2068df0, receiver=0x3db68d0, e=0x3df3060) at kernel/qapplication.cpp:4531
#18 0x00007f551729e713 in QApplication::notify (this=0x7ffff2d71f60, receiver=0x3db68d0, e=0x3df3060) at kernel/qapplication.cpp:4420
#19 0x00007f5517fd2b46 in KApplication::notify (this=0x7ffff2d71f60, receiver=0x3db68d0, event=0x3df3060) at ../../kdeui/kernel/kapplication.cpp:311
#20 0x00007f55168a4e9c in QCoreApplication::notifyInternal (this=0x7ffff2d71f60, receiver=0x3db68d0, event=0x3df3060) at kernel/qcoreapplication.cpp:876
#21 0x00007f55168a8c6a in sendEvent (event=0x3df3060, receiver=0x3db68d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x202c380) at kernel/qcoreapplication.cpp:1500
#23 0x00007f55168d3f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#24 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#25 0x00007f5510427c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f5510428060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f5510428124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f55168d43bf in QEventDispatcherGlib::processEvents (this=0x202dc10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#29 0x00007f5517341d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x00007f55168a3c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007f55168a3ed7 in QEventLoop::exec (this=0x7ffff2d71ef0, flags=...) at kernel/qeventloop.cpp:204
#32 0x00007f55168a8f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#33 0x0000000000403629 in main (argc=1, argv=0x7ffff2d72588) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 253031.

Possible duplicates by query: bug 293311, bug 292983, bug 290342, bug 290189, bug 288785.

Reported using DrKonqi
Comment 1 Christophe Marin 2012-05-09 13:32:31 UTC

*** This bug has been marked as a duplicate of bug 253031 ***