Bug 275893 - Akonadi continuously crashes after login after migrating from kmail v1
Summary: Akonadi continuously crashes after login after migrating from kmail v1
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-17 11:28 UTC by Kai Krakow
Modified: 2011-07-13 14:52 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Krakow 2011-06-17 11:28:15 UTC
Application: akonadi_imap_resource (0.1)
KDE Platform Version: 4.6.4 (4.6.4)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-gentoo-r7 x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:

I migrated from kmail1 to kmail2 - the process went fine except some notices about some bridge adapter already intialized. After rebooting and logging in again to KDE, the desktop always opens with a crash dialog about akonadi. Closing this dialog makes the next crash dialog appear a few seconds later. This repeats for about 20-30 times - very annoying.

The crash can be reproduced every time.

-- Backtrace:
Application: Akonadi Resource (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f3262651760 (LWP 3997))]

Thread 2 (Thread 0x7f324e273700 (LWP 3999)):
#0  0x00007f325e028b43 in poll () from /lib64/libc.so.6
#1  0x00007f325cd70f81 in g_main_context_poll (context=0xdf04c0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:3404
#2  g_main_context_iterate (context=0xdf04c0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:3086
#3  0x00007f325cd713cc in g_main_context_iteration (context=0xdf04c0, may_block=1) at gmain.c:3154
#4  0x00007f3261ae2816 in QEventDispatcherGlib::processEvents (this=0xea4750, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f3261ab5d42 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007f3261ab612d in QEventLoop::exec (this=0x7f324e272dd0, flags=) at kernel/qeventloop.cpp:201
#7  0x00007f32619c41bd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007f3260721753 in KIMAP::SessionThread::run (this=0xed79a0) at /var/tmp/portage/kde-base/kdepimlibs-4.6.4/work/kdepimlibs-4.6.4/kimap/sessionthread.cpp:166
#9  0x00007f32619c7165 in QThreadPrivate::start (arg=0xed79a0) at thread/qthread_unix.cpp:320
#10 0x00007f325d8dd9d1 in start_thread () from /lib64/libpthread.so.0
#11 0x00007f325e0323fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f3262651760 (LWP 3997)):
[KCrash Handler]
#6  QSharedDataPointer (one=..., other=...) at /usr/include/qt4/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at /var/tmp/portage/kde-base/kdepimlibs-4.6.4/work/kdepimlibs-4.6.4/akonadi/entity.cpp:49
#8  0x00007f32620dc134 in Akonadi::Entity::Entity (this=0x7fffeea39b60, other=...) at /var/tmp/portage/kde-base/kdepimlibs-4.6.4/work/kdepimlibs-4.6.4/akonadi/entity.cpp:56
#9  0x0000000000424b38 in ImapResource::onIdleCollectionFetchDone (this=0xe86db0, job=<value optimized out>) at /var/tmp/portage/kde-base/kdepim-runtime-4.6.0/work/kdepim-runtime-4.6.0/resources/imap/imapresource.cpp:503
#10 0x00000000004255a5 in ImapResource::qt_metacall (this=0xe86db0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffeea39cd0) at /var/tmp/portage/kde-base/kdepim-runtime-4.6.0/work/kdepim-runtime-4.6.0_build/resources/imap/imapresource.moc:135
#11 0x00007f3261ace82f in QMetaObject::activate (sender=0x7f32481d9b10, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xfedce0) at kernel/qobject.cpp:3278
#12 0x00007f325e937de2 in KJob::result (this=0x7fffeea39b60, _t1=0x7f32481d9b10) at /var/tmp/portage/kde-base/kdelibs-4.6.4/work/kdelibs-4.6.4_build/kdecore/kjob.moc:194
#13 0x00007f325e938080 in KJob::emitResult (this=0x7f32481d9b10) at /var/tmp/portage/kde-base/kdelibs-4.6.4/work/kdelibs-4.6.4/kdecore/jobs/kjob.cpp:312
#14 0x00007f326218f319 in delayedEmitResult (this=0x7f32481d9b10, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xf01ca0) at /var/tmp/portage/kde-base/kdepimlibs-4.6.4/work/kdepimlibs-4.6.4/akonadi/job.cpp:144
#15 Akonadi::Job::qt_metacall (this=0x7f32481d9b10, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xf01ca0) at /var/tmp/portage/kde-base/kdepimlibs-4.6.4/work/kdepimlibs-4.6.4_build/akonadi/job.moc:91
#16 0x00007f3262110635 in Akonadi::CollectionFetchJob::qt_metacall (this=0x7fffeea39b60, _c=33, _id=0, _a=0xfedce0) at /var/tmp/portage/kde-base/kdepimlibs-4.6.4/work/kdepimlibs-4.6.4_build/akonadi/collectionfetchjob.moc:73
#17 0x00007f3261ac8a6e in QObject::event (this=0x7f32481d9b10, e=0x7fffeea39b60) at kernel/qobject.cpp:1217
#18 0x00007f3260e5c22c in QApplicationPrivate::notify_helper (this=0xcafa60, receiver=0x7f32481d9b10, e=0xf8ef00) at kernel/qapplication.cpp:4462
#19 0x00007f3260e6293d in QApplication::notify (this=0x7fffeea3a7b0, receiver=0x7f32481d9b10, e=0xf8ef00) at kernel/qapplication.cpp:4341
#20 0x00007f325ef5d156 in KApplication::notify (this=0x7fffeea3a7b0, receiver=0x7f32481d9b10, event=0xf8ef00) at /var/tmp/portage/kde-base/kdelibs-4.6.4/work/kdelibs-4.6.4/kdeui/kernel/kapplication.cpp:311
#21 0x00007f3261ab6fbb in QCoreApplication::notifyInternal (this=0x7fffeea3a7b0, receiver=0x7f32481d9b10, event=0xf8ef00) at kernel/qcoreapplication.cpp:731
#22 0x00007f3261ab9f11 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0xc91510) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#23 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0xc91510) at kernel/qcoreapplication.cpp:1372
#24 0x00007f3261ae2c63 in sendPostedEvents (s=0xcb2290) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#25 postEventSourceDispatch (s=0xcb2290) at kernel/qeventdispatcher_glib.cpp:277
#26 0x00007f325cd6cbc1 in g_main_dispatch (context=0xcb21b0) at gmain.c:2440
#27 g_main_context_dispatch (context=0xcb21b0) at gmain.c:3013
#28 0x00007f325cd71218 in g_main_context_iterate (context=0xcb21b0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:3091
#29 0x00007f325cd713cc in g_main_context_iteration (context=0xcb21b0, may_block=1) at gmain.c:3154
#30 0x00007f3261ae27c3 in QEventDispatcherGlib::processEvents (this=0xc90cf0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#31 0x00007f3260f0cfae in QGuiEventDispatcherGlib::processEvents (this=0x7fffeea39b60, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x00007f3261ab5d42 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#33 0x00007f3261ab612d in QEventLoop::exec (this=0x7fffeea3a720, flags=) at kernel/qeventloop.cpp:201
#34 0x00007f3261aba123 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#35 0x00007f32621ae4f3 in Akonadi::ResourceBase::init (r=0xe86db0) at /var/tmp/portage/kde-base/kdepimlibs-4.6.4/work/kdepimlibs-4.6.4/akonadi/resourcebase.cpp:390
#36 0x0000000000423238 in init<ImapResource> (argc=<value optimized out>, argv=<value optimized out>) at /usr/include/akonadi/resourcebase.h:188
#37 main (argc=<value optimized out>, argv=<value optimized out>) at /var/tmp/portage/kde-base/kdepim-runtime-4.6.0/work/kdepim-runtime-4.6.0/resources/imap/imapresource.cpp:597

Possible duplicates by query: bug 272440, bug 266108, bug 264994, bug 259924, bug 258684.

Reported using DrKonqi
Comment 1 Christophe Marin 2011-07-13 14:52:06 UTC

*** This bug has been marked as a duplicate of bug 253031 ***