Bug 294453 - kmail crashes on save draft
Summary: kmail crashes on save draft
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-19 21:48 UTC by Bart van Deenen
Modified: 2012-03-30 13:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bart van Deenen 2012-02-19 21:48:47 UTC
Application: kmail (4.8.0)
KDE Platform Version: 4.8.00 (4.8.0 "release 462"
Qt Version: 4.8.0
Operating System: Linux 3.1.9-1.4-desktop i686
Distribution: "openSUSE 12.1 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
Either click close button of draft window and confirm 'save draft', or explicitly using the 'save draft' menu crashes kmail

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0xb1940940 (LWP 8515))]

Thread 3 (Thread 0xaffa7b70 (LWP 8527)):
#0  0xb5c22782 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0xb5e9f3ac in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#2  0xb38a3189 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0xb38a31cf in ?? () from /usr/lib/libQtWebKit.so.4
#4  0xb5c1ea7d in start_thread () from /lib/libpthread.so.0
#5  0xb5e9189e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xaf67fb70 (LWP 8528)):
#0  0xb5e86994 in poll () from /lib/libc.so.6
#1  0xb4607f7b in g_poll () from /usr/lib/libglib-2.0.so.0
#2  0xb45f9466 in ?? () from /usr/lib/libglib-2.0.so.0
#3  0xb45f97fa in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0xb6ccb5a7 in QEventDispatcherGlib::processEvents (this=0xaed00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0xb6c9740d in QEventLoop::processEvents (this=0xaf67f2d0, flags=...) at kernel/qeventloop.cpp:149
#6  0xb6c976a9 in QEventLoop::exec (this=0xaf67f2d0, flags=...) at kernel/qeventloop.cpp:204
#7  0xb6b81d0c in QThread::exec (this=0x86bba90) at thread/qthread.cpp:501
#8  0xb6b81dfb in QThread::run (this=0x86bba90) at thread/qthread.cpp:568
#9  0xb6b851f0 in QThreadPrivate::start (arg=0x86bba90) at thread/qthread_unix.cpp:298
#10 0xb5c1ea7d in start_thread () from /lib/libpthread.so.0
#11 0xb5e9189e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb1940940 (LWP 8515)):
[KCrash Handler]
#6  QSharedDataPointer (o=..., this=0xbff9867c) at /usr/include/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at /usr/src/debug/kdepimlibs-4.8.0/akonadi/entity.cpp:49
#8  0xb52dc107 in Akonadi::Entity::operator= (this=0xbff986e8, other=...) at /usr/src/debug/kdepimlibs-4.8.0/akonadi/entity.cpp:116
#9  0xb51591dd in operator= (this=<optimized out>) at /usr/include/akonadi/collection.h:75
#10 Message::ComposerViewBase::slotSaveMessage (this=0x8346250, job=0x8b17640) at /usr/src/debug/kdepim-4.8.0/messagecomposer/composerviewbase.cpp:941
#11 0xb5159789 in qt_static_metacall (_a=0xbff98808, _id=13, _o=0x8346250, _c=<optimized out>) at /usr/src/debug/kdepim-4.8.0/build/messagecomposer/composerviewbase.moc:89
#12 Message::ComposerViewBase::qt_static_metacall (_o=0x8346250, _c=QMetaObject::InvokeMetaMethod, _id=13, _a=0xbff98808) at /usr/src/debug/kdepim-4.8.0/build/messagecomposer/composerviewbase.moc:70
#13 0xb6caf0ff in QMetaObject::activate (sender=0x8b17640, m=0xb72d34cc, local_signal_index=3, argv=0xbff98808) at kernel/qobject.cpp:3556
#14 0xb7123fa5 in KJob::result(KJob*) () from /usr/lib/libkdecore.so.5
#15 0xb7123ff8 in KJob::emitResult() () from /usr/lib/libkdecore.so.5
#16 0xb52d1b3e in Akonadi::JobPrivate::delayedEmitResult (this=0x8b1c440) at /usr/src/debug/kdepimlibs-4.8.0/akonadi/job.cpp:144
#17 0xb6caa621 in QMetaCallEvent::placeMetaCall (this=0x8b10d50, object=0x8b17640) at kernel/qobject.cpp:525
#18 0xb6cb378b in QObject::event (this=0x8b17640, e=0x8b10d50) at kernel/qobject.cpp:1204
#19 0xb61822f4 in notify_helper (e=0x8b10d50, receiver=0x8b17640, this=0x80909b8) at kernel/qapplication.cpp:4550
#20 QApplicationPrivate::notify_helper (this=0x80909b8, receiver=0x8b17640, e=0x8b10d50) at kernel/qapplication.cpp:4522
#21 0xb6187703 in QApplication::notify (this=0x8b10d50, receiver=0x8b17640, e=0x8b10d50) at kernel/qapplication.cpp:4279
#22 0xb74da851 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#23 0xb6c9889e in QCoreApplication::notifyInternal (this=0xbff9908c, receiver=0x8b17640, event=0x8b10d50) at kernel/qcoreapplication.cpp:876
#24 0xb6c9c518 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8051750) at kernel/qcoreapplication.cpp:1500
#26 0xb6c9c84c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#27 0xb6ccb154 in sendPostedEvents () at kernel/qcoreapplication.h:236
#28 postEventSourceDispatch (s=0x8090640) at kernel/qeventdispatcher_glib.cpp:279
#29 0xb45f8e2f in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#30 0xb45f9560 in ?? () from /usr/lib/libglib-2.0.so.0
#31 0xb45f97fa in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#32 0xb6ccb547 in QEventDispatcherGlib::processEvents (this=0x8051388, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#33 0xb623610a in QGuiEventDispatcherGlib::processEvents (this=0x8051388, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0xb6c9740d in QEventLoop::processEvents (this=0xbff98fb4, flags=...) at kernel/qeventloop.cpp:149
#35 0xb6c976a9 in QEventLoop::exec (this=0xbff98fb4, flags=...) at kernel/qeventloop.cpp:204
#36 0xb6c9c8fa in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#37 0xb6180164 in QApplication::exec () at kernel/qapplication.cpp:3811
#38 0x0804a496 in ?? ()
#39 0xb5dd6003 in __libc_start_main () from /lib/libc.so.6
#40 0x0804a939 in _start ()

Possible duplicates by query: bug 293820, bug 290184, bug 283680, bug 283619, bug 283593.

Reported using DrKonqi
Comment 1 Christophe Marin 2012-03-30 13:33:28 UTC

*** This bug has been marked as a duplicate of bug 253031 ***