Bug 301006 - Crash while saving a draft message
Summary: Crash while saving a draft message
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-01 17:26 UTC by Lothar Werzinger
Modified: 2012-06-02 00:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lothar Werzinger 2012-06-01 17:26:20 UTC
Application: kontact (4.8.3)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-25-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
Trying to save a message as draft

Kubuntu 12.04

Linux 3.2.0-25-generic #40-Ubuntu SMP Wed May 23 20:30:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6af57f77c0 (LWP 14645))]

Thread 4 (Thread 0x7f6ad8c1d700 (LWP 14646)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f6af1ffcdec in WTF::TCMalloc_PageHeap::scavengerThread (this=0x7f6af29c5de0) at wtf/FastMalloc.cpp:2495
#2  0x00007f6af1ffcf19 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at wtf/FastMalloc.cpp:1618
#3  0x00007f6aed4c2e9a in start_thread (arg=0x7f6ad8c1d700) at pthread_create.c:308
#4  0x00007f6af2d2e4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f6ad831c700 (LWP 14647)):
#0  0x00007f6aed0312e5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f6aed031589 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6aecff5b59 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6aecff6060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6aecff6124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f6af34a3426 in QEventDispatcherGlib::processEvents (this=0x7f6ad00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f6af3472c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f6af3472ed7 in QEventLoop::exec (this=0x7f6ad831bdc0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f6af3371fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f6af3374fcb in QThreadPrivate::start (arg=0x251d4d0) at thread/qthread_unix.cpp:298
#10 0x00007f6aed4c2e9a in start_thread (arg=0x7f6ad831c700) at pthread_create.c:308
#11 0x00007f6af2d2e4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f6a7b56a700 (LWP 14664)):
#0  0x00007f6af2d22b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f6aecff5ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6aecff6124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6af34a3426 in QEventDispatcherGlib::processEvents (this=0x7f6a740008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f6af3472c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6af3472ed7 in QEventLoop::exec (this=0x7f6a7b569d90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f6af3371fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f6af34529ff in QInotifyFileSystemWatcherEngine::run (this=0x38ceae0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f6af3374fcb in QThreadPrivate::start (arg=0x38ceae0) at thread/qthread_unix.cpp:298
#9  0x00007f6aed4c2e9a in start_thread (arg=0x7f6a7b56a700) at pthread_create.c:308
#10 0x00007f6af2d2e4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6af57f77c0 (LWP 14645)):
[KCrash Handler]
#6  QSharedDataPointer (o=..., this=0x7fffc3423e80) at /usr/include/qt4/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at ../../akonadi/entity.cpp:49
#8  0x00007f6aef7eec9e in Akonadi::Entity::operator= (this=0x7fffc3423ec0, other=...) at ../../akonadi/entity.cpp:116
#9  0x00007f6a8edb41a5 in operator= (this=0x7fffc3423ec0) at /usr/include/akonadi/collection.h:75
#10 Message::ComposerViewBase::slotSaveMessage (this=0xed40050, job=0xbabfcc0) at ../../messagecomposer/composerviewbase.cpp:944
#11 0x00007f6af3488281 in QMetaObject::activate (sender=0xbabfcc0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffc3424070) at kernel/qobject.cpp:3547
#12 0x00007f6af38fdc82 in KJob::result (this=<optimized out>, _t1=0xbabfcc0) at ./kjob.moc:208
#13 0x00007f6af38fdcc0 in KJob::emitResult (this=0xbabfcc0) at ../../kdecore/jobs/kjob.cpp:318
#14 0x00007f6af348d446 in QObject::event (this=0xbabfcc0, e=<optimized out>) at kernel/qobject.cpp:1195
#15 0x00007f6af3e69894 in notify_helper (e=0xd306110, receiver=0xbabfcc0, this=0x25189b0) at kernel/qapplication.cpp:4559
#16 QApplicationPrivate::notify_helper (this=0x25189b0, receiver=0xbabfcc0, e=0xd306110) at kernel/qapplication.cpp:4531
#17 0x00007f6af3e6e713 in QApplication::notify (this=0x7fffc3424a00, receiver=0xbabfcc0, e=0xd306110) at kernel/qapplication.cpp:4420
#18 0x00007f6af4ba2bb6 in KApplication::notify (this=0x7fffc3424a00, receiver=0xbabfcc0, event=0xd306110) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x00007f6af3473e9c in QCoreApplication::notifyInternal (this=0x7fffc3424a00, receiver=0xbabfcc0, event=0xd306110) at kernel/qcoreapplication.cpp:876
#20 0x00007f6af3477c6a in sendEvent (event=0xd306110, receiver=0xbabfcc0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x24e2380) at kernel/qcoreapplication.cpp:1500
#22 0x00007f6af34a2f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#23 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#24 0x00007f6aecff5c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f6aecff6060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f6aecff6124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f6af34a33bf in QEventDispatcherGlib::processEvents (this=0x24e3c10, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#28 0x00007f6af3f11d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007f6af3472c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007f6af3472ed7 in QEventLoop::exec (this=0x7fffc3424990, flags=...) at kernel/qeventloop.cpp:204
#31 0x00007f6af3477f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#32 0x0000000000403629 in main (argc=1, argv=0x7fffc3425028) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 253031.

Possible duplicates by query: bug 297038, bug 284842, bug 284505, bug 283619, bug 283593.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-06-02 00:00:29 UTC

*** This bug has been marked as a duplicate of bug 253031 ***