Bug 280961 - akonadi_imap_resource crash on akonadi startup
Summary: akonadi_imap_resource crash on akonadi startup
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.7
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-28 22:03 UTC by Dirk Schoebel
Modified: 2011-08-28 22:19 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Schoebel 2011-08-28 22:03:06 UTC
Application: akonadi_imap_resource (4.7)
KDE Platform Version: 4.7.00 (4.7.0) (Compiled from sources)
Qt Version: 4.7.3
Operating System: Linux 2.6.39.4+ x86_64
Distribution: "Gentoo Base System release 2.0.3"

-- Information about the crash:
Directly after login, when Akonadi is started the akonadi_imap_resource process crashes 3 times and is nonfunctional afterwards. The resource is a imap account with kmail/kolab groupware folders and content. Other resources containing only mails work correctly.
The crash is reproducible on every login and on every akonadi server restart (e.g. via akonadictl).

The crash can be reproduced every time.

-- Backtrace:
Application: Akonadi Resource (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f01f2a67780 (LWP 241933))]

Thread 2 (Thread 0x7f01df98a700 (LWP 241992)):
#0  0x00007f01ee4b72a3 in poll () from /lib64/libc.so.6
#1  0x00007f01ed1f34bd in g_main_context_poll (n_fds=1, fds=0x1e1a620, timeout=-1, context=0x1ce2360, priority=<optimized out>) at gmain.c:3405
#2  g_main_context_iterate (context=0x1ce2360, block=1, dispatch=1, self=<optimized out>) at gmain.c:3087
#3  0x00007f01ed1f39ed in g_main_context_iteration (context=0x1ce2360, may_block=1) at gmain.c:3155
#4  0x00007f01f1f06016 in QEventDispatcherGlib::processEvents (this=0x1cd2460, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f01f1eda492 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f01f1eda6d4 in QEventLoop::exec (this=0x7f01df989de0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f01f1df06a4 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:492
#8  0x00007f01f0b93043 in KIMAP::SessionThread::run (this=0x1e12f10) at /var/tmp/portage/kde-base/kdepimlibs-4.7.0/work/kdepimlibs-4.7.0/kimap/sessionthread.cpp:166
#9  0x00007f01f1df2ef5 in QThreadPrivate::start (arg=0x1e12f10) at thread/qthread_unix.cpp:320
#10 0x00007f01edd67dfc in start_thread () from /lib64/libpthread.so.0
#11 0x00007f01ee4c184d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f01f2a67780 (LWP 241933)):
[KCrash Handler]
#6  0x00007f01f25035a6 in QSharedDataPointer (o=..., this=0x7fff5ea18890) at /usr/include/qt4/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at /var/tmp/portage/kde-base/kdepimlibs-4.7.0/work/kdepimlibs-4.7.0/akonadi/entity.cpp:49
#8  0x00007f01f2503684 in Akonadi::Entity::Entity (this=0x7fff5ea18970, other=<optimized out>) at /var/tmp/portage/kde-base/kdepimlibs-4.7.0/work/kdepimlibs-4.7.0/akonadi/entity.cpp:56
#9  0x000000000041bcc6 in ImapResource::onIdleCollectionFetchDone (this=0x1deb600, job=<optimized out>) at /var/tmp/portage/kde-base/kdepim-runtime-4.7.0/work/kdepim-runtime-4.7.0/resources/imap/imapresource.cpp:504
#10 0x000000000041c445 in ImapResource::qt_metacall (this=0x1deb600, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0x7fff5ea18ac0) at /var/tmp/portage/kde-base/kdepim-runtime-4.7.0/work/kdepim-runtime-4.7.0_build/resources/imap/imapresource.moc:135
#11 0x00007f01f1eef7a7 in QMetaObject::activate (sender=0x1de17f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff5ea18ac0) at kernel/qobject.cpp:3278
#12 0x00007f01eede1b62 in KJob::result (this=<optimized out>, _t1=0x1de17f0) at /var/tmp/portage/kde-base/kdelibs-4.7.0-r1/work/kdelibs-4.7.0_build/kdecore/kjob.moc:194
#13 0x00007f01eede1ba0 in KJob::emitResult (this=0x1de17f0) at /var/tmp/portage/kde-base/kdelibs-4.7.0-r1/work/kdelibs-4.7.0/kdecore/jobs/kjob.cpp:312
#14 0x00007f01f25bda8d in Akonadi::Job::qt_metacall (this=0x1de17f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x1fe4e60) at /var/tmp/portage/kde-base/kdepimlibs-4.7.0/work/kdepimlibs-4.7.0_build/akonadi/job.moc:91
#15 0x00007f01f253d545 in Akonadi::CollectionFetchJob::qt_metacall (this=0x1de17f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x1fe4e60) at /var/tmp/portage/kde-base/kdepimlibs-4.7.0/work/kdepimlibs-4.7.0_build/akonadi/collectionfetchjob.moc:75
#16 0x00007f01f1eef2aa in QObject::event (this=0x1de17f0, e=<optimized out>) at kernel/qobject.cpp:1217
#17 0x00007f01f12c3a14 in QApplicationPrivate::notify_helper (this=0x1c698d0, receiver=0x1de17f0, e=0x1fdd030) at kernel/qapplication.cpp:4462
#18 0x00007f01f12c858a in QApplication::notify (this=<optimized out>, receiver=0x1de17f0, e=0x1fdd030) at kernel/qapplication.cpp:4341
#19 0x00007f01ef3db806 in KApplication::notify (this=0x7fff5ea19550, receiver=0x1de17f0, event=0x1fdd030) at /var/tmp/portage/kde-base/kdelibs-4.7.0-r1/work/kdelibs-4.7.0/kdeui/kernel/kapplication.cpp:311
#20 0x00007f01f1edb0cb in QCoreApplication::notifyInternal (this=0x7fff5ea19550, receiver=0x1de17f0, event=0x1fdd030) at kernel/qcoreapplication.cpp:731
#21 0x00007f01f1ede884 in sendEvent (event=0x1fdd030, receiver=0x1de17f0) at kernel/qcoreapplication.h:215
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1c433e0) at kernel/qcoreapplication.cpp:1372
#23 0x00007f01f1f05e23 in sendPostedEvents () at kernel/qcoreapplication.h:220
#24 postEventSourceDispatch (s=0x1c675e0) at kernel/qeventdispatcher_glib.cpp:277
#25 0x00007f01ed1f2f6e in g_main_dispatch (context=0x1c668e0) at gmain.c:2441
#26 g_main_context_dispatch (context=0x1c668e0) at gmain.c:3014
#27 0x00007f01ed1f3758 in g_main_context_iterate (context=0x1c668e0, block=1, dispatch=1, self=<optimized out>) at gmain.c:3092
#28 0x00007f01ed1f39ed in g_main_context_iteration (context=0x1c668e0, may_block=1) at gmain.c:3155
#29 0x00007f01f1f05fbf in QEventDispatcherGlib::processEvents (this=0x1c61b40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#30 0x00007f01f1368e7e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007f01f1eda492 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007f01f1eda6d4 in QEventLoop::exec (this=0x7fff5ea194c0, flags=...) at kernel/qeventloop.cpp:201
#33 0x00007f01f1edeb3b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#34 0x00007f01f25d4c36 in Akonadi::ResourceBase::init (r=0x1deb600) at /var/tmp/portage/kde-base/kdepimlibs-4.7.0/work/kdepimlibs-4.7.0/akonadi/resourcebase.cpp:393
#35 0x0000000000419c88 in init<ImapResource> (argv=<optimized out>, argc=<optimized out>) at /usr/include/akonadi/resourcebase.h:188
#36 main (argc=<optimized out>, argv=<optimized out>) at /var/tmp/portage/kde-base/kdepim-runtime-4.7.0/work/kdepim-runtime-4.7.0/resources/imap/imapresource.cpp:598

Possible duplicates by query: bug 280149, bug 280137, bug 278824, bug 278799, bug 277930.

Reported using DrKonqi
Comment 1 Christophe Marin 2011-08-28 22:19:20 UTC

*** This bug has been marked as a duplicate of bug 253031 ***