Bug 292983 - IMAP crashes and entire Kontact goes down and desktop stops responding
Summary: IMAP crashes and entire Kontact goes down and desktop stops responding
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-31 17:18 UTC by Richard Ssekibuule
Modified: 2012-02-03 13:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Ssekibuule 2012-01-31 17:18:57 UTC
Application: akonadi_imap_resource (4.7)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I was retrieving IMAP mails using a folder refresh procedure. The entire desktop slowed down and the desktop stopped responding

-- Backtrace:
Application: Google Mail of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0xb773e710 (LWP 2217))]

Thread 2 (Thread 0xb6aa3b70 (LWP 2219)):
#0  0x00ff1416 in __kernel_vsyscall ()
#1  0x00ce840e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x02b8a34b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x02b7b896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x02b7bc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00644b37 in QEventDispatcherGlib::processEvents (this=0x8863a40, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x006151dd in QEventLoop::processEvents (this=0xb6aa32d0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00615421 in QEventLoop::exec (this=0xb6aa32d0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0051890b in QThread::exec (this=0x88d3710) at thread/qthread.cpp:498
#9  0x008c84d0 in KIMAP::SessionThread::run (this=0x88d3710) at ../../kimap/sessionthread.cpp:169
#10 0x0051b7b3 in QThreadPrivate::start (arg=0x88d3710) at thread/qthread_unix.cpp:331
#11 0x00444d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00cf70ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb773e710 (LWP 2217)):
[KCrash Handler]
#7  QSharedDataPointer (o=..., this=0xbfaccb0c) at /usr/include/qt4/QtCore/qshareddata.h:93
#8  assignEntityPrivate (one=..., other=...) at ../../akonadi/entity.cpp:49
#9  0x00a4b9eb in Akonadi::Entity::Entity (this=0xbfaccbac, other=...) at ../../akonadi/entity.cpp:56
#10 0x00a7cac3 in Akonadi::Collection::Collection (this=0xbfaccbac, other=...) at ../../akonadi/collection.cpp:72
#11 0x0805cfbd in ImapResource::onIdleCollectionFetchDone (this=0x88ea238, job=0x889e060) at ../../../resources/imap/imapresource.cpp:505
#12 0x0805dc9d in ImapResource::qt_metacall (this=0x88ea238, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0xbfaccce8) at ./imapresource.moc:135
#13 0x0061cb7d in metacall (argv=0xbfaccce8, idx=67, cl=QMetaObject::InvokeMetaMethod, object=0x88ea238) at kernel/qmetaobject.cpp:237
#14 QMetaObject::metacall (object=0x88ea238, cl=QMetaObject::InvokeMetaMethod, idx=67, argv=0xbfaccce8) at kernel/qmetaobject.cpp:232
#15 0x0062ba6a in QMetaObject::activate (sender=0x889e060, m=0x1d7958c, local_signal_index=3, argv=0xbfaccce8) at kernel/qobject.cpp:3278
#16 0x01bcbef5 in KJob::result (this=0x889e060, _t1=0x889e060) at ./kjob.moc:194
#17 0x01bcbf48 in KJob::emitResult (this=0x889e060) at ../../kdecore/jobs/kjob.cpp:312
#18 0x00b17b9e in Akonadi::JobPrivate::delayedEmitResult (this=0x8ab7b58) at ../../akonadi/job.cpp:144
#19 0x00b188af in Akonadi::Job::qt_metacall (this=0x889e060, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x8ac0980) at ./job.moc:91
#20 0x00a8b572 in Akonadi::CollectionFetchJob::qt_metacall (this=0x889e060, _c=QMetaObject::InvokeMetaMethod, _id=34, _a=0x8ac0980) at ./collectionfetchjob.moc:75
#21 0x0061cb7d in metacall (argv=0x8ac0980, idx=34, cl=QMetaObject::InvokeMetaMethod, object=0x889e060) at kernel/qmetaobject.cpp:237
#22 QMetaObject::metacall (object=0x889e060, cl=QMetaObject::InvokeMetaMethod, idx=34, argv=0x8ac0980) at kernel/qmetaobject.cpp:232
#23 0x00627685 in QMetaCallEvent::placeMetaCall (this=0x886f168, object=0x889e060) at kernel/qobject.cpp:535
#24 0x0062eb52 in QObject::event (this=0x889e060, e=0x886f168) at kernel/qobject.cpp:1217
#25 0x01149d84 in notify_helper (e=0x886f168, receiver=0x889e060, this=0x881c478) at kernel/qapplication.cpp:4486
#26 QApplicationPrivate::notify_helper (this=0x881c478, receiver=0x889e060, e=0x886f168) at kernel/qapplication.cpp:4458
#27 0x0114f133 in QApplication::notify (this=0x886f168, receiver=0x889e060, e=0x886f168) at kernel/qapplication.cpp:3886
#28 0x0784d971 in KApplication::notify (this=0xbfacd4a0, receiver=0x889e060, event=0x886f168) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x0061619e in QCoreApplication::notifyInternal (this=0xbfacd4a0, receiver=0x889e060, event=0x886f168) at kernel/qcoreapplication.cpp:787
#30 0x00619f93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x87ffd60) at kernel/qcoreapplication.cpp:1428
#32 0x0061a0ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#33 0x006446a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#34 postEventSourceDispatch (s=0x881ed80) at kernel/qeventdispatcher_glib.cpp:277
#35 0x02b7b25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#36 0x02b7b990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#37 0x02b7bc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x00644ada in QEventDispatcherGlib::processEvents (this=0x8800c68, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#39 0x01201e7a in QGuiEventDispatcherGlib::processEvents (this=0x8800c68, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x006151dd in QEventLoop::processEvents (this=0xbfacd404, flags=...) at kernel/qeventloop.cpp:149
#41 0x00615421 in QEventLoop::exec (this=0xbfacd404, flags=...) at kernel/qeventloop.cpp:201
#42 0x0061a19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#43 0x01147924 in QApplication::exec () at kernel/qapplication.cpp:3760
#44 0x00b32311 in Akonadi::ResourceBase::init (r=0x88ea238) at ../../akonadi/resourcebase.cpp:393
#45 0x0805e147 in Akonadi::ResourceBase::init<ImapResource> (argc=3, argv=0xbfacd574) at /usr/include/akonadi/resourcebase.h:188
#46 0x0805859b in main (argc=3, argv=0xbfacd574) at ../../../resources/imap/imapresource.cpp:599

This bug may be a duplicate of or related to bug 253031.

Possible duplicates by query: bug 290342, bug 290189, bug 288785, bug 287011, bug 285883.

Reported using DrKonqi
Comment 1 Christophe Marin 2012-02-03 13:06:52 UTC

*** This bug has been marked as a duplicate of bug 253031 ***