Bug 264994 - akonadi resource crashed after sending mail
Summary: akonadi resource crashed after sending mail
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Mixed Maildir resource (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-31 20:29 UTC by Achim Herwig
Modified: 2011-11-17 23:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Achim Herwig 2011-01-31 20:29:28 UTC
Application: akonadi_mixedmaildir_resource (0.1)
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.1
Operating System: Linux 2.6.31.14-0.6-desktop x86_64
Distribution: "openSUSE 11.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I sent a mail comprising a number of recipients. After sending out (I checked in the mail server logs that it really worked), the akonadi resource crashed with the backtrace as below. The message was correctly moved to the desired folder on an IMAP resource, though (plain login over TLS).

This was the first time for this kind of crash though I already sent quite a number of mails this way.

The crash does not seem to be reproducible.

-- Backtrace:
Application: Akonadi Resource (akonadi_mixedmaildir_resource), signal: Segmentation fault
[KCrash Handler]
#6  QSharedDataPointer (o=<value optimized out>, this=<value optimized out>) at /usr/include/QtCore/qshareddata.h:93
#7  assignEntityPrivate (o=<value optimized out>, this=<value optimized out>) at /usr/src/debug/kdepimlibs-4.6.0svn.rev1216163/akonadi/entity.cpp:49
#8  0x00007fb901f986c4 in Akonadi::Entity::Entity (this=0x7fffcf82b010, other=...) at /usr/src/debug/kdepimlibs-4.6.0svn.rev1216163/akonadi/entity.cpp:56
#9  0x00000000004126be in _start ()

This bug may be a duplicate of or related to bug 258430.

Possible duplicates by query: bug 259924, bug 258684, bug 258430, bug 253031, bug 250078.

Reported using DrKonqi
Comment 1 Christophe Marin 2011-11-17 23:47:04 UTC

*** This bug has been marked as a duplicate of bug 253031 ***