Bug 301110 - Kontact crashes after changing IMAP settings for gmail
Summary: Kontact crashes after changing IMAP settings for gmail
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.8
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-03 16:16 UTC by David
Modified: 2012-07-06 19:13 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David 2012-06-03 16:16:42 UTC
Application: akonadi_imap_resource (4.8)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-25-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I disabled the local subscriptions, then the IMAP client of kmail crashed, now i am unable to recreate the folder

-- Backtrace:
Application: gmail of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fbe76f7b780 (LWP 2545))]

Thread 3 (Thread 0x7fbe61b4e700 (LWP 4346)):
#0  0x00007fbe7292db03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fbe71479ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fbe7147a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fbe763a5426 in QEventDispatcherGlib::processEvents (this=0x7fbe580008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fbe76374c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fbe76374ed7 in QEventLoop::exec (this=0x7fbe61b4dde0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fbe76273fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fbe74faac39 in KIMAP::SessionThread::run (this=0x2498540) at ../../kimap/sessionthread.cpp:181
#8  0x00007fbe76276fcb in QThreadPrivate::start (arg=0x2498540) at thread/qthread_unix.cpp:298
#9  0x00007fbe71f95e9a in start_thread (arg=0x7fbe61b4e700) at pthread_create.c:308
#10 0x00007fbe729394bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fbe530ad700 (LWP 6979)):
#0  0x00007fbe7292db03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fbe71479ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fbe7147a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fbe763a5426 in QEventDispatcherGlib::processEvents (this=0x7fbe48002400, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fbe76374c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fbe76374ed7 in QEventLoop::exec (this=0x7fbe530acde0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fbe76273fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fbe74faac39 in KIMAP::SessionThread::run (this=0x2c30d10) at ../../kimap/sessionthread.cpp:181
#8  0x00007fbe76276fcb in QThreadPrivate::start (arg=0x2c30d10) at thread/qthread_unix.cpp:298
#9  0x00007fbe71f95e9a in start_thread (arg=0x7fbe530ad700) at pthread_create.c:308
#10 0x00007fbe729394bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fbe76f7b780 (LWP 2545)):
[KCrash Handler]
#6  QSharedDataPointer (o=..., this=0x7fffb02e9ee0) at /usr/include/qt4/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at ../../akonadi/entity.cpp:49
#8  0x00007fbe769c2cc4 in Akonadi::Entity::Entity (this=0x7fffb02e9f40, other=...) at ../../akonadi/entity.cpp:56
#9  0x000000000041986f in ImapResource::onIdleCollectionFetchDone (this=0x2395460, job=0x27da0c0) at ../../../resources/imap/imapresource.cpp:513
#10 0x00007fbe7638a281 in QMetaObject::activate (sender=0x27da0c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffb02ea120) at kernel/qobject.cpp:3547
#11 0x00007fbe7324cc82 in KJob::result (this=<optimized out>, _t1=0x27da0c0) at ./kjob.moc:208
#12 0x00007fbe7324ccc0 in KJob::emitResult (this=0x27da0c0) at ../../kdecore/jobs/kjob.cpp:318
#13 0x00007fbe7638f446 in QObject::event (this=0x27da0c0, e=<optimized out>) at kernel/qobject.cpp:1195
#14 0x00007fbe756f8894 in notify_helper (e=0x248eae0, receiver=0x27da0c0, this=0x21f8d90) at kernel/qapplication.cpp:4559
#15 QApplicationPrivate::notify_helper (this=0x21f8d90, receiver=0x27da0c0, e=0x248eae0) at kernel/qapplication.cpp:4531
#16 0x00007fbe756fd713 in QApplication::notify (this=0x7fffb02eaac0, receiver=0x27da0c0, e=0x248eae0) at kernel/qapplication.cpp:4420
#17 0x00007fbe73823bb6 in KApplication::notify (this=0x7fffb02eaac0, receiver=0x27da0c0, event=0x248eae0) at ../../kdeui/kernel/kapplication.cpp:311
#18 0x00007fbe76375e9c in QCoreApplication::notifyInternal (this=0x7fffb02eaac0, receiver=0x27da0c0, event=0x248eae0) at kernel/qcoreapplication.cpp:876
#19 0x00007fbe76379c6a in sendEvent (event=0x248eae0, receiver=0x27da0c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x21cd4d0) at kernel/qcoreapplication.cpp:1500
#21 0x00007fbe763a4f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#22 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#23 0x00007fbe71479c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fbe7147a060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007fbe7147a124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fbe763a53bf in QEventDispatcherGlib::processEvents (this=0x21cecb0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#27 0x00007fbe757a0d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007fbe76374c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007fbe76374ed7 in QEventLoop::exec (this=0x7fffb02eaa40, flags=...) at kernel/qeventloop.cpp:204
#30 0x00007fbe76379f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#31 0x00007fbe76aa42f6 in Akonadi::ResourceBase::init (r=0x2395460) at ../../akonadi/resourcebase.cpp:412
#32 0x000000000041a996 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:188
#33 0x00007fbe7286876d in __libc_start_main (main=0x4151c0 <main(int, char**)>, argc=3, ubp_av=0x7fffb02eabd8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffb02eabc8) at libc-start.c:226
#34 0x0000000000415375 in _start ()

This bug may be a duplicate of or related to bug 253031.

Possible duplicates by query: bug 299330, bug 293311, bug 292983, bug 290342, bug 290189.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-06 19:13:30 UTC

*** This bug has been marked as a duplicate of bug 253031 ***