Bug 288785 - Gmail IMAP connection crashes, Akonadi error?!
Summary: Gmail IMAP connection crashes, Akonadi error?!
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-12 10:41 UTC by Pyroman
Modified: 2011-12-13 09:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pyroman 2011-12-12 10:41:34 UTC
Application: akonadi_imap_resource (4.7)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
It crashes after start up since today. Bug reappears after restart too.

The crash can be reproduced every time.

-- Backtrace:
Application: Gmail-IMAP of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0xb771b710 (LWP 1717))]

Thread 2 (Thread 0xb6ad0b70 (LWP 1776)):
#0  0x00ad2d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x004757d5 in do_gettime (frac=0xb6ad0040, sec=0xb6ad0038) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x005484b6 in QTimerInfoList::updateCurrentTime (this=0x9aa967c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0054880a in QTimerInfoList::timerWait (this=0x9aa967c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00547053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb6ad014c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x005470ed in timerSourcePrepare (source=0x9aa9648, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0475288c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x04753637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x04753c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00547b37 in QEventDispatcherGlib::processEvents (this=0x9aa8028, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x005181dd in QEventLoop::processEvents (this=0xb6ad02d0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00518421 in QEventLoop::exec (this=0xb6ad02d0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0041b90b in QThread::exec (this=0x9aa78c8) at thread/qthread.cpp:498
#14 0x007cb4d0 in KIMAP::SessionThread::run (this=0x9aa78c8) at ../../kimap/sessionthread.cpp:169
#15 0x0041e7b3 in QThreadPrivate::start (arg=0x9aa78c8) at thread/qthread_unix.cpp:331
#16 0x009d5d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x096ab0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb771b710 (LWP 1717)):
[KCrash Handler]
#7  QSharedDataPointer (o=..., this=0xbfd424ec) at /usr/include/qt4/QtCore/qshareddata.h:93
#8  assignEntityPrivate (one=..., other=...) at ../../akonadi/entity.cpp:49
#9  0x0016076b in Akonadi::Entity::Entity (this=0xbfd4258c, other=...) at ../../akonadi/entity.cpp:56
#10 0x001913d3 in Akonadi::Collection::Collection (this=0xbfd4258c, other=...) at ../../akonadi/collection.cpp:72
#11 0x0805cf9d in ImapResource::onIdleCollectionFetchDone (this=0x9a513c8, job=0xb6106520) at ../../../resources/imap/imapresource.cpp:504
#12 0x0805dc7d in ImapResource::qt_metacall (this=0x9a513c8, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0xbfd426c8) at ./imapresource.moc:135
#13 0x0051fb7d in metacall (argv=0xbfd426c8, idx=66, cl=QMetaObject::InvokeMetaMethod, object=0x9a513c8) at kernel/qmetaobject.cpp:237
#14 QMetaObject::metacall (object=0x9a513c8, cl=QMetaObject::InvokeMetaMethod, idx=66, argv=0xbfd426c8) at kernel/qmetaobject.cpp:232
#15 0x0052ea6a in QMetaObject::activate (sender=0xb6106520, m=0x4dcb58c, local_signal_index=3, argv=0xbfd426c8) at kernel/qobject.cpp:3278
#16 0x04c1deb5 in KJob::result (this=0xb6106520, _t1=0xb6106520) at ./kjob.moc:194
#17 0x04c1df08 in KJob::emitResult (this=0xb6106520) at ../../kdecore/jobs/kjob.cpp:312
#18 0x0022c25e in Akonadi::JobPrivate::delayedEmitResult (this=0xb6114e00) at ../../akonadi/job.cpp:144
#19 0x0022cf6f in Akonadi::Job::qt_metacall (this=0xb6106520, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xb6100d58) at ./job.moc:91
#20 0x0019fe22 in Akonadi::CollectionFetchJob::qt_metacall (this=0xb6106520, _c=QMetaObject::InvokeMetaMethod, _id=34, _a=0xb6100d58) at ./collectionfetchjob.moc:75
#21 0x0051fb7d in metacall (argv=0xb6100d58, idx=34, cl=QMetaObject::InvokeMetaMethod, object=0xb6106520) at kernel/qmetaobject.cpp:237
#22 QMetaObject::metacall (object=0xb6106520, cl=QMetaObject::InvokeMetaMethod, idx=34, argv=0xb6100d58) at kernel/qmetaobject.cpp:232
#23 0x0052a685 in QMetaCallEvent::placeMetaCall (this=0xb61077a0, object=0xb6106520) at kernel/qobject.cpp:535
#24 0x00531b52 in QObject::event (this=0xb6106520, e=0xb61077a0) at kernel/qobject.cpp:1217
#25 0x00d8bd54 in notify_helper (e=0xb61077a0, receiver=0xb6106520, this=0x997b4d0) at kernel/qapplication.cpp:4486
#26 QApplicationPrivate::notify_helper (this=0x997b4d0, receiver=0xb6106520, e=0xb61077a0) at kernel/qapplication.cpp:4458
#27 0x00d91103 in QApplication::notify (this=0xb61077a0, receiver=0xb6106520, e=0xb61077a0) at kernel/qapplication.cpp:3886
#28 0x05dbb681 in KApplication::notify (this=0xbfd42e80, receiver=0xb6106520, event=0xb61077a0) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x0051919e in QCoreApplication::notifyInternal (this=0xbfd42e80, receiver=0xb6106520, event=0xb61077a0) at kernel/qcoreapplication.cpp:787
#30 0x0051cf93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x995dd60) at kernel/qcoreapplication.cpp:1428
#32 0x0051d0ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#33 0x005476a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#34 postEventSourceDispatch (s=0x997dbc8) at kernel/qeventdispatcher_glib.cpp:277
#35 0x0475325f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#36 0x04753990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#37 0x04753c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x00547ada in QEventDispatcherGlib::processEvents (this=0x995ec68, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#39 0x00e43e3a in QGuiEventDispatcherGlib::processEvents (this=0x995ec68, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x005181dd in QEventLoop::processEvents (this=0xbfd42de4, flags=...) at kernel/qeventloop.cpp:149
#41 0x00518421 in QEventLoop::exec (this=0xbfd42de4, flags=...) at kernel/qeventloop.cpp:201
#42 0x0051d19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#43 0x00d898f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#44 0x002469d1 in Akonadi::ResourceBase::init (r=0x9a513c8) at ../../akonadi/resourcebase.cpp:393
#45 0x0805e127 in Akonadi::ResourceBase::init<ImapResource> (argc=3, argv=0xbfd42f54) at /usr/include/akonadi/resourcebase.h:188
#46 0x0805859b in main (argc=3, argv=0xbfd42f54) at ../../../resources/imap/imapresource.cpp:598

This bug may be a duplicate of or related to bug 253031.

Possible duplicates by query: bug 287011, bug 285883, bug 283341, bug 282060, bug 282036.

Reported using DrKonqi
Comment 1 Christophe Marin 2011-12-13 09:33:40 UTC

*** This bug has been marked as a duplicate of bug 253031 ***