Bug 331499 - Error starting kmail. "Unable to fetch item from backend (collection 0): Unable to contact resource"
Summary: Error starting kmail. "Unable to fetch item from backend (collection 0): Unab...
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.12
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-02-25 16:34 UTC by Dmitry
Modified: 2014-03-10 09:03 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry 2014-02-25 16:34:04 UTC
Application: akonadi_imap_resource (4.12)
KDE Platform Version: 4.12.2
Qt Version: 4.8.6
Operating System: Linux 3.13.0-12-generic x86_64
Distribution: Ubuntu Trusty Tahr (development branch)

-- Information about the crash:
Error starting kmail. "Unable to fetch item from backend (collection 0): Unable to contact resource"

The crash can be reproduced every time.

-- Backtrace:
Application: Google Mail (mail.rage) типа Почтовый сервер IMAP (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8a9b4797c0 (LWP 2640))]

Thread 2 (Thread 0x7f8a877b2700 (LWP 2692)):
#0  0x00007f8a96e3bddd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f8a95b68004 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8a95b6810c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8a9a873836 in QEventDispatcherGlib::processEvents (this=0x7f8a800008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4  0x00007f8a9a84509f in QEventLoop::processEvents (this=this@entry=0x7f8a877b1e20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8a9a845395 in QEventLoop::exec (this=this@entry=0x7f8a877b1e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f8a9a741c4f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#7  0x00007f8a9a74431f in QThreadPrivate::start (arg=0x1dade30) at thread/qthread_unix.cpp:349
#8  0x00007f8a9648c182 in start_thread (arg=0x7f8a877b2700) at pthread_create.c:312
#9  0x00007f8a96e4912d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f8a9b4797c0 (LWP 2640)):
[KCrash Handler]
#6  QSharedDataPointer (o=..., this=0x7fffd6112730) at /usr/include/qt4/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at ../../akonadi/entity.cpp:49
#8  0x00007f8a9aea3355 in Akonadi::Entity::Entity (this=0x7fffd6112790, other=...) at ../../akonadi/entity.cpp:55
#9  0x000000000041c7d4 in ImapResource::onIdleCollectionFetchDone (this=0x1d49870, job=<optimized out>) at ../../../resources/imap/imapresource.cpp:677
#10 0x000000000041e374 in ImapResource::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./imapresource.moc:118
#11 0x00007f8a9a85a868 in QMetaObject::activate (sender=sender@entry=0x1d7af60, m=m@entry=0x7f8a97ae0600 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fffd6112940) at kernel/qobject.cpp:3539
#12 0x00007f8a977506f2 in KJob::result (this=this@entry=0x1d7af60, _t1=_t1@entry=0x1d7af60) at ./kjob.moc:207
#13 0x00007f8a97750730 in KJob::emitResult (this=0x1d7af60) at ../../kdecore/jobs/kjob.cpp:318
#14 0x00007f8a9a85ec0e in QObject::event (this=0x1d7af60, e=<optimized out>) at kernel/qobject.cpp:1194
#15 0x00007f8a99bdde2c in QApplicationPrivate::notify_helper (this=this@entry=0x1b95880, receiver=receiver@entry=0x1d7af60, e=e@entry=0x1d78e00) at kernel/qapplication.cpp:4567
#16 0x00007f8a99be44a0 in QApplication::notify (this=this@entry=0x7fffd6113000, receiver=receiver@entry=0x1d7af60, e=e@entry=0x1d78e00) at kernel/qapplication.cpp:4353
#17 0x00007f8a97d10aaa in KApplication::notify (this=0x7fffd6113000, receiver=0x1d7af60, event=0x1d78e00) at ../../kdeui/kernel/kapplication.cpp:311
#18 0x00007f8a9a8464cd in QCoreApplication::notifyInternal (this=0x7fffd6113000, receiver=receiver@entry=0x1d7af60, event=event@entry=0x1d78e00) at kernel/qcoreapplication.cpp:953
#19 0x00007f8a9a849b2d in sendEvent (event=0x1d78e00, receiver=0x1d7af60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1b637a0) at kernel/qcoreapplication.cpp:1577
#21 0x00007f8a9a849fd3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#22 0x00007f8a9a873f53 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#23 postEventSourceDispatch (s=0x1b91480) at kernel/qeventdispatcher_glib.cpp:280
#24 0x00007f8a95b67e24 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f8a95b68068 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f8a95b6810c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f8a9a873815 in QEventDispatcherGlib::processEvents (this=0x1b64c60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#28 0x00007f8a99c7fbb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007f8a9a84509f in QEventLoop::processEvents (this=this@entry=0x7fffd6112f70, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007f8a9a845395 in QEventLoop::exec (this=this@entry=0x7fffd6112f70, flags=...) at kernel/qeventloop.cpp:204
#31 0x00007f8a9a84ab69 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#32 0x00007f8a99bdc37c in QApplication::exec () at kernel/qapplication.cpp:3828
#33 0x00007f8a9af80c33 in Akonadi::ResourceBase::init (r=r@entry=0x1d49870) at ../../akonadi/resourcebase.cpp:504
#34 0x000000000041fae3 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:192
#35 0x00007f8a96d6fec5 in __libc_start_main (main=0x4167b0 <main(int, char**)>, argc=3, argv=0x7fffd6113118, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffd6113108) at libc-start.c:285
#36 0x0000000000416934 in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 329805.

Possible duplicates by query: bug 330269, bug 329805, bug 325911, bug 323883, bug 323115.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-03-10 09:03:39 UTC

*** This bug has been marked as a duplicate of bug 253031 ***