Bug 283341 - Akonadi Crash after login
Summary: Akonadi Crash after login
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-04 19:20 UTC by CisBug
Modified: 2011-10-04 19:49 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description CisBug 2011-10-04 19:20:47 UTC
Application: akonadi_imap_resource (4.7)
KDE Platform Version: 4.7.1 (4.7.1)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
The Netbook has just booted and I have logged in. KMail is contained in KDE Autostart.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Akonadi Resource (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0xb775c930 (LWP 1536))]

Thread 2 (Thread 0xb53feb70 (LWP 1830)):
#0  0x0092cd41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x0060add8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x006d74f2 in updateCurrentTime (this=0x87c96b4, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x87c96b4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x006d5d32 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb53fe0fc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x006d5dcd in timerSourcePrepare (source=0x87c9680, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0321efd4 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x0321fe63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x03220524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x006d6577 in QEventDispatcherGlib::processEvents (this=0x86acc18, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x006a8289 in QEventLoop::processEvents (this=0xb53fe2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x006a8522 in QEventLoop::exec (this=0xb53fe2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x005b22a0 in QThread::exec (this=0x8697260) at thread/qthread.cpp:492
#14 0x00143cb2 in KIMAP::SessionThread::run (this=0x8697260) at ../../kimap/sessionthread.cpp:169
#15 0x005b4da2 in QThreadPrivate::start (arg=0x8697260) at thread/qthread_unix.cpp:320
#16 0x00c24e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x072fc73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb775c930 (LWP 1536)):
[KCrash Handler]
#7  QSharedDataPointer (one=..., other=...) at /usr/include/qt4/QtCore/qshareddata.h:93
#8  assignEntityPrivate (one=..., other=...) at ../../akonadi/entity.cpp:49
#9  0x0027018a in Akonadi::Entity::Entity (this=0xbfc2edbc, other=...) at ../../akonadi/entity.cpp:56
#10 0x002a07f4 in Akonadi::Collection::Collection (this=0xbfc2edbc, other=...) at ../../akonadi/collection.cpp:72
#11 0x0805cc92 in ImapResource::onIdleCollectionFetchDone (this=0x8657268, job=0x87c1328) at ../../../resources/imap/imapresource.cpp:504
#12 0x0805d942 in ImapResource::qt_metacall (this=0x8657268, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0xbfc2eed8) at ./imapresource.moc:135
#13 0x006af6ba in QMetaObject::metacall (object=0x8657268, cl=QMetaObject::InvokeMetaMethod, idx=66, argv=0xbfc2eed8) at kernel/qmetaobject.cpp:237
#14 0x006bf4ff in QMetaObject::activate (sender=0x87c1328, m=0x20d4508, local_signal_index=3, argv=0xbfc2eed8) at kernel/qobject.cpp:3287
#15 0x01f75443 in KJob::result (this=0x87c1328, _t1=0x87c1328) at ./kjob.moc:194
#16 0x01f75498 in KJob::emitResult (this=0x87c1328) at ../../kdecore/jobs/kjob.cpp:312
#17 0x00336450 in Akonadi::JobPrivate::delayedEmitResult (this=0x87c1340) at ../../akonadi/job.cpp:144
#18 0x00337096 in Akonadi::Job::qt_metacall (this=0x87c1328, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x86b85c0) at ./job.moc:91
#19 0x002ae70a in Akonadi::CollectionFetchJob::qt_metacall (this=0x87c1328, _c=QMetaObject::InvokeMetaMethod, _id=34, _a=0x86b85c0) at ./collectionfetchjob.moc:75
#20 0x006af6ba in QMetaObject::metacall (object=0x87c1328, cl=QMetaObject::InvokeMetaMethod, idx=34, argv=0x86b85c0) at kernel/qmetaobject.cpp:237
#21 0x006b9e16 in QMetaCallEvent::placeMetaCall (this=0x8697fe8, object=0x87c1328) at kernel/qobject.cpp:535
#22 0x006be3b7 in QObject::event (this=0x87c1328, e=0x8697fe8) at kernel/qobject.cpp:1226
#23 0x00d79d24 in QApplicationPrivate::notify_helper (this=0x85b7f80, receiver=0x87c1328, e=0x8697fe8) at kernel/qapplication.cpp:4462
#24 0x00d7e8ce in QApplication::notify (this=0xbfc2f800, receiver=0x87c1328, e=0x8697fe8) at kernel/qapplication.cpp:3862
#25 0x06b3ec9a in KApplication::notify (this=0xbfc2f800, receiver=0x87c1328, event=0x8697fe8) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x006a90bb in QCoreApplication::notifyInternal (this=0xbfc2f800, receiver=0x87c1328, event=0x8697fe8) at kernel/qcoreapplication.cpp:731
#27 0x006acc79 in sendEvent (receiver=0x0, event_type=0, data=0x857c990) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x857c990) at kernel/qcoreapplication.cpp:1372
#29 0x006ace0d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#30 0x006d63c4 in sendPostedEvents (s=0x85b56d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#31 postEventSourceDispatch (s=0x85b56d0) at kernel/qeventdispatcher_glib.cpp:277
#32 0x0321faa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#33 0x03220270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#34 0x03220524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#35 0x006d653c in QEventDispatcherGlib::processEvents (this=0x857c4e8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#36 0x00e301e5 in QGuiEventDispatcherGlib::processEvents (this=0x857c4e8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#37 0x006a8289 in QEventLoop::processEvents (this=0xbfc2f754, flags=...) at kernel/qeventloop.cpp:149
#38 0x006a8522 in QEventLoop::exec (this=0xbfc2f754, flags=...) at kernel/qeventloop.cpp:201
#39 0x006acecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#40 0x00d778e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#41 0x0034f938 in Akonadi::ResourceBase::init (r=0x8657268) at ../../akonadi/resourcebase.cpp:393
#42 0x0805b303 in init<ImapResource> (argc=0, argv=0x0) at /usr/include/akonadi/resourcebase.h:188
#43 main (argc=0, argv=0x0) at ../../../resources/imap/imapresource.cpp:598

This bug may be a duplicate of or related to bug 253031.

Possible duplicates by query: bug 282060, bug 282036, bug 280961, bug 280149, bug 280137.

Reported using DrKonqi
Comment 1 Christophe Marin 2011-10-04 19:49:14 UTC

*** This bug has been marked as a duplicate of bug 253031 ***