Bug 293820 - kmail2 barfed on quit from composer
Summary: kmail2 barfed on quit from composer
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: kmail2
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-10 23:52 UTC by Christopher Heiny
Modified: 2012-03-30 13:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Heiny 2012-02-10 23:52:59 UTC
Application: kmail (4.7.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.2.2-1.fc16.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
Quit kmail2 by hitting CTRL-Q while focus was in a new message editor.  A dialog popped up, and I elected to save the message as a draft.  Windows closed and crash assistant popped up.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f028e01a840 (LWP 2958))]

Thread 3 (Thread 0x7f0281699700 (LWP 2964)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x00000034e41b86ec in WTF::TCMalloc_PageHeap::scavengerThread (this=0x34e4b7cc20) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x00000034e41b8819 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003a0dc07d90 in start_thread (arg=0x7f0281699700) at pthread_create.c:309
#4  0x0000003a0d4ef48d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f0280d98700 (LWP 2965)):
#0  0x0000003a0d4e6af3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00000034f9a44fd8 in g_main_context_poll (n_fds=1, fds=0x7f027c0013e0, priority=<optimized out>, timeout=9254, context=0x7f027c0009a0) at gmain.c:3402
#2  g_main_context_iterate (context=0x7f027c0009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3084
#3  0x00000034f9a4549c in g_main_context_iteration (context=0x7f027c0009a0, may_block=1) at gmain.c:3152
#4  0x00000034d7da7dc6 in QEventDispatcherGlib::processEvents (this=0x7f027c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00000034d7d78182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00000034d7d783d7 in QEventLoop::exec (this=0x7f0280d97d40, flags=...) at kernel/qeventloop.cpp:204
#7  0x00000034d7c78b27 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00000034d7c7bb6b in QThreadPrivate::start (arg=0xfc5360) at thread/qthread_unix.cpp:298
#9  0x0000003a0dc07d90 in start_thread (arg=0x7f0280d98700) at pthread_create.c:309
#10 0x0000003a0d4ef48d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f028e01a840 (LWP 2958)):
[KCrash Handler]
#6  QSharedDataPointer (o=..., this=0x7fff42597760) at /usr/include/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at /usr/src/debug/kdepimlibs-4.7.4/akonadi/entity.cpp:49
#8  0x00000034e107acee in Akonadi::Entity::operator= (this=0x7fff425977a0, other=<optimized out>) at /usr/src/debug/kdepimlibs-4.7.4/akonadi/entity.cpp:116
#9  0x00000034eb67d6a5 in operator= (this=0x7fff425977a0) at /usr/include/kde4/akonadi/collection.h:75
#10 Message::ComposerViewBase::slotSaveMessage (this=0x2e1f890, job=0x3e19e50) at /usr/src/debug/kdepim-4.7.4/messagecomposer/composerviewbase.cpp:978
#11 0x00000034d7d8cce1 in QMetaObject::activate (sender=0x3e19e50, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff42597950) at kernel/qobject.cpp:3547
#12 0x00000034d9d41d92 in KJob::result (this=<optimized out>, _t1=0x3e19e50) at /usr/src/debug/kdelibs-4.7.4/x86_64-redhat-linux-gnu/kdecore/kjob.moc:208
#13 0x00000034d9d41dd0 in KJob::emitResult (this=0x3e19e50) at /usr/src/debug/kdelibs-4.7.4/kdecore/jobs/kjob.cpp:312
#14 0x00000034d7d91f16 in QObject::event (this=0x3e19e50, e=<optimized out>) at kernel/qobject.cpp:1195
#15 0x00000034d8fc9994 in notify_helper (e=0x2d4cb30, receiver=0x3e19e50, this=0xb8dde0) at kernel/qapplication.cpp:4550
#16 QApplicationPrivate::notify_helper (this=0xb8dde0, receiver=0x3e19e50, e=0x2d4cb30) at kernel/qapplication.cpp:4522
#17 0x00000034d8fce813 in QApplication::notify (this=0x7fff425983d0, receiver=0x3e19e50, e=0x2d4cb30) at kernel/qapplication.cpp:4411
#18 0x00000034db050766 in KApplication::notify (this=0x7fff425983d0, receiver=0x3e19e50, event=0x2d4cb30) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#19 0x00000034d7d7904c in QCoreApplication::notifyInternal (this=0x7fff425983d0, receiver=0x3e19e50, event=0x2d4cb30) at kernel/qcoreapplication.cpp:876
#20 0x00000034d7d7cada in sendEvent (event=0x2d4cb30, receiver=0x3e19e50) at kernel/qcoreapplication.h:231
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xb46210) at kernel/qcoreapplication.cpp:1500
#22 0x00000034d7da7933 in sendPostedEvents () at kernel/qcoreapplication.h:236
#23 postEventSourceDispatch (s=0xb964f0) at kernel/qeventdispatcher_glib.cpp:279
#24 0x00000034f9a44acd in g_main_dispatch (context=0xb96400) at gmain.c:2441
#25 g_main_context_dispatch (context=0xb96400) at gmain.c:3011
#26 0x00000034f9a452c8 in g_main_context_iterate (context=0xb96400, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3089
#27 0x00000034f9a4549c in g_main_context_iteration (context=0xb96400, may_block=1) at gmain.c:3152
#28 0x00000034d7da7d5f in QEventDispatcherGlib::processEvents (this=0xb47af0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#29 0x00000034d906c66e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#30 0x00000034d7d78182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x00000034d7d783d7 in QEventLoop::exec (this=0x7fff425982a0, flags=...) at kernel/qeventloop.cpp:204
#32 0x00000034d7d7cdd5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#33 0x0000000000402d23 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kdepim-4.7.4/kmail/main.cpp:145

Possible duplicates by query: bug 290184, bug 283680, bug 283619, bug 283593, bug 283364.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-03-30 13:33:37 UTC

*** This bug has been marked as a duplicate of bug 253031 ***