Bug 308691 - continious gmail imap segfault after suspend
Summary: continious gmail imap segfault after suspend
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.8
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-20 04:01 UTC by Belomir
Modified: 2012-11-08 06:58 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Belomir 2012-10-20 04:01:24 UTC
Application: akonadi_imap_resource (4.8)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.5.4-030504-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Ones I suspend my laptop and boot it again. Than even after reboot gmail imap resource crashes. Another imap resource (mail.ru) doesn't crash. I suspended laptop earlier much—there were no errors. Actually I'm mot shure this is related to suspend, but something gets error.

My gmail  imap resource used by kolab throu akonadi and googledata and gcal resources are present too.

-- Backtrace:
Application: sergius.frassei@gmail.com of type Почтовый сервер IMAP (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd01b877780 (LWP 2949))]

Thread 2 (Thread 0x7fd0087ce700 (LWP 2951)):
#0  0x00007fd01720c403 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fd015d57036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd015d57164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd01ac8c426 in QEventDispatcherGlib::processEvents (this=0x7fd0000008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fd01ac5bc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fd01ac5bed7 in QEventLoop::exec (this=0x7fd0087cdde0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fd01ab5afa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fd019890c39 in KIMAP::SessionThread::run (this=0x167d950) at ../../kimap/sessionthread.cpp:181
#8  0x00007fd01ab5dfcb in QThreadPrivate::start (arg=0x167d950) at thread/qthread_unix.cpp:298
#9  0x00007fd016872e9a in start_thread (arg=0x7fd0087ce700) at pthread_create.c:308
#10 0x00007fd017217dbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd01b877780 (LWP 2949)):
[KCrash Handler]
#6  QSharedDataPointer (o=..., this=0x7fffaa5e8dc0) at /usr/include/qt4/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at ../../akonadi/entity.cpp:49
#8  0x00007fd01b2a9cc4 in Akonadi::Entity::Entity (this=0x7fffaa5e8e20, other=...) at ../../akonadi/entity.cpp:56
#9  0x000000000041986f in ImapResource::onIdleCollectionFetchDone (this=0x15ae620, job=0x16801a0) at ../../../resources/imap/imapresource.cpp:513
#10 0x00007fd01ac71281 in QMetaObject::activate (sender=0x16801a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffaa5e9000) at kernel/qobject.cpp:3547
#11 0x00007fd017b2c152 in KJob::result (this=<optimized out>, _t1=0x16801a0) at ./kjob.moc:208
#12 0x00007fd017b2c190 in KJob::emitResult (this=0x16801a0) at ../../kdecore/jobs/kjob.cpp:318
#13 0x00007fd01ac76446 in QObject::event (this=0x16801a0, e=<optimized out>) at kernel/qobject.cpp:1195
#14 0x00007fd019fdf894 in notify_helper (e=0x1680310, receiver=0x16801a0, this=0x148f7c0) at kernel/qapplication.cpp:4559
#15 QApplicationPrivate::notify_helper (this=0x148f7c0, receiver=0x16801a0, e=0x1680310) at kernel/qapplication.cpp:4531
#16 0x00007fd019fe4713 in QApplication::notify (this=0x7fffaa5e99a0, receiver=0x16801a0, e=0x1680310) at kernel/qapplication.cpp:4420
#17 0x00007fd0181073f6 in KApplication::notify (this=0x7fffaa5e99a0, receiver=0x16801a0, event=0x1680310) at ../../kdeui/kernel/kapplication.cpp:311
#18 0x00007fd01ac5ce9c in QCoreApplication::notifyInternal (this=0x7fffaa5e99a0, receiver=0x16801a0, event=0x1680310) at kernel/qcoreapplication.cpp:876
#19 0x00007fd01ac60c6a in sendEvent (event=0x1680310, receiver=0x16801a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x145e4d0) at kernel/qcoreapplication.cpp:1500
#21 0x00007fd01ac8bf93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#22 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#23 0x00007fd015d56d53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fd015d570a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007fd015d57164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fd01ac8c3bf in QEventDispatcherGlib::processEvents (this=0x145fcb0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#27 0x00007fd01a087d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007fd01ac5bc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007fd01ac5bed7 in QEventLoop::exec (this=0x7fffaa5e9920, flags=...) at kernel/qeventloop.cpp:204
#30 0x00007fd01ac60f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#31 0x00007fd01b38b326 in Akonadi::ResourceBase::init (r=0x15ae620) at ../../akonadi/resourcebase.cpp:412
#32 0x000000000041a996 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:188
#33 0x00007fd01714576d in __libc_start_main (main=0x4151c0 <main(int, char**)>, argc=3, ubp_av=0x7fffaa5e9ab8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffaa5e9aa8) at libc-start.c:226
#34 0x0000000000415375 in _start ()

This bug may be a duplicate of or related to bug 253031.

Possible duplicates by query: bug 308070, bug 306740, bug 301647, bug 301110, bug 299330.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-11-08 06:58:01 UTC

*** This bug has been marked as a duplicate of bug 253031 ***