Bug 290134 - The imap resource crashes all the time
Summary: The imap resource crashes all the time
Status: RESOLVED DUPLICATE of bug 253031
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 4.8
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-29 22:56 UTC by Christoph Bartoschek
Modified: 2012-01-02 13:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Bartoschek 2011-12-29 22:56:13 UTC
Version:           4.8 (using Devel) 
OS:                Linux

After adding an imap resource and waiting for some minutes the imap resource started to crash. The traceback is:

Application: IMAP-Konto 1 vom Typ IMAP-E-Mail-Server (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f7f02dd1760 (LWP 6325))]

Thread 2 (Thread 0x7f7ef1ce4700 (LWP 6330)):
#0  0x00007f7efe00511f in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007f7efd096b43 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f7efd096f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f7f021ed946 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007f7f021bd672 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f7f021bd8c7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f7f020be537 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007f7f00de0fc3 in ?? () from /usr/lib64/libkimap.so.4
#8  0x00007f7f020c155b in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f7efe001f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f7efe74d53d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f7f02dd1760 (LWP 6325)):
[KCrash Handler]
#6  QSharedDataPointer (o=..., this=0x7fff63e62ab0) at /usr/include/QtCore/qshareddata.h:93
#7  assignEntityPrivate (one=..., other=...) at /usr/src/debug/kdepimlibs-4.7.95/akonadi/entity.cpp:49
#8  0x00007f7f02812534 in Akonadi::Entity::Entity (this=0x7fff63e62b10, other=<optimized out>) at /usr/src/debug/kdepimlibs-4.7.95/akonadi/entity.cpp:56
#9  0x000000000041aa8f in _start ()


Reproducible: Didn't try

Steps to Reproduce:
Don't know how to reproduce. But after the error occurs it happens all the time.

Actual Results:  
A crash

Expected Results:  
No crash.
Comment 1 Christophe Marin 2012-01-02 13:49:23 UTC

*** This bug has been marked as a duplicate of bug 253031 ***